Registration not possible

Reported by Hachmann on 2012-02-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openclipart
Critical
Jakub Jankiewicz

Bug Description

Maybe this is only a temporary problem, but a friend of mine who tried to register for OCAL couldn't proceed after filling out all fields in the registration form. The "Sign in" button doesn't do anything (in Firefox and Chrome).

Hachmann (marenhachmann) wrote :

Registering doesn't work until today.

Jakub Jankiewicz (jcubic) wrote :

You mean he still can't register? We have this bug that don't allow to comment or upload clipart but only few people notice that (Including me), I will fix it as soon as possible, I haven't time to check it you yet.

Sorry for inconvenience, we will work on this ASAP.

Hello Jakub,

yes, it doesn't work, he can fill in the registration form and enter the captcha, but when he clicks on "sign up" nothing happens. We tried on different computers and different browsers.

If you click on "Sign up" when nothing is filled in, the fields move a little to the right and to the left, to indicate that you must fill something in. This part works.

Something else: It is rare that a password must be entered only once (like on OCAL), usually it is entered twice to check for misspellings.

Thanks for your work and your response,

 Maren (Moini)

--- On Mon, 2/13/12, Jakub Jankiewicz <email address hidden> wrote:

> From: Jakub Jankiewicz <email address hidden>
> Subject: [Bug 930621] Re: Registration not possible (Feb, 11 2012)
> To: <email address hidden>
> Date: Monday, February 13, 2012, 9:20 AM
> You mean he still can't register? We
> have this bug that don't allow to
> comment or upload clipart but only few people notice that
> (Including
> me), I will fix it as soon as possible, I haven't time to
> check it you
> yet.
>
> Sorry for inconvenience, we will work on this ASAP.
>
> --
> You received this bug notification because you are
> subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/930621
>
> Title:
>   Registration not possible (Feb, 11 2012)
>
> Status in openclipart:
>   New
>
> Bug description:
>   Maybe this is only a temporary problem, but a friend
> of mine who tried
>   to register for OCAL couldn't proceed after filling
> out all fields in
>   the registration form. The "Sign in" button doesn't
> do anything (in
>   Firefox and Chrome).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions
>

Jakub Jankiewicz (jcubic) wrote :

On Tue, 14 Feb 2012 12:37:29 -0000
Hachmann <email address hidden> wrote:

> Hello Jakub,
>
> yes, it doesn't work, he can fill in the registration form and enter
> the captcha, but when he clicks on "sign up" nothing happens. We
> tried on different computers and different browsers.

If different browsers and computers that maybe it doesn't work at all.
When I change that form to use captcha and code from open font library
it was working. I will check it out.

>
> If you click on "Sign up" when nothing is filled in, the fields move a
> little to the right and to the left, to indicate that you must fill
> something in. This part works.
>
> Something else: It is rare that a password must be entered only once
> (like on OCAL), usually it is entered twice to check for misspellings.

Some site already figure it out that small number of fields is better
and use one password field instead of two. Some sites have even only 2
fields in registration form email and password and the only indication
that this is not login form is button or header.

>
> Thanks for your work and your response,
>
> Maren (Moini)
>
> --- On Mon, 2/13/12, Jakub Jankiewicz <email address hidden>
> wrote:
>
> > From: Jakub Jankiewicz <email address hidden>
> > Subject: [Bug 930621] Re: Registration not possible (Feb, 11 2012)
> > To: <email address hidden>
> > Date: Monday, February 13, 2012, 9:20 AM
> > You mean he still can't register? We
> > have this bug that don't allow to
> > comment or upload clipart but only few people notice that
> > (Including
> > me), I will fix it as soon as possible, I haven't time to
> > check it you
> > yet.
> >
> > Sorry for inconvenience, we will work on this ASAP.
> >
> > --
> > You received this bug notification because you are
> > subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/930621
> >
> > Title:
> >   Registration not possible (Feb, 11 2012)
> >
> > Status in openclipart:
> >   New
> >
> > Bug description:
> >   Maybe this is only a temporary problem, but a friend
> > of mine who tried
> >   to register for OCAL couldn't proceed after filling
> > out all fields in
> >   the registration form. The "Sign in" button doesn't
> > do anything (in
> >   Firefox and Chrome).
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions
> >
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

Hello Jakub,

Can you check with your database if there have been any new registrations lately?

Greetings,
 Moini

Jakub Jankiewicz (jcubic) wrote :

There is no info about registration only first login

mysql> select username, first_login from aiki_users order by first_login desc limit 10;
+----------------+---------------------+
| username       | first_login         |
+----------------+---------------------+
| wes_h          | 2012-01-14 03:24:31 |
| chuckchuckone  | 2012-01-14 00:15:48 |
| JamesDP        | 2012-01-13 21:48:47 |
| pillometer1993 | 2012-01-13 16:57:35 |
| june43         | 2012-01-13 16:17:02 |
| Terje          | 2012-01-13 13:08:14 |
| amimarten      | 2012-01-13 12:10:36 |
| vip333         | 2012-01-13 11:00:36 |
| vip777         | 2012-01-13 10:58:07 |
| adruki         | 2012-01-13 10:39:29 |
+----------------+---------------------+

Changed in openclipart:
importance: Undecided → Critical
milestone: none → 3.2
assignee: nobody → Jakub Jankiewicz (jcubic)
Jakub Jankiewicz (jcubic) wrote :

User <Michael Finch> add this as a question:

>>>>>

I tried registering on openclipart.org to upload some artwork using the form on http://openclipart.org/register

If any of the fields are empty, and the "Sign Up" button is clicked, the empty field will be animated and outlined in red. But once all the fields are filled out and the recaptcha field filled out, the "Sign Up" button appears to do nothing.

As a last-ditch effort I disabled javascript on the page and was able to submit the form and register. But I thought I'd fill this out anyway to give you guys a heads up. :)

>>>>>

so it's a bug in JavaScript

rejon (rejon) wrote :

Shit, this is pretty bad! How can be fixed?

Changed in openclipart:
status: New → Confirmed
Jakub Jankiewicz (jcubic) wrote :

Check again that query, Shit, no new registration.

It seams that there was wrong API key for recaptcha, but now recaptcha suks, it don't allow to register.

Even if I put right captcha I've got { "status": "0", "message": "The reCAPTCHA was entered incorrectly." }, I'm removin recaptcha becuase it's sux, I'll use http://www.picatcha.com/

wait, before start down that path let's find the right api key.

I just created one and sending to you.

Jon

On Wed, Mar 7, 2012 at 10:28 PM, Jakub Jankiewicz
<email address hidden> wrote:
> Check again that query, Shit, no new registration.
>
> It seams that there was wrong API key for recaptcha, but now recaptcha
> suks, it don't allow to register.
>
> Even if I put right captcha I've got { "status": "0", "message": "The
> reCAPTCHA was entered incorrectly." }, I'm removin recaptcha becuase
> it's sux, I'll use http://www.picatcha.com/
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/930621
>
> Title:
>  Registration not possible (Feb, 11 2012)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Jakub Jankiewicz (jcubic) wrote :

The API key was ok, I've got error that captcha was entered invalid, I
change to picatcha and I've got the same error, I enter captcha
correctly and get error that it was incorrect.

On Wed, 07 Mar 2012 14:44:35 -0000
rejon <email address hidden> wrote:

> wait, before start down that path let's find the right api key.
>
> I just created one and sending to you.
>
> Jon
>
> On Wed, Mar 7, 2012 at 10:28 PM, Jakub Jankiewicz
> <email address hidden> wrote:
> > Check again that query, Shit, no new registration.
> >
> > It seams that there was wrong API key for recaptcha, but now
> > recaptcha suks, it don't allow to register.
> >
> > Even if I put right captcha I've got { "status": "0", "message":
> > "The reCAPTCHA was entered incorrectly." }, I'm removin recaptcha
> > becuase it's sux, I'll use http://www.picatcha.com/
> >
> > --
> > You received this bug notification because you are a member of
> > openclipart.devel, which is subscribed to openclipart.
> > https://bugs.launchpad.net/bugs/930621
> >
> > Title:
> >  Registration not possible (Feb, 11 2012)
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

Can we remove the recaptcha from the live site & work on a fix using the dev site in order to allow new registrants, for the time being?

Yes, that is what we should do. Jakub can you do this? This has gone
on too long, we are loosing traffic!

Jon

On Mon, Mar 12, 2012 at 9:09 AM, Brad Phillips
<email address hidden> wrote:
> Can we remove the recaptcha from the live site & work on a fix using the
> dev site in order to allow new registrants, for the time being?
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/930621
>
> Title:
>  Registration not possible (Feb, 11 2012)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

I am still getting this error.

Yes I know I try to change the captcha code but this one don't work for
unknown reason too. I will remove it and then test it somewere else so
users will be able to register just like when registration was on old
server.

BTW: I add captcha because current registration on OCAL doesn't
work and that was code work on OFLB and sharism sites.

Sorry that it take so long to fix. I will fix it ASAP.

On Mon, 12 Mar 2012 20:44:42 -0000
Jim Oblak <email address hidden> wrote:

> I am still getting this error.
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) wrote :

Did you get this fixed? Please focus on this. I need you to get
dev.openclipart.org upgraded and work there after this.

Jon

On Tue, Mar 13, 2012 at 5:54 AM, Jakub Jankiewicz
<email address hidden> wrote:
> Yes I know I try to change the captcha code but this one don't work for
> unknown reason too. I will remove it and then test it somewere else so
> users will be able to register just like when registration was on old
> server.
>
> BTW: I add captcha because current registration on OCAL doesn't
> work and that was code work on OFLB and sharism sites.
>
> Sorry that it take so long to fix. I will fix it ASAP.
>
> On Mon, 12 Mar 2012 20:44:42 -0000
> Jim Oblak <email address hidden> wrote:
>
>> I am still getting this error.
>>
>
> --
> Jakub Jankiewicz
> twitter: @jcubic
> www: http://jcubic.pl
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/930621
>
> Title:
>  Registration not possible (Feb, 11 2012)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Finaly fixed, it was Varnish issue, he cache php scripts in /assets folder.

Changed in openclipart:
status: Confirmed → Fix Committed
summary: - Registration not possible (Feb, 11 2012)
+ Registration not possible

great work, can you announce on the mailing list? still think good to
upgrade ocal

On Wed, Mar 14, 2012 at 10:27 PM, Jakub Jankiewicz
<email address hidden> wrote:
> Finaly fixed, it was Varnish issue, he cache php scripts in /assets
> folder.
>
> ** Changed in: openclipart
>       Status: Confirmed => Fix Committed
>
> ** Summary changed:
>
> - Registration not possible (Feb, 11 2012)
> + Registration not possible
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/930621
>
> Title:
>  Registration not possible
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Jakub Jankiewicz (jcubic) wrote :

Yes, we need it, I will work on that. I want to fix that
other bug (with upload) first or only find the reason why I can't
upload clipart.

On Wed, 14 Mar 2012 14:38:37 -0000
rejon <email address hidden> wrote:

> great work, can you announce on the mailing list? still think good to
> upgrade ocal
>
> On Wed, Mar 14, 2012 at 10:27 PM, Jakub Jankiewicz
> <email address hidden> wrote:
> > Finaly fixed, it was Varnish issue, he cache php scripts in /assets
> > folder.
> >
> > ** Changed in: openclipart
> >       Status: Confirmed => Fix Committed
> >
> > ** Summary changed:
> >
> > - Registration not possible (Feb, 11 2012)
> > + Registration not possible
> >
> > --
> > You received this bug notification because you are a member of
> > openclipart.devel, which is subscribed to openclipart.
> > https://bugs.launchpad.net/bugs/930621
> >
> > Title:
> >  Registration not possible
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/openclipart/+bug/930621/+subscriptions
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) on 2012-04-23
Changed in openclipart:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers