Comments mixed up

Reported by Gerald on 2011-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openclipart
Critical
Brad Phillips

Bug Description

Many clipart seem to have comments that were written for other clipart. They got mixed up at a release upgrade I believe at one point.

This is a list of some I've found in my clipart, which I will add to as I find more.

Gerald (jazzmanian) wrote :
Gerald (jazzmanian) wrote :

http://www.openclipart.org/detail/8544
http://www.openclipart.org/detail/8537
http://www.openclipart.org/detail/8536
http://www.openclipart.org/detail/8535
http://www.openclipart.org/detail/8526
http://www.openclipart.org/detail/8520
http://www.openclipart.org/detail/8512
http://www.openclipart.org/detail/8511
http://www.openclipart.org/detail/8508
http://www.openclipart.org/detail/8506
http://www.openclipart.org/detail/8503
http://www.openclipart.org/detail/8614
http://www.openclipart.org/detail/8613
http://www.openclipart.org/detail/8499
http://www.openclipart.org/detail/8611
http://www.openclipart.org/detail/8610
http://www.openclipart.org/detail/8581
http://www.openclipart.org/detail/8580
http://www.openclipart.org/detail/8556
http://www.openclipart.org/detail/8546
http://www.openclipart.org/detail/8823
http://www.openclipart.org/detail/8822
http://www.openclipart.org/detail/8820
http://www.openclipart.org/detail/8807
http://www.openclipart.org/detail/8806
http://www.openclipart.org/detail/8745
http://www.openclipart.org/detail/8951
http://www.openclipart.org/detail/8872
http://www.openclipart.org/detail/8870
http://www.openclipart.org/detail/8959
http://www.openclipart.org/detail/9120
http://www.openclipart.org/detail/9116
http://www.openclipart.org/detail/9108
http://www.openclipart.org/detail/9102
http://www.openclipart.org/detail/9093
http://www.openclipart.org/detail/9095
http://www.openclipart.org/detail/9094
http://www.openclipart.org/detail/9122
http://www.openclipart.org/detail/9193
http://www.openclipart.org/detail/9177

rejon (rejon) on 2011-04-11
Changed in openclipart:
assignee: nobody → Bassel Safadi (bassel)
milestone: none → 3.0
importance: Undecided → Critical
status: New → Confirmed
rejon (rejon) on 2011-04-27
Changed in openclipart:
assignee: Bassel Safadi (bassel) → Brad Phillips (brad-bradphillips)
Changed in openclipart:
status: Confirmed → In Progress

wow, what a PAIN..

So, the problem lies in the way comments are pulled into the clip art detail pages. The id for the clip art commented on is stored in 1 field called topic_upload. Rather than only comparing that value to a clip art id, though, the clipart detail page also checks to see if the value is equivalent to a field called 'file_upload'. I'm unsure of what this value is used for. Since recent uploads all have '0' as a value for the field, I can only assume it's a legacy field that was necessary in the past (perhaps it was a way to link png versions of svg files before the svg-to-png method existed in aiki).

Whatever it's use, those values are numbers, much like clipart ids, and, in some cases, those values are exactly the same as clipart ids. In those cases, the comments will be pulled into the wrong detail pages.

I went through each url in question, one-by-one & changed the 'topic_upload' field to reflect it's intended id (rather than a 'file_upload' reference) and the comments have been fixed.

Does anyone else know about the 'file_upload' field & what it's use is or was? I wonder if that field could be deleted or removed from the search sql?

Changed in openclipart:
status: In Progress → Fix Released

old cchost ghost - i am guessing. I don't know what it's for. Perhaps it was
a reference to a zip file upload that it came from? I've never seen it used
in this version of OCAL.

On Sun, May 1, 2011 at 10:10 PM, Brad Phillips <email address hidden>wrote:

> wow, what a PAIN..
>
> So, the problem lies in the way comments are pulled into the clip art
> detail pages. The id for the clip art commented on is stored in 1 field
> called topic_upload. Rather than only comparing that value to a clip
> art id, though, the clipart detail page also checks to see if the value
> is equivalent to a field called 'file_upload'. I'm unsure of what this
> value is used for. Since recent uploads all have '0' as a value for the
> field, I can only assume it's a legacy field that was necessary in the
> past (perhaps it was a way to link png versions of svg files before the
> svg-to-png method existed in aiki).
>
> Whatever it's use, those values are numbers, much like clipart ids, and,
> in some cases, those values are exactly the same as clipart ids. In
> those cases, the comments will be pulled into the wrong detail pages.
>
> I went through each url in question, one-by-one & changed the
> 'topic_upload' field to reflect it's intended id (rather than a
> 'file_upload' reference) and the comments have been fixed.
>
> Does anyone else know about the 'file_upload' field & what it's use is
> or was? I wonder if that field could be deleted or removed from the
> search sql?
>
> ** Changed in: openclipart
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719675
>
> Title:
> Comments mixed up
>
> Status in openclipart:
> Fix Released
>
> Bug description:
> Many clipart seem to have comments that were written for other
> clipart. They got mixed up at a release upgrade I believe at one
> point.
>
> This is a list of some I've found in my clipart, which I will add to
> as I find more.
>

--
Cheers
Chovynz

chovynz (chovynz) wrote :

Here's another one with a mixed up comment.
http://www.openclipart.org/detail/3839

>
> On Sun, May 1, 2011 at 10:10 PM, Brad Phillips <email address hidden>wrote:
>
>> wow, what a PAIN..
>>
>> So, the problem lies in the way comments are pulled into the clip art
>> detail pages. The id for the clip art commented on is stored in 1 field
>> called topic_upload. Rather than only comparing that value to a clip
>> art id, though, the clipart detail page also checks to see if the value
>> is equivalent to a field called 'file_upload'. I'm unsure of what this
>> value is used for. Since recent uploads all have '0' as a value for the
>> field, I can only assume it's a legacy field that was necessary in the
>> past (perhaps it was a way to link png versions of svg files before the
>> svg-to-png method existed in aiki).
>>
>> Whatever it's use, those values are numbers, much like clipart ids, and,
>> in some cases, those values are exactly the same as clipart ids. In
>> those cases, the comments will be pulled into the wrong detail pages.
>>
>> I went through each url in question, one-by-one & changed the
>> 'topic_upload' field to reflect it's intended id (rather than a
>> 'file_upload' reference) and the comments have been fixed.
>>
>> Does anyone else know about the 'file_upload' field & what it's use is
>> or was? I wonder if that field could be deleted or removed from the
>> search sql?
>>
>> ** Changed in: openclipart
>> Status: In Progress => Fix Released
>>
>> --
>> You received this bug notification because you are a member of
>> openclipart.devel, which is subscribed to openclipart.
>> https://bugs.launchpad.net/bugs/719675
>>
>> Title:
>> Comments mixed up
>>
>> Status in openclipart:
>> Fix Released
>>
>> Bug description:
>> Many clipart seem to have comments that were written for other
>> clipart. They got mixed up at a release upgrade I believe at one
>> point.
>>
>> This is a list of some I've found in my clipart, which I will add to
>> as I find more.
>>
>
>
>
> --
> Cheers
> Chovynz
>

--
Cheers
Chovynz

rejon (rejon) wrote :

sucks!

brad, did you fix the problem so the comments are linked properly?

thanks!

Jon

On Sun, May 1, 2011 at 6:22 AM, chovynz <email address hidden> wrote:
> Here's another one with a mixed up comment.
> http://www.openclipart.org/detail/3839
>
>
>>
>> On Sun, May 1, 2011 at 10:10 PM, Brad Phillips <email address hidden>wrote:
>>
>>> wow, what a PAIN..
>>>
>>> So, the problem lies in the way comments are pulled into the clip art
>>> detail pages.  The id for the clip art commented on is stored in 1 field
>>> called topic_upload.  Rather than only comparing that value to a clip
>>> art id, though, the clipart detail page also checks to see if the value
>>> is equivalent to a field called 'file_upload'.  I'm unsure of what this
>>> value is used for.  Since recent uploads all have '0' as a value for the
>>> field, I can only assume it's a legacy field that was necessary in the
>>> past (perhaps it was a way to link png versions of svg files before the
>>> svg-to-png method existed in aiki).
>>>
>>> Whatever it's use, those values are numbers, much like clipart ids, and,
>>> in some cases, those values are exactly the same as clipart ids.  In
>>> those cases, the comments will be pulled into the wrong detail pages.
>>>
>>> I went through each url in question, one-by-one & changed the
>>> 'topic_upload' field to reflect it's intended id (rather than a
>>> 'file_upload' reference) and the comments have been fixed.
>>>
>>> Does anyone else know about the 'file_upload' field & what it's use is
>>> or was?  I wonder if that field could be deleted or removed from the
>>> search sql?
>>>
>>> ** Changed in: openclipart
>>>       Status: In Progress => Fix Released
>>>
>>> --
>>> You received this bug notification because you are a member of
>>> openclipart.devel, which is subscribed to openclipart.
>>> https://bugs.launchpad.net/bugs/719675
>>>
>>> Title:
>>>  Comments mixed up
>>>
>>> Status in openclipart:
>>>   Fix Released
>>>
>>> Bug description:
>>>  Many clipart seem to have comments that were written for other
>>>  clipart. They got mixed up at a release upgrade I believe at one
>>>  point.
>>>
>>>  This is a list of some I've found in my clipart, which I will add to
>>>  as I find more.
>>>
>>
>>
>>
>> --
>> Cheers
>> Chovynz
>>
>
>
> --
> Cheers
> Chovynz
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719675
>
> Title:
>  Comments mixed up
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

Fixed the above comment. So, comments should always link to the file they're specified for. The problem is that some of those file ids are also equivalent to a field in the ocal_db called 'file_upload'.

I'm unclear of what this 'file_upload' field is or was used for, but it appears that all recent uploads are disregarding this field (getting values of 0). So, If I were to login now & make a comment on an older clipart (one that has a value set for the 'file_upload'), there's still a chance that that comment will be pulled into multiple clipart detail pages (it always will display on the intended detail page, though).

So, the best solution I can think of is to remove the check in the sql for equivalency in the 'file_upload' field & just check to see if the clipart id is equivalent. This should instantly eliminate comments showing up on incorrect detail pages.

I'll go ahead & put that in place & anyone who finds discrepancies post solution can post their issues here & I'll try & dig deeper to figure out what 'file_upload' is used for.

rejon (rejon) wrote :

On Sun, May 1, 2011 at 6:18 PM, Brad Phillips <email address hidden> wrote:
> Fixed the above comment.  So, comments should always link to the file
> they're specified for.  The problem is that some of those file ids are
> also equivalent to a field in the ocal_db called 'file_upload'.
>
> I'm unclear of what this 'file_upload' field is or was used for, but it
> appears that all recent uploads are disregarding this field (getting
> values of 0).  So, If I were to login now & make a comment on an older
> clipart (one that has a value set for the 'file_upload'), there's still
> a chance that that comment will be pulled into multiple clipart detail
> pages (it always will display on the intended detail page, though).
>
> So, the best solution I can think of is to remove the check in the sql
> for equivalency in the 'file_upload' field & just check to see if the
> clipart id is equivalent.  This should instantly eliminate comments
> showing up on incorrect detail pages.

Sounds good.

>
> I'll go ahead & put that in place & anyone who finds discrepancies post
> solution can post their issues here & I'll try & dig deeper to figure
> out what 'file_upload' is used for.

Totally...

Does that allow deleting some extra fields too?

Great work!

Jon

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

chovynz (chovynz) wrote :

I think these two bugs are either identical or related.
https://bugs.launchpad.net/openclipart/+bug/779317

You can find the clipart I'm tagging at
http://www.openclipart.org/tags/comment_problem
or
http://www.openclipart.org/search/?query=comment_problem (preferred)

Changed in openclipart:
status: Fix Released → Incomplete
Gerald (jazzmanian) wrote :

Awesome work!

I took a look at a large sample of these this morning, and the fix appears to be GOOD.

I wonder if there is a similar check being made in the remix code?

http://www.openclipart.org/detail/1777
http://www.openclipart.org/detail/1990
http://www.openclipart.org/detail/9207
http://www.openclipart.org/detail/9108
http://www.openclipart.org/detail/9102
http://www.openclipart.org/detail/9094

Notice the mixed up nature of these remixes is similar to the mixed up comments.

Gerald (jazzmanian) wrote :

http://www.openclipart.org/detail/8258

Still looks odd to me. the word "Caslte" has never been associated with this clip.

chovynz (chovynz) wrote :

Hi Gerald

Are you able to add to the tags on your own clipart?
Use remix_problem for remix problems (like the remix and original clipart
mixups that you see on 8258)
Use comment_problem for clipart that have weird comments on them.

Please remember to end the tag list in a comma.

The two are similar issues where an id is getting mixed up, but they
(probably) won't be solved by the same solution. It's helpful for us to have
both tags while we sort this out.

On Wed, May 11, 2011 at 5:08 AM, Gerald <email address hidden> wrote:

> http://www.openclipart.org/detail/8258
>
> Still looks odd to me. the word "Caslte" has never been associated with
> this clip.
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719675
>
> Title:
> Comments mixed up
>
> Status in openclipart:
> Incomplete
>
> Bug description:
> Many clipart seem to have comments that were written for other
> clipart. They got mixed up at a release upgrade I believe at one
> point.
>
> This is a list of some I've found in my clipart, which I will add to
> as I find more.
>

--
Cheers
Chovynz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers