Copyright Claim made

Reported by Gerald on 2011-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openclipart
Critical
Brad Phillips
rejon (rejon) on 2011-02-15
Changed in openclipart:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 3.0
rejon (rejon) wrote :

you mean these need to be deleted Gerald? Can you help us with that?

Gerald (jazzmanian) wrote :

I mean more than "they need to be deleted".

Yes they need to be deleted, (I believe) but before they are, someone needs to form a COMPLETE list of all the files that have this claim made by Mearle Gates.

Since there is apparently no way so search for all comments by a specific user, I can offer no solution here.

And also I cannot delete, as I am not a librarian.

Gerald, do you want to be? (:

rejon (rejon) wrote :

Yeah, we need you gerald!!!!

On Sat, Feb 19, 2011 at 1:39 AM, Oleg Koptev <email address hidden> wrote:
> Gerald, do you want to be? (:
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719607
>
> Title:
>  Copyright Claim made
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)

chovynz (chovynz) wrote :

http://www.openclipart.org/searchcomments/?query=anabel4you

Ok, I've made a first step towards dealing with spam and other troublesome comments.
Generic search tool for comments.

    * Will search username and comment for [query]
    * Will display comments that have [query] in a table.
    * Pagination is broken due to another bug, but pagination IS actually activated on this search.
    * Results are limited to 50.
    * Only Librarians can see / use this page.
    * At this stage, this will only display, but I plan on making user actions for when a librarian needs to hide the comment or to edit the comments if need be.
    * It's probably would benefit from some css styling.
    * Footer screwed up the page, so I removed it from showing up on this page.

Pity I can't do /search/comments, instead of creating an entirely different url (/searchcomments). When I placed this page under /search/comments, the cliparts matching [query] also displayed in the standard search view, which is not what I wanted. Kill URL's search didn't work. It works downline, but not upline.

There is currently no tool to edit / hide comments. I'll work on that next.

chovynz (chovynz) wrote :

You can also use this tool to search, for example, for Mearle Gates, which will return all comments that has that name in them.

chovynz (chovynz) wrote :

Just to head of Jon enthusiastic button pushing, ;)
This bug is not complete, since we don't yet have a full list of clipart that is affected.

rejon (rejon) on 2011-04-27
Changed in openclipart:
assignee: nobody → Brad Phillips (brad-bradphillips)

Ok, I've done a search for 'Mearle Gates', using Chovynz' searchcomments tool & have removed the following cliparts (along with the above initially mentioned cliparts).

Snail 02, Walrus 2, Seal, Polar Bear, Mountain Lion, Koala, Kangaroo 2, Ground Squirell, Elephant 2, Donkey 2, Giraffe 2, Dolphin 3, Deer 3, Deer 6, Chipmunk, Camel 1, Bison 1, Beaver, Bear 3, Armadillo 1, Ape 1, Animal 12, Animal 9, Animal 7, Animal 4, Animal 2, Bird 01, Bird 02, Bird 04, Bird 06, Bird 08, Bird 11, Bird 15, Bird 20, Bird 22, Bird 27, Bird 31, Bird 32, Bird 34, Bird 40, Bird 44, Bird 57, Bird 63, Bird 36, Bird 43, Bird 67, Bird 69, windmill 01, windmill 03, cat with string, cat with mouse, hand 25, phone 13, fire 14, fire 13, lobster 01, seashell 02, seashell 03, seashell 04, seashell 05, seashell 06, seashell 07, starfish 01, meat 02, vegetables 18, money 18, money 02, insect 02, insect 03, insect 21, insect 22, insect 23, insect 25, insect 26, insect 27, insect 28, insect 31, Pig 02, Sheep 04, Sheep (Ewe), Pig 2

The first major test for the Manage section of the 'Action Bar' is a success!

Changed in openclipart:
status: Confirmed → Fix Released
chovynz (chovynz) wrote :

awesome. well done.

is librarian action tracking enabled?

On Sun, May 1, 2011 at 11:29 AM, Brad Phillips <email address hidden>wrote:

> Ok, I've done a search for 'Mearle Gates', using Chovynz' searchcomments
> tool & have removed the following cliparts (along with the above
> initially mentioned cliparts).
>
> Snail 02, Walrus 2, Seal, Polar Bear, Mountain Lion, Koala, Kangaroo 2,
> Ground Squirell, Elephant 2, Donkey 2, Giraffe 2, Dolphin 3, Deer 3,
> Deer 6, Chipmunk, Camel 1, Bison 1, Beaver, Bear 3, Armadillo 1, Ape 1,
> Animal 12, Animal 9, Animal 7, Animal 4, Animal 2, Bird 01, Bird 02,
> Bird 04, Bird 06, Bird 08, Bird 11, Bird 15, Bird 20, Bird 22, Bird 27,
> Bird 31, Bird 32, Bird 34, Bird 40, Bird 44, Bird 57, Bird 63, Bird 36,
> Bird 43, Bird 67, Bird 69, windmill 01, windmill 03, cat with string,
> cat with mouse, hand 25, phone 13, fire 14, fire 13, lobster 01,
> seashell 02, seashell 03, seashell 04, seashell 05, seashell 06,
> seashell 07, starfish 01, meat 02, vegetables 18, money 18, money 02,
> insect 02, insect 03, insect 21, insect 22, insect 23, insect 25, insect
> 26, insect 27, insect 28, insect 31, Pig 02, Sheep 04, Sheep (Ewe), Pig
> 2
>
> The first major test for the Manage section of the 'Action Bar' is a
> success!
>
> ** Changed in: openclipart
> Status: Confirmed => Fix Released
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719607
>
> Title:
> Copyright Claim made
>
> Status in openclipart:
> Fix Released
>
> Bug description:
> The following clips have been reported as not-PD in the comments under
> each image.
> Someone needs to find all comments made to ArtFavor or by the user "Mearle
> Gates" to ensure that all are dealt with.
>
> The following list is not complete.
>
> http://www.openclipart.org/detail/41023
> http://www.openclipart.org/detail/41365
> http://www.openclipart.org/detail/41347
> http://www.openclipart.org/detail/41335
> http://www.openclipart.org/detail/41329
> http://www.openclipart.org/detail/41317
> http://www.openclipart.org/detail/41311
> http://www.openclipart.org/detail/41305
> http://www.openclipart.org/detail/41299
> http://www.openclipart.org/detail/41287
> http://www.openclipart.org/detail/41281
> http://www.openclipart.org/detail/43009
> http://www.openclipart.org/detail/42937
> http://www.openclipart.org/detail/42919
>
> Comment:
> This is a pirated copy of clipart belonging to Totem Graphics Inc. You can
> see the original at
> http://www.gototem.com/wordpress/clip-art-sales/domestic-animals/ Please
> remove this from your site!
>

--
Cheers
Chovynz

rejon (rejon) wrote :

On Sat, Apr 30, 2011 at 10:54 PM, chovynz <email address hidden> wrote:
> awesome. well done.
>
> is librarian action tracking enabled?

Can you explain this more?

Cheers

chovynz (chovynz) wrote :

As in does ocal record the actions of a logged in user? I think this is
especially important if we are going to get librarians upwards of 10 people.
If something stuffs up we know who to ask to fix it. Alternatively : if one
of us abuses "teh powas", that will be plain too and can be dealt with
accordingly.

Yes trust is good, but so is a good record. This'll bring in accountability
to each other. IMHO anyway.

I'm wanting to know if it's going to record my actions of deleting a
comment, instead of the comments just disappearing.

On Sun, May 1, 2011 at 4:44 PM, rejon <email address hidden> wrote:

> On Sat, Apr 30, 2011 at 10:54 PM, chovynz <email address hidden>
> wrote:
> > awesome. well done.
> >
> > is librarian action tracking enabled?
>
> Can you explain this more?
>
> Cheers
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719607
>
> Title:
> Copyright Claim made
>
> Status in openclipart:
> Fix Released
>
> Bug description:
> The following clips have been reported as not-PD in the comments under
> each image.
> Someone needs to find all comments made to ArtFavor or by the user "Mearle
> Gates" to ensure that all are dealt with.
>
> The following list is not complete.
>
> http://www.openclipart.org/detail/41023
> http://www.openclipart.org/detail/41365
> http://www.openclipart.org/detail/41347
> http://www.openclipart.org/detail/41335
> http://www.openclipart.org/detail/41329
> http://www.openclipart.org/detail/41317
> http://www.openclipart.org/detail/41311
> http://www.openclipart.org/detail/41305
> http://www.openclipart.org/detail/41299
> http://www.openclipart.org/detail/41287
> http://www.openclipart.org/detail/41281
> http://www.openclipart.org/detail/43009
> http://www.openclipart.org/detail/42937
> http://www.openclipart.org/detail/42919
>
> Comment:
> This is a pirated copy of clipart belonging to Totem Graphics Inc. You can
> see the original at
> http://www.gototem.com/wordpress/clip-art-sales/domestic-animals/ Please
> remove this from your site!
>

--
Cheers
Chovynz

I agree on this, and I think we had discussed a notifications table that would update whenever admin actions take place (or anything deemed necessary for recording, like user account settings adjustments, etc). There probably should be a blueprint filled out for this feature, as it's pretty extensive & not yet mapped out.

Everyone agree?

rejon (rejon) wrote :

Yes great!

<email address hidden>
http://fabricatorz.com
On May 1, 2011 1:25 AM, "Brad Phillips" <email address hidden> wrote:
> I agree on this, and I think we had discussed a notifications table that
> would update whenever admin actions take place (or anything deemed
> necessary for recording, like user account settings adjustments, etc).
> There probably should be a blueprint filled out for this feature, as
> it's pretty extensive & not yet mapped out.
>
> Everyone agree?
>
> --
> You received this bug notification because you are a member of
> openclipart.devel, which is subscribed to openclipart.
> https://bugs.launchpad.net/bugs/719607
>
> Title:
> Copyright Claim made

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers