underscores and spaces in tags - descriptive tags instead of abbreviations

Reported by chovynz on 2010-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openclipart
High
Roan

Bug Description

As per mailing list

Task #2b : Now that spaces are acceptable for tags, can we please change tags such as "b_w" to "black and white" or "black & white"? Self explanatory names seem better in the long run than shortened abbreviations that might not make sense. (I suggest that this would more affect those who use the site but choose not to register.)

rejon (rejon) wrote :

Ok, people can do this manually or someone can write a tool in aiki to clean up the entire list. Any other thoughts?

Changed in openclipart:
status: New → Confirmed
importance: Undecided → Wishlist
tags: added: wishlist
Leandro Gómez (leogg) wrote :

I'm assigning this task to myself.

Changed in openclipart:
assignee: nobody → Leandro Gómez (leogg)
rejon (rejon) on 2010-11-23
Changed in openclipart:
milestone: none → 2.8
Leandro Gómez (leogg) on 2010-11-23
Changed in openclipart:
status: Confirmed → In Progress
rejon (rejon) wrote :

are you changing them all??? geez! how far ar eyou?

Changed in openclipart:
milestone: 2.8 → 2.9
rejon (rejon) wrote :

how is this going? Can this be closed?

Changed in openclipart:
importance: Wishlist → Medium
Bassel Safadi (bassel) wrote :

ok let me finish this in automated job, I'll post those bot jobs to the librarians page

Changed in openclipart:
importance: Medium → High
assignee: Leandro Gómez (leogg) → Bassel Safadi (bassel)
rejon (rejon) wrote :

when?

Bassel Safadi (bassel) on 2011-02-15
Changed in openclipart:
milestone: 2.9 → 3.0
rejon (rejon) on 2011-04-09
Changed in openclipart:
milestone: 3.0 → 3.1
rejon (rejon) on 2011-05-09
Changed in openclipart:
assignee: Bassel Safadi (bassel) → Roan (roan)
Roan (roan) wrote :

standardized on: black and white

added 'black and white' tag to any taglist that contained 'b_w' tag and did not also have 'black and white' tag.
removed all 'b_w' tags

It looks like tags which used to have an underscore character in place of an apostrophe have been converted. Are their any other special cases where an underscore is being used to represent another character other than the space character?

If not I can do a global replace of the underscore character to the space character.

"If not I can do a global replace of the underscore character to the
space character."

Please do this if it is not too much trouble. Are you on IRC? or some other
IM?

On Wed, May 11, 2011 at 2:28 PM, Roan <email address hidden> wrote:

> standardized on: black and white
>
> added 'black and white' tag to any taglist that contained 'b_w' tag and did
> not also have 'black and white' tag.
> removed all 'b_w' tags
>
> It looks like tags which used to have an underscore character in place
> of an apostrophe have been converted. Are their any other special cases
> where an underscore is being used to represent another character other
> than the space character?
>
> If not I can do a global replace of the underscore character to the
> space character.
>
>

chovynz (chovynz) wrote :

At developers :
Do we have an auto tag converter?
i.e. if someone types in b_w in their tag list, it will convert that to
black and white?
And can we add to this list?

On Wed, May 11, 2011 at 2:48 PM, chovynz <email address hidden> wrote:

> "If not I can do a global replace of the underscore character to the
> space character."
>
> Please do this if it is not too much trouble. Are you on IRC? or some other
> IM?
>
>
> On Wed, May 11, 2011 at 2:28 PM, Roan <email address hidden> wrote:
>
>> standardized on: black and white
>>
>> added 'black and white' tag to any taglist that contained 'b_w' tag and
>> did not also have 'black and white' tag.
>> removed all 'b_w' tags
>>
>> It looks like tags which used to have an underscore character in place
>> of an apostrophe have been converted. Are their any other special cases
>> where an underscore is being used to represent another character other
>> than the space character?
>>
>> If not I can do a global replace of the underscore character to the
>> space character.
>>
>>

--
Cheers
Chovynz

Roan (roan) wrote :

My nick in IRC is justjohnny68 or justjohnny681 (if I forget to log off when I leave home)

I am not aware of any current filter to automatically convert 'b_w' to 'black and white' when a person enters their tag list. This could be added through javascript relatively easily.

I will do the underscore to space conversion a little later today

Roan (roan) wrote :

have replaced all underscore characters in upload_tags column of the ocal_files table and the tags_tag column of the cc_tbl_tags tagble:

update ocal_tables set upload_tags = replace(upload_tags, '_', ' ') where upload_tags like '%\_%';
 update cc_tbl_tags set tags_tag = replace(tags_tag, '_', ' ') where tags_tag like '%\_%';

Changed in openclipart:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers