unity-singlet from one hundred scopes PPA conflicts with (newer) python-unity-singlet form precise archive

Reported by Scott Sweeny on 2012-04-25
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
One Hundred Scopes
Undecided
Michael Hall

Bug Description

Unpacking unity-singlet (from .../unity-singlet_0.2.1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/unity-singlet_0.2.1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/singlet/utils.py', which is also in package python-unity-singlet 0.2.2-ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/unity-singlet_0.2.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It appears that there are newer versions of some of these packages in precise under different names. In addition to unity-singlet vs. python-unity-singlet I also spotted quickly-lens-templates (PPA) vs. quickly-unity-lens-template (precise).

David Callé (davidc3) on 2012-04-25
Changed in onehundredscopes:
assignee: nobody → Michael Hall (mhall119)
Terry Barton (tdorl) wrote :

So this appears to be the exact problem I'm having, Now if someone could tell me what I need to do in order to fix my package manager I would appreciate it. Thanks in advance.

Matt Fischer (mfisch) wrote :

I think we need to remove the package from the scopes packagers archive. Let's see what Michael says.

David Callé (davidc3) wrote :

Package removed to fix the conflict.

Changed in onehundredscopes:
status: New → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers