Onboard crashes since last update

Bug #933030 reported by burli on 2012-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
High
Unassigned

Bug Description

Since the last update Onboard crashes. Revision 751

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/Onboard/OnboardGtk.py", line 90, in do_activate
    self.init()
  File "/usr/lib/python2.7/dist-packages/Onboard/OnboardGtk.py", line 105, in init
    config.init()
  File "/usr/lib/python2.7/dist-packages/Onboard/Config.py", line 235, in init
    self.load_system_defaults(paths)
  File "/usr/lib/python2.7/dist-packages/Onboard/ConfigUtils.py", line 399, in load_system_defaults
    self._read_sysdef_section(parser)
  File "/usr/lib/python2.7/dist-packages/Onboard/Config.py", line 442, in _read_sysdef_section
    super(self.__class__, self)._read_sysdef_section(parser)
  File "/usr/lib/python2.7/dist-packages/Onboard/ConfigUtils.py", line 422, in _read_sysdef_section
    .format(sysdef, value))
UnicodeEncodeError: 'ascii' codec can't encode character u'\ue0ff' in position 0: ordinal not in range(128)

Related branches

marmuta (marmuta) wrote :

Thanks for the bug report. I can reproduce this with running
LANGUAGE=de onboard. I'l look into it.

As a workaround try running
LANGUAGE=en onboard

marmuta (marmuta) wrote :

Fixed in revision 756 in trunk and in branch 0.97.

Changed in onboard:
status: New → Fix Committed
importance: Undecided → High
marmuta (marmuta) wrote :

Marking as released. The fix went into the first 0.97 release at the last minute.

Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers