Onboard should provide an accessible description for its indicator.

Bug #891931 reported by Luke Yelavich on 2011-11-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Medium
Unassigned
onboard (Ubuntu)
Medium
Unassigned

Bug Description

 affects onboard

 affects ubuntu/onboard
 tag a11y

The indicator API now supports adding accessible/textual descriptions to indicators via the app_indicator_set_icon_full and app_indicator_set_attention_icon_full method calls. It would be good if onboard set an accessible/textual description of its indicator.

Related branches

marmuta (marmuta) on 2011-11-21
Changed in onboard:
status: New → Confirmed
importance: Undecided → Medium
marmuta (marmuta) wrote :

Thanks Luke, I've added a fix to trunk.

Changed in onboard:
status: Confirmed → Fix Committed

If not already done so, I think we should get this into Precise

Changed in onboard (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
marmuta (marmuta) wrote :

We're preparing a bug fix release 0.96.2 for Oneiric and Precise including this fix.

Martin Pitt (pitti) on 2011-11-30
Changed in onboard (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
status: New → Triaged
Changed in onboard (Ubuntu):
assignee: Luke Yelavich (themuso) → nobody
Francesco Fumanti (frafu) wrote :

Hello,

You can find a preview package for oneiric and precise containing the fix for this bug in the Onboard Snapshots PPA:
https://launchpad.net/~onboard/+archive/snapshots

In the case where you dare to test packages build from snapshots, please give us feedback here.

Moreover, if you see other bugs during your tests, please file them indicating in what package you found them.

Many thanks in advance.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.96.2-0ubuntu1

---------------
onboard (0.96.2-0ubuntu1) precise; urgency=low

    * Protect against accidental resize/move of Onboard window (LP: #893644)
    * Add option to always show on visible workspace (LP: #803875)
    * Give the AppIndicator an accessible description (LP: #891931)
    * Don't let compiz grid plugin resize the icon palette (LP: 893644)
    * Don't let the move button leave the screen (LP: 885608)
    * Reduce updates of gtk widget (LP: 897678)
    * Work around transparency state loss due to bug 837456
    * Fix resize cursor disapearing for north east window corner
    * Fix window corner issue in Unity on Ubuntu Precise
    * Fix Icon Palette flashing when unity-greeter is killed
    * Fix Unity 2D fighting with Onboard for the top spot
    * Fix missing super key label on distributions without the ubuntu logo
    * Fix almost invisible short feedback on keypress occuring on some notebooks
    * Don't shrink labels when the system font dpi changes
    * Don't ignore force-to-top mode when moving the window back into view
    * Hide move button when window decoration is enabled and force-to-top is off
    * Don't fail to start on older versions of gtk3 (3.0.11 on Mandriva 2011)
    * Prevent onboard getting stuck by grid plugin and gnome-shell
    * Fix middle and right click button for 0.95 legacy layouts
    * Don't crash gnome-shell when window state sticky is off
    * Make a newly created customized theme the active one
    * Stop intltool warnings about messages being hard to translate
    * Restore Authors file that was accidently deleted
    * Some cleanup, typo fixing, gui improvements and performance fixes
    * Merge oneiric translations from the 13-12-2011
    * debian/patches: add system defaults file with values for Unity
 -- Francesco Fumanti <email address hidden> Tue, 13 Dec 2011 21:01:07 +0100

Changed in onboard (Ubuntu):
status: Triaged → Fix Released
marmuta (marmuta) on 2012-01-02
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers