Onboard does not keep previous position and size after a hide and show

Bug #819971 reported by Francesco Fumanti on 2011-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned

Bug Description

Comment 2 of https://answers.launchpad.net/onboard/+question/107509 says among others:

[quote]
Another nice thing would be able to lock the keyboard to a certain size and position on the screen. Whenever I try to resize it to make a row filling the bottom of the screen, after a hide and re-show it pops up near the middle of the screen, resized again.
[/quote]

There is another similar problem: I noticed that Onboard does not save its last position and size when the computer shuts down; however, it saves its last position and size when it the user manually quits Onboard.

Related branches

marmuta (marmuta) wrote :

Works here with trunk (probably 0.96 and up too). Could you retest this for the current version, Francesco?

About not saving the position on shutdown: I've seen this in the code and that behavior could be changed to saving more often. The only drawback I can see is, that running multiple instances of Onboard would then always sit on top of each other.
Is this accaptable?

Changed in onboard:
status: New → Incomplete
Francesco Fumanti (frafu) wrote :

I am not able to reproduce the behaviour described in the bug message by the lines between the quotes with onboard 0.96.2.

Concerning the behaviour of not saving on shutdown, but saving on quit: I forgot about it when I filed the bug; but I think it was done on purpose. In fact, around June 2010 (I just looked it up again), on shutdown, the system moved the Onboard window accross the screen, as if it was doing a shutdown animation. As Onboard used to save its position immediately after the move, the user position was lost by the shutdown animation (or whatever it was that produced the move).

If the code is going to be changed to save the position more often, it should perhaps also take such shutdown animations into account.

Francesco Fumanti (frafu) wrote :

So it seems that we have to choose between:
- save position also on shutdown
and
-ability to have to instances of Onboard at two different positions

If I put it this way, I would opt for the first, because I suppose that the circumstances where a user needs to run more than one instance of Onboard are probably quite rare.

But maybe that a third approach is possible to solve the problem...

marmuta (marmuta) wrote :

We could perhaps detect a running instance and skip saving positions for the second one or something, though I'm not sure it's worth the effort.

Ok, I would then trigger saving on configure events, probably delayed or something to reduce the number of disk writes..

marmuta (marmuta) wrote :

Trunk now saves position and size 5 seconds after a configure event. This should fix the position getting lost on shutdown. The main issue of this bug is gone too. Let's close it.

Changed in onboard:
status: Incomplete → Fix Committed
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions