Feature freeze exception request for new minor release

Bug #621374 reported by Francesco Fumanti
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Invalid
Undecided
Unassigned
onboard (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Hi First of all, sorry for missing the feature freeze; there was an error in my calendar application.

Onboard is the onscreen keyboard shipping by default with Ubuntu. A new minor update has just been released, that incorporates not only the fixes that went into the 0.93.x updates already available in Ubuntu maverick, but also a new fonctionality that makes onboard listen for changes of the system keyboard and honor them in its own layout.

This new fonctionality requires an updated version of the python-virtkey library. Thus, I have filed a freeze exception to get also the new python-virtkey release into Ubuntu maverick; you can find it here: https://bugs.edge.launchpad.net/python-virtkey/+bug/619809

Here are the changes that went into the onboard 0.94.0 package that I prepared:

    * Make onboard follow keyboard layout changes (LP: 526791, LP: 65626)
    * Save onboard geometry on quit instead on configure-events (LP: #596248)
    * Improve handling of missing dependency for the clicks (LP: #524148):
        - Use soname instead of linker for libXi in X11.py
        - Add dependency on libxi6 to break package build if necessary
        - Get current version of soname for libx11 from environment
        - Respect DISPLAY environment variable in KeyboardGTK.py
        - Add debian/README.source with info about libxi6 and libx11
    * Do not crash if icon of IconPalette is missing (LP: #538109)
    * Fix Menu key, Delete key and Insert key
    * Qualify the import of our X11 module
    * Make strings in our X11 module translatable
    * Some cleanup by remove trailing spaces
    * debian/source/format:
        - Add debian source format file and use 3.0 (quilt)
    * debian/compat:
        - Raise it to 7
    * debian/control:
        - Update Standards-Version to 3.9.1
        - Update email address of original maintainer
        - Set minimal required version for debhelper to 7.0.8
        - Set minimal required version for python-virtkey to 0.60.0
        - Add quilt and libxi6 to Build-Depends
        - Add libxi6 and libx11-6 to Depends
    * debian/copyright:
        - Add hosting site
        - Add section with upstream authors
        - Update license information to GPL 3
    * debian/rules:
        - Include patchsys-quilt.mk and remove simple-patchsys.mk
        - Add clean target
    * debian/watch:
        - Add watch file
    * debian/README.source
        - Add README.source file

The package builds, install and seems to run correctly on my Ubuntu maverick installation.

If you need additional informations, please, don't hesitate to ask.

Best regards.

Related branches

Revision history for this message
Francesco Fumanti (frafu) wrote :

Here are the files of the corresponding debian source package (format 3.0 quilt).

The orig.tar.gz file is a manual copy of the tar.gz file.

The diff.gz file has been created by calling debuild -S -sa.

Lintian 2.4.3ubuntu1 does not give any error, nor any warning during the debian source package build.

Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Revision history for this message
Francesco Fumanti (frafu) wrote :
Changed in onboard:
status: New → Invalid
Revision history for this message
Luke Yelavich (themuso) wrote :

Worth updating, minus debian packaging bits like quilt 3.0, standards, compat update.

Revision history for this message
Scott Kitterman (kitterman) wrote :

FFe approved based on Luke's recommendation.

Changed in onboard (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.94.0-0ubuntu1

---------------
onboard (0.94.0-0ubuntu1) maverick; urgency=low

    * Feature freeze exception request to update to new release (LP: #621374)
    * Make onboard follow keyboard layout changes (LP: 526791, LP: 65626)
    * Save onboard geometry on quit instead on configure-events (LP: #596248)
    * Improve handling of missing dependency for the clicks (LP: #524148):
        - Use soname instead of linker for libXi in X11.py
        - Add dependency on libxi6 to break package build if necessary
        - Get current version of soname for libx11 from environment
        - Respect DISPLAY environment variable in KeyboardGTK.py
        - Add debian/README.source with info about libxi6 and libx11
    * Do not crash if icon of IconPalette is missing (LP: #538109)
    * Fix Menu key, Delete key and Insert key
    * Qualify the import of our X11 module
    * Make strings in our X11 module translatable
    * Some cleanup by remove trailing spaces
    * debian/control:
        - Update email address of original maintainer
        - Set minimal required version for python-virtkey to 0.60.0
        - Add libxi6 to Build-Depends
        - Add libxi6 and libx11-6 to Depends
    * debian/copyright:
        - Add hosting site
        - Add section with upstream authors
        - Update license information to GPL 3
    * debian/watch:
        - Add watch file
    * debian/README.source
        - Add README.source file
 -- Francesco Fumanti <email address hidden> Fri, 20 Aug 2010 17:11:12 +0200

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers