glib.GError: Icon 'onboard' not present in theme with onboard-0.93.0

Bug #538109 reported by Michał Górny
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Fix Released
Undecided
Unassigned

Bug Description

After update to onboard-0.93.0, the application fails to start, throwing following exception:

Traceback (most recent call last):
  File "/usr/bin/onboard", line 15, in <module>
    ob = Onboard()
  File "/usr/lib64/python2.6/site-packages/Onboard/OnboardGtk.py", line 67, in __init__
    self._window = KbdWindow()
  File "/usr/lib64/python2.6/site-packages/Onboard/KbdWindow.py", line 164, in __init__
    KbdWindowBase.__init__(self)
  File "/usr/lib64/python2.6/site-packages/Onboard/KbdWindow.py", line 35, in __init__
    self.icp = IconPalette()
  File "/usr/lib64/python2.6/site-packages/Onboard/IconPalette.py", line 92, in __init__
    "onboard", 192, 0)
glib.GError: Icon 'onboard' not present in theme

Switching the system icon set to 'GNOME' makes onboard work again.

Onboard should not rely on existence of its' icon in current icon theme as this makes it unusable on any system with different icon set set.

Related branches

Revision history for this message
Francesco Fumanti (frafu) wrote :

Hi,

thanks for your interest in onboard and for telling us about your proplem.

Unfortunately, I am not able to reproduce the problem here; could you please give more detailed instructions about how to reproduce the problem?

Many thanks in advance.

Revision history for this message
Michał Górny (mgorny) wrote :

1. Switch icon set to something other than GNOME/hicolor (Rodent, for example);
2. Try to start onboard.

I'm using xfce and it's 'Appearance' preferences to switch the icon set but I think GNOME settings do it in the same fashion.

Revision history for this message
Francesco Fumanti (frafu) wrote :

Hi,

I installed the Xubuntu-desktop from the universe repository to try to reproduce your problem; but onboard continues to start up without error.

Could you please confirm that you are running onboard 0.93.0? Consequently, I suppose that you are running the development version of lucid; otherwise, could you please tell me how you installed it?

Many thanks in advance.

Revision history for this message
Michał Górny (mgorny) wrote :

Did you changed the system icon set?

Yes, I'm trying to run 0.93.0. The previous version I used worked fine.

And no, I'm not using Ubuntu. I'm the maintainer of Gentoo ebuilds for onboard, and I'm installing it through distutils.

Revision history for this message
Chris Jones (tortoise) wrote :

Hicolor should be the fallback theme for any icon set. See http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html

Though Onboard shouldn't crash if it can't find the icon.

Changed in onboard:
status: New → In Progress
Revision history for this message
Michał Górny (mgorny) wrote :

Ok, I now see what I did wrong - I didn't update the icon cache and that made the fallback fail. Sorry.

Chris Jones (tortoise)
Changed in onboard:
status: In Progress → Fix Committed
Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers