RFE: Add option to automatically show and hide onboard

Bug #443986 reported by Francesco Fumanti
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Onboard
Fix Released
Undecided
Unassigned
smartphone
New
Undecided
Unassigned

Bug Description

I got the following enhancement request from a from a user:

Would it be possible to add an option to onboard to make it automatically appear when an item that accepts keyboard input has focus? On the other hand, onboard should be automatically hidden, when there is no input field with focus.

Moreover, positioning onboard automatically next to the input field when it appears might also be useful.

Related branches

Revision history for this message
rdnrvn (vikram-sharda) wrote :

Any idea how long does a thing like this take? I need it for my project and I'm considering if I could do this by myself. But I'm not a very experienced programmer.

Revision history for this message
Most People Use Their Full Name here (fullname1) wrote :

I accidentally posted the following as a duplicate of this bug. The new bug is marked as duplicate.
---------------------------------------------------------------------------------------------------------------------------

On devices with small display resolution like WVGA (800x480) it is critical to save as much of the available display space as available.
Since it is also important to have large areas to touch when using (capacitive) touchscreen, onboard must be largely scaled in order to be well usable.

To solve this conflict it would be nice to include a mechanism in onboard that will scan for the need of an input device (e.g. when cursor appears in a web browser text field) to show onboard in such situations and to hide it once the input procedure is finished.
As this could also be useful to users of big display devices but will not be perfect in any case it might be good to add it as an option like 'auto mode'

Best regards

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: onboard 0.93.2-0ubuntu1
Uname: Linux 2.6.32.9-38168-g65aefba-dirty armv7l
Architecture: armel
Date: Mon Jan 11 13:34:56 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: onboard

Revision history for this message
Most People Use Their Full Name here (fullname1) wrote :
Revision history for this message
Most People Use Their Full Name here (fullname1) wrote :

Did anybody look into a patch that implements such a function?
I am wondering which program has a similar mechanism that checks for presence of active input field so we could steal from that. Any thoughts ?

Best regards

Revision history for this message
Neonightmare (neonightmare) wrote :

Hi there, i search the same function. I have found the project "florence" witch has this functionallity.

http://florence.sourceforge.net/english.html

maybe this is hint is usefull...

Greets neo

Revision history for this message
Most People Use Their Full Name here (fullname1) wrote : Re: [Bug 443986] Re: RFE: Add option to automatically show and hide onboard

Neo,
Great finding!

Following is extracted from the florence README at
http://florence.git.sourceforge.net/git/gitweb.cgi?p=florence/florence;a=blob_plain;f=README;h=3702410b440d2d39c8022735b0589cbc00dc7f25;hb=HEAD

"If Florence is not in "always on screen" mode, it will appear when
you click on an editable
widget (like the address bar in epiphany or the text area in a text
editor). When you click
on an uneditable widget, Florence will disappear.
If you don't like this behaviour, you can switch to normal virtual
keyboard always on
screen"

The full git repository is at
 git://florence.git.sourceforge.net/gitroot/florence/florence

Now we need to locate the relevant auto hide code and implement it in onboard.

Best regards
Lukas

On 9/28/10, Neonightmare <email address hidden> wrote:
> Hi there, i search the same function. I have found the project
> "florence" witch has this functionallity.
>
> http://florence.sourceforge.net/english.html
>
> maybe this is hint is usefull...
>
> Greets neo
>
> --
> RFE: Add option to automatically show and hide onboard
> https://bugs.launchpad.net/bugs/443986
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (626062).
>
> Status in onboard onscreen keyboard: New
>
> Bug description:
> I got the following enhancement request from a from a user:
>
> Would it be possible to add an option to onboard to make it automatically
> appear when an item that accepts keyboard input has focus? On the other
> hand, onboard should be automatically hidden, when there is no input field
> with focus.
>
> Moreover, positioning onboard automatically next to the input field when it
> appears might also be useful.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/onboard/+bug/443986/+subscribe
>

Revision history for this message
Francesco Fumanti (frafu) wrote :

According to some documentation of Florence, it seems to depend on at-spi. Now I wonder whether it is particularly that feature that depends on at-spi.

We do not want onboard to depend on at-spi; at least not until some of its major problems are solved.

Revision history for this message
Most People Use Their Full Name here (fullname1) wrote :

Did anybody look at this more closely ? Is it really mandatory to use at-spi in order to implement auto show/hide in the way it is implemented in florence ?

Francesco, can you detail on the majore problems you see using at-spi ?

Best regards

Revision history for this message
marmuta (marmuta) wrote :

Onboard main now has optional auto-hide based on at-spi2 focus messages.
It should work in principle, but is only as accurate as the underlying at-spi2 focus messages are. Many applications cooperate, others don't. In general I find it more useful than distracting, but you milage may vary.
Be sure to report bugs.

Changed in onboard:
status: New → Fix Committed
Revision history for this message
Francesco Fumanti (frafu) wrote :

My remarks in comment 7 were about at-spi, not at-spi2.

I am also using at-spi2 now because of the auto-show feature of Onboard.

Changed in onboard:
status: Fix Committed → Fix Released
Revision history for this message
Francesco Fumanti (frafu) wrote :

I marked this bug as Fix Released, because the auto-show feature is now available in Onboard 0.97.0, that has been released yesterday.

Somebody add the smartphone distribution to this bug report. If this is still an issue for you, please open a new bug with details about the issue.

Best Regards.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers