onboard does not work with wayland

Bug #1826742 reported by Wolf
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Onboard
New
Undecided
Unassigned

Bug Description

ubu 18.04.2 and 18.10

When you try to work with wayland, you're lost. Onboard keyboard still shows up, but typing does not create characters in apps (tested gedit, FF, activities menu, terminal, preferences). Unluckily, the default GNOME keyboard does not come in.

This is serious, because only with wayland you can enable scaleable zoom, which improves the GUI quite a lot.

Revision history for this message
Puspam Adak (pom1234567890) wrote :

Another thing to add is that the "move" button on the keyboard does not work with Wayland.

Revision history for this message
Dan (deano-5) wrote :

The problems still remain

Revision history for this message
Luis Llana (luisllana) wrote :

The problem is not solved yet.

Revision history for this message
Chris Cooper (superduper2024) wrote :

2024 and the problem is not solved yet. I hope someone can get Onboard working with Wayland as it is very good indeed. Come on guys, please can someone fix it.

Revision history for this message
Björn Tantau (bjoern-tantau) wrote :

As a workaround you can use https://github.com/Supreeeme/extest to make Onboard work. Compile it as a 64 bit library and launch onboard with

env LD_PRELOAD=/usr/lib64/libextest.so onboard

If you want to use it with KDE you can add

X-KDE-Wayland-VirtualKeyboard=true

to its desktop-file.

I used kwin rules to get rid of window decorations and have it always on top without stealing focus. If someone knows how to make all other windows smaller when it's active that would be great.

Only problem remaining is that sometimes the keys get stuck on touch input. At least on my Steam Deck on OpenSUSE.

Revision history for this message
Chris Cooper (superduper2024) wrote :

Thanks for the workaround Björn Tantau (bjoern-tantau) - however I am not technical with Linux and I cannot do that. Is there an easier way for me to get Onboard working ? Not having Onboard is a big loss.
My system is

Operating System: Garuda Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.8-zen1-1-zen (64-bit)
Graphics Platform: X11 === OR WAYLAND ===
Processors: 12 × AMD Ryzen 5 5600G with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Product Name: X570S PG Riptide

Thanks for your help.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.