Left click tray icon stopped working in 1.1.0

Bug #1421972 reported by Zen25000 on 2015-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Medium
Unassigned

Bug Description

I have just updated the Mageia package to 1.1.0 for testing and left click on the tray icon fails to open onboard.

This is similar to https://bugs.launchpad.net/bugs/1329750, which was fixed, however our previous version is working correctly with the current gtk version and other dependencies we currently have, so this seems different.
Running in a terminal the error on left click of the tray icon is as follows:

[baz@jackodesktop ~]$ onboard
TypeError: on_show_keyboard_toggle() takes 1 positional argument but 2 were given

Right click ->show onboard works as expected, although jut the right click produces an error:

Traceback (most recent call last):
  File "/usr/lib64/python3.4/site-packages/Onboard/Indicator.py", line 184, in _menu_position_func
    return Gtk.StatusIcon.position_menu(self._menu, status_icon)
TypeError: argument menu: Expected Gtk.Menu, but got Onboard.Indicator.ContextMenu

marmuta (marmuta) wrote :

Thank you, I missed that. Should be fixed with
https://bazaar.launchpad.net/~onboard/onboard/trunk/revision/1946
Tested in Cinnamon as the status icon didn't show up in Ubuntu's KDE Plasma. Let me know if it does for you, please.

FYI: we're going to create a 1.1.1 release before Ubuntu's feature freeze on the 19th. There've been a handful of problems since 1.1.0, amongst them an X error bug that might cause Onboard to disappear (still open).

Changed in onboard:
status: New → Fix Committed
importance: Undecided → Medium
Zen25000 (zen25000) wrote :

Hi,
I can confirm that this is fixed with 1946. :)
We are officially in version freeze now, but due to delays I may still be able to squeeze in 1.1.1 if it's not too far off ;)
Cheers,
Barry

Francesco Fumanti (frafu) wrote :

Hi,

Onboard 1.1.1 has just been published:
https://launchpad.net/onboard/+download

I hope it is still in time for you. :-)

Cheers

Changed in onboard:
status: Fix Committed → Fix Released

On 18/02/15 15:33, Francesco Fumanti wrote:
> Hi,
>
> Onboard 1.1.1 has just been published:
> https://launchpad.net/onboard/+download
>
> I hope it is still in time for you. :-)
>
> Cheers
>

Thanks for the heads-up! - freeze push request is in :)

Barry

Francesco Fumanti (frafu) wrote :

You are welcome. :)

Francesco

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers