trunk 1222 doesn't work

Bug #1095508 reported by David López on 2013-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Medium
Unassigned

Bug Description

I've just built trunk 1222 in a wetab tablet with 64 bits archlinux, lxde and openbox. Pressing keys on onboard doesn't do nothing at all. It's not easy to explain, keyboard looks like a fixed image.

Starting from a terminal I can see lots of message errors:

(onboard:794): Gdk-CRITICAL **: gdk_device_get_axis_use: assertion `index_ < device->axes->len' failed

marmuta (marmuta) wrote :

Thanks for testing. Trunk is listening XInput slave devices directly now, to hopefully resolve a number of pointer grab related bugs. I've only been able to test Ubuntu 13.04 on a Nexus 7 and x86_64 desktop so far, where it works quite well.

What's the output of
$ xinput
$ ./onboard -dinfo # just starting is enough, no need to press anything

Switching to "GTK" in Preferences->Advanced->Input event source should restore pointer input, though I hoped you wouldn't need that.

I'm still investigating the Gdk-CRITICAL assertions, I've seen them too on the Nexus 7, but not on every start of Onboard. They appear to have little effect though, and aren't responsible for this bug.

marmuta (marmuta) wrote :

I've tested the XInput mode on Arch and didn't spot any problems. Also I've heard back from Francesco and he's having only minor issues on his hardware. I suspect there is something unique about the pointing devices on the wetab.

If you find the time, please send me these:
$ xinput
$ ./onboard -dinfo 2>&1 |grep TouchInput

The reason for all that XInput hassle is that it might finally be a fix for bug #905636, i.e. no more lost key-strokes when typing URLs. Though if there remains a risk of Onboard becoming unresponsive, we can't make this the default.

marmuta (marmuta) wrote :

We've had a few weeks of testing since and plenty of regressions were fixed with the XInput event source. This wetab issue is still looming though, I'd appreciate if you could try current trunk rev 1269 again.

There's some new stuff too to make it worthwhile, check out label popup and sound feedback in Preferences->Keyboard.

If you are hit again with an unresponsive keyboard, switch Preferences->Keyboard->Advanced->Input Event Source to "GTK" and everything should be back to normal. Just drop us a note in that case, please.

Changed in onboard:
status: New → Incomplete
importance: Undecided → Medium
David López (david-lopez-upct) wrote :

Sorry, marmuta, I've had a lot of work and missed your test request. Today I've built rev. 1268 and it works perfectly in my wetab tablet. Thanks a lot.

marmuta (marmuta) wrote :

Great, that's good news. Thanks for testing.

Changed in onboard:
status: Incomplete → Fix Committed
Francesco Fumanti (frafu) wrote :

Hi,

I have uploaded a snapshot of the current development status of Onboard containing a fix for this bug and other new features to our main PPA:
https://launchpad.net/~onboard/+archive/ppa

The snapshot is available for raring and for saucy.

Have a nice day.

Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers