keyboard doesn't update after pressing modifiers keys

Bug #1069990 reported by David López on 2012-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned

Bug Description

The keyboard doesn't properly update after pressing shift or AltGr keys.

To reproduce the bug:

- Press shift key (the keyboard changes to uppercase keys and shift key turns to grey)
- Press key A (an uppercase 'A' is written and shift key returns to normal status)

The expected behaviour is the keyboard returning to normal lowercase, however it remains showing uppercase keys (it only shows uppercase, in fact pressing keys it writes lowercase). A complete cycle in the shift key (normal-grey-red-normal) is needed to return to show lowercase keys. Same problem happens with AltGr key.

I'm using trunk revision 1016 on a 64 bits Arch machine with lxde and openbox.

marmuta (marmuta) wrote :

Thank you, should be fixed. Pressing shift was rather sluggish in my Arch install, so I felt I had to optimize that a bit and didn't catch at the cases at first try.

Changed in onboard:
status: New → Fix Committed
marmuta (marmuta) wrote :

Marking "Fix Released", since this was an unreleased regression.

Changed in onboard:
status: Fix Committed → Fix Released
David López (david-lopez-upct) wrote :

I can confirm this bug is gone in revision 1018. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers