Comment 6 for bug 1035578

Jeff Sereno (jsereno) wrote :

Not sure how it worked for Franz, but testing 0.97.1-0ppa~precise2 myself in Ubuntu 12.04 (updated through to today) unfortunately yields no success in fullscreen applications be it Firefox, Chromium or Google Chrome.

Have tested in a VM, real Intel-graphics-based PC and a real NVidia-graphics-based PC. No joy. Everytime I go fullscreen, OnBoard remains behind the full-screen display despite "Force window to top" settings. Rebooted a few times just to make sure too.

Tried to use wmctrl to try and force the OnBoard window to the front too or force Chromium/Firefox to the back, but with no success.

Also tried toggling Compiz's "Fullscreen Legacy Support" in the Workarounds plugin on and off with no change either.

There is also no apparent difference with using Unity 2D and Unity 3D either.

At this stage I have had more success with 0.97.0 with being at the front on test machines and VM's in Unity 2D mode, but no success on the PC I intend to use. :(

As a side note, I've noticed 12.04's handling of fullscreen applications in general seems to have changed from previous versions - you can't even use MPlayer full-screen if Firefox or Chromium are already in fullscreen mode. Previously, you could.

Is there a place to get hold of 0.98 to try out?