xserver-xorg-input-synaptics grabs devices it shouldn't

Bug #624985 reported by Chase Douglas on 2010-08-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Input Framework
High
Chase Douglas
xserver-xorg-input-synaptics (Ubuntu)
Medium
Unassigned

Bug Description

Two touchpad devices A and B
X enumerates A before B
They both have a /dev/input/event* node and a /dev/input/mouse* node
I set up xorg.conf to use evdev for A
A gets handled by evdev
B's /dev/input/mouse* node gets probed by synaptics
it doesn't match /dev/input/event* in the synaptics probe function, so synaptics runs the eventcomm AutoDevProbe callback
the AutoDevProbe callback finds the first evdev node that isn't grabbed by synaptics already
in this case, it finds A and grabs it

Freeze Exception Information:

The solution is to match the synaptics input module only for /dev/input/event* nodes. For the purposes of Ubuntu, this bug may cause the Magic Trackpad to be grabbed by the synaptics driver instead of evdev. When this occurs, gestures will not work.

Changed in utouch:
importance: Undecided → High
status: New → In Progress
assignee: nobody → Chase Douglas (chasedouglas)
milestone: none → ubuntu-10.10
Changed in utouch:
status: In Progress → Invalid
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
importance: Undecided → Medium
milestone: none → ubuntu-10.10
status: New → In Progress
description: updated
Bryce Harrington (bryce) on 2010-09-15
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → Fix Released
Chase Douglas (chasedouglas) wrote :

Turns out the patch was added but never applied. The package will need to be uploaded with a fix.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Fix Released → In Progress
Chase Douglas (chasedouglas) wrote :
Chase Douglas (chasedouglas) wrote :

Patch added in ubuntu4 version of the package, for review purposes.

description: updated
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: In Progress → New
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.2.2-2ubuntu5

---------------
xserver-xorg-input-synaptics (1.2.2-2ubuntu5) maverick; urgency=low

  * 115_evdev_only.patch was added but never applied. (LP: #624985)
 -- Chase Douglas <email address hidden> Sat, 18 Sep 2010 15:19:21 +0200

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers