Conversion to dirac video takes endless

Bug #279367 reported by Hanno Böck on 2008-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OggConvert
Critical
Kerry Hatcher

Bug Description

When trying to convert a video to dirac, it takes endless, the output file is zero bytes. The "remaining time" increases and nothing more happens.

I can confirm that Dirac-into-Ogg encoding doesn't work at all with GStreamer as shipped in Ubuntu Intrepid, at least if the file also has an audio track.

As far as I can gather, it seems to be a bug in the version of oggmux used in Intrepid (gst-plugins-base 0.10.21). Strangely enough, Dirac-into-Matroska encoding works correctly in this version, whereas it was previously broken (hence why OggConvert normally won't let you do it).

Changed in oggconvert:
importance: Undecided → Critical
status: New → Confirmed
Yfrwlf (yfrwlf) wrote :

Nothing has changed for Jaunty either yet, tho perhaps it's using the same packages, not sure. Works with Matroska, but OggConvert doesn't want to do that, damn, in between a rock and a hard place. ^^

Confirmed that it's the sound problem Tristan noted. After stripping out the sound from a movie, it had no problem converting it.

Hi subscribers,

It's been a while, but this seems to have been fixed in GStreamer in the intervening 18 months, at least for me using OggConvert 0.3.2 on Lucid x86. Can others confirm so I can close the bug?

Thanks

Am Sonntag 23 Mai 2010 schrieben Sie:
> It's been a while, but this seems to have been fixed in GStreamer in the
> intervening 18 months, at least for me using OggConvert 0.3.2 on Lucid
> x86. Can others confirm so I can close the bug?

Hi,

Yes, I can confirm that dirac now works (tested with latest oggconvert 0.3.3
and up-to-date Gentoo system).
Although now with vp8/webm, there probably is not much interest in dirac any
more.

--
Hanno Böck Blog: http://www.hboeck.de/
GPG: 3DBD3B20 Jabber/Mail: <email address hidden>

http://schokokeks.org - professional webhosting

Kerry Hatcher (kerry.hatcher) wrote :

Looks like 10.04 all is well. I'd say lets call it fixed!

-Kerry

Changed in oggconvert:
status: Confirmed → Fix Released
assignee: nobody → Kerry Hatcher (kerry.hatcher)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers