Huawei with invalid serial not regocnised

Bug #612479 reported by Kalle Valo on 2010-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
Medium
Kalle Valo
ofono
Fix Released
Undecided
Kalle Valo
ofono (Ubuntu)
Undecided
Kalle Valo

Bug Description

I was contacted by a user which has Huawei E620 (usb id 12d1:1001) and ofono didn't recognise the modem. The modem has garbage as serial and ofono does not initialise the modem:

E: ID_SERIAL=ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ_HUAWEI_Mobile_ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ
E: ID_SERIAL_SHORT=ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ
E: ID_BUS=usb
E: ID_USB_INTERFACES=:ffffff:080650:
E: ID_VENDOR_FROM_DATABASE=Huawei Technologies Co., Ltd.
E: ID_MODEL_FROM_DATABASE=E620 USB Modem

My Huawei E1552 again has serial as empty (null in ofono) and initialisation succeeds.

Mark Shuttleworth (sabdfl) wrote :

It would be useful if we could have a mechanism for gathering thousands of opt-in users' metadata, to see if this is a common occurrence, and if there are patterns to help us spot it.

Kalle Valo (kvalo) on 2010-08-06
Changed in ofono:
status: New → In Progress
assignee: nobody → Kalle Valo (kvalo)
Kalle Valo (kvalo) wrote :

Here's a distro patch which should fix the issue. It also changes ofono to use cdbs.

A test package is here:

https://launchpad.net/~indicator-network-developers/+archive/ppa/+files/ofono_0.26-0ubuntu2~ind2_amd64.deb
https://launchpad.net/~indicator-network-developers/+archive/ppa/+files/ofono_0.26-0ubuntu2~ind2_i386.deb

(The test package also contains upstart and apport changes.)

Kalle Valo (kvalo) on 2010-08-30
Changed in ofono (Ubuntu):
status: New → In Progress
assignee: nobody → Kalle Valo (kvalo)
David Barth (dbarth) on 2010-09-01
Changed in ayatana-ubuntu:
milestone: none → ubuntu-10.10
assignee: nobody → Kalle Valo (kvalo)
importance: Undecided → Medium
status: New → In Progress
Chris Coulson (chrisccoulson) wrote :

Thanks for the patch. We shouldn't convert the package to use CDBS really though. Instead, I'll just update it to source format 3.0, which uses quilt automatically

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 0.26-0ubuntu2

---------------
ofono (0.26-0ubuntu2) maverick; urgency=low

  [ Kalle Valo <email address hidden> ]
  * Ofono should use upstart (LP: #600503)
    - add debian/ofono.upstart
    - add debian/ofono.preinst
    - remove debian/ofono.init
    - remote debian/ofono.default
  * Add Apport support (LP: #600502)
    - add debian/ofono-crashdb.conf
    - add debian/source_ofono.py
  * Fix LP: #612479 - Huawei with invalid serial not recognised
    - add debian/patches/01-check-that-modem-name-is-valid.patch
    - add debian/patches/series

  [ Chris Coulson <email address hidden> ]
  * Switch to dpkg-source 3.0 (quilt) format
    - add debian/source/format
  * Fix script-in-etc-init.d-not-registered-via-update-rc.d warning
    triggered by shipping the symlink to the upstart job
    - add debian/ofono.lintian-overrides
 -- Kalle Valo <email address hidden> Thu, 02 Sep 2010 18:21:57 +0100

Changed in ofono (Ubuntu):
status: In Progress → Fix Released
Kalle Valo (kvalo) on 2010-09-03
Changed in ofono:
status: In Progress → Fix Released
Changed in ayatana-ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers