support armhf architecture

Bug #892240 reported by Fathi Boudra
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Offspring
Undecided
Guilherme Salgado
Offspring
Undecided
Unassigned

Bug Description

The architectures supported by Offspring are i386, amd64, lpia and armel.
There's some work on going to add armhf architecture for Ubuntu Precise.

Could you add armhf architecture support so we can start building and evaluating images on our instance (ubuntu-build.linaro.org)?

Related branches

Fathi Boudra (fboudra)
description: updated
Revision history for this message
Guilherme Salgado (salgado) wrote :

So, AIUI this is trivial to implement in Offspring (just a matter of adding 'armhf' to ARCH_CHOICES), but do we have armhf builders and package archives already?

Revision history for this message
Fathi Boudra (fboudra) wrote : Re: [Bug 892240] Re: support armhf architecture

On 18 November 2011 21:57, Guilherme Salgado
<email address hidden> wrote:
> So, AIUI this is trivial to implement in Offspring (just a matter of
> adding 'armhf' to ARCH_CHOICES), but do we have armhf builders and
> package archives already?

We don't have builders yet. Buildds are building packages and LP has
armhf support.

Revision history for this message
LaMont Jones (lamont) wrote :

All of our armel hardware in the datacenters can run armhf binaries on the underlying armel. If offspring has a way to force uname -m or equivalent such that it doesn't use the underlying native model, the builder does not actually need to be running armhf. (We will likely leave the buildds running armel, and switch which architecture they build.)

Revision history for this message
Loïc Minier (lool) wrote :

There's no difference in uname output between armel and armhf; you can just "chroot" into an armhf chroot from an armel system and vice-versa.

Revision history for this message
Tom Gall (tom-gall) wrote :

For what it's worth there's a small change to enable it for live-build as well. It "should" work with the a40 version I've put together, however it's untested as of yet.

Changed in linaro-offspring:
assignee: nobody → Guilherme Salgado (salgado)
status: New → Fix Committed
Changed in linaro-offspring:
status: Fix Committed → Fix Released
Changed in linaro-offspring:
status: Fix Released → In Progress
Revision history for this message
Guilherme Salgado (salgado) wrote :

When polling the slaves Offspring will update its database with the information returned by the slaves (name, machine type, etc), but since the slave registered as the armhf builder was actually running armel Offspring changes the machine type of the builder to armel after the first scan and we no longer have anything to build the armhf jobs.

Changed in linaro-offspring:
status: In Progress → Fix Released
David Murphy (schwuk)
Changed in offspring:
status: New → Confirmed
David Murphy (schwuk)
tags: added: feature
Changed in offspring:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints