The prompt for installing MP3 playback support dialogue box does not fit in a 1024x600 display

Bug #962860 reported by Chih-Hsyuan Ho on 2012-03-23
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Ursula Junque
Precise
Undecided
Unassigned
libubuntuone
Status tracked in Trunk
Stable-3-0
High
dobey
Trunk
High
dobey
libubuntuone (Ubuntu)
High
dobey
Precise
High
dobey

Bug Description

* Ubuntu Release: 12.04 Beta1
* Steps to reproduce it:
1. Click on link to "Ubuntu One" music store
2. Click on any album link to open up its play list
3. Try to trial play any of the songs in the list

Please see the attached screen shots for more information.

Related branches

Chih-Hsyuan Ho (chih) wrote :
Kent Lin (kent-jclin) on 2012-03-23
Changed in oem-priority:
importance: Undecided → High
Kent Lin (kent-jclin) on 2012-03-23
Changed in oem-priority:
importance: High → Medium

Is it possible to resize the dialog to fit in a width of only 600 pix?

Changed in rhythmbox (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Low
Changed in oem-priority:
assignee: nobody → Ursula Junque (ursinha)
Changed in rhythmbox (Ubuntu):
status: New → Invalid
Changed in rhythmbox-ubuntuone:
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
status: New → Incomplete
status: Incomplete → New
Changed in rhythmbox-ubuntuone (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Medium
James M. Leddy (jm-leddy) wrote :

Changes the message to "MP3 playback plugin must be installed to play Previews and Purchased Music."

Changed in rhythmbox-ubuntuone:
status: New → Invalid
Changed in rhythmbox-ubuntuone (Ubuntu):
status: New → Invalid
Changed in libubuntuone (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
dobey (dobey) wrote :

Is there a string/UI freeze break approval for this? I don't see one here.

Also, why is this not being done as a branch against upstream?

The attachment "libubuntone-shorten-mp3install-message.diff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
James M. Leddy (jm-leddy) wrote :

Screenshot with the shorter message.

James M. Leddy (jm-leddy) wrote :

In response to comment #4, patch against trunk.

Rick McBride (rmcbride) on 2012-04-06
Changed in libubuntuone:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: New → Triaged
Micah Gersten (micahg) wrote :

Unsubscribing ubuntu-sponsors until "upstream" Ubuntu One decides what they want to do with this, Also, no UIFe as mentioned in comment #4. Please resubscribe ubuntu-sponsors when the appropriate paperwork is filed.

Manuel de la Peña (mandel) wrote :

Fixing the bug by changing the text is not the correct way. What is happening here is that the label is not wrapping which makes the frame be too big. If we changed the text we would just be fixing the eng version (I do agree that the proposed text is better).

I propose to fix the bug by making the text wrap which will ensure that the widget uses the correct size and will be fix the issue for all langs. Also, doing that will not require a UIFe because we are talking about a bug and we are not being a PITA to the translators.

You can see an attachment with the image of the new wrappig version (background) and the old one. I have also added a branch with the fix which the u1 team will ensure that lands following the correct paper work.

Manuel de la Peña (mandel) wrote :

Also, I forgot to mention, there are padding issues in there, I'll fix those to (icon and button)

Manuel de la Peña (mandel) wrote :

The following is the fix running in a small screen

dobey (dobey) on 2012-04-19
no longer affects: rhythmbox-ubuntuone (Ubuntu)
no longer affects: rhythmbox (Ubuntu)
no longer affects: rhythmbox-ubuntuone
Changed in libubuntuone (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Rodney Dawes (dobey)
status: New → Triaged
importance: Undecided → High
Changed in oem-priority:
status: New → Triaged
dobey (dobey) on 2012-05-18
Changed in libubuntuone (Ubuntu Precise):
milestone: none → precise-updates
Chris Halse Rogers (raof) wrote :

Why is this not yet fixed in Quantal? We're getting past the time where I'm happy to pocket-copy from precise-updates to quantal.

I'll accept this now, but please also upload to quantal. There's no reason quantal should wait 7 days for the fix.

Changed in libubuntuone (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed

Hello Chih-Hsyuan, or anyone else affected,

Accepted libubuntuone into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Chih-Hsyuan Ho (chih) wrote :

With the gir1.2-ubuntuoneui-3.0 and libubuntuoneui-3.0-1 in precise proposed (main), this issue is properly addressed (a screen shot is attached.)

tags: added: verification-done
removed: verification-needed
dobey (dobey) wrote :

Chris, because we want it pocket-copied. We'll be doing new releases off a new stable branch soon for Quantal, but having to resort to 0ubuntu0.1 numbering for releasing the exact same code on both Q and P is tedious, so we're trying to avoid that until we start having new releases.

Also, libubuntuone is FTBFS on Quantal at the moment, due to changes in gcc 4.7 adding a new warning which isn't available to use in gcc 4.6 on Precise, which makes fixing it a bit difficult, but which I hope to have fixed soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 3.0.1-0ubuntu1.1

---------------
libubuntuone (3.0.1-0ubuntu1.1) quantal; urgency=low

  * New upstream release.
    - Enable line wrap for the MP3/subscribe alert label. (LP: #962860)
 -- Rodney Dawes <email address hidden> Mon, 21 May 2012 16:30:28 -0400

Changed in libubuntuone (Ubuntu):
status: Triaged → Fix Released
Changed in oem-priority:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 3.0.1-0ubuntu1

---------------
libubuntuone (3.0.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Enable line wrap for the MP3/subscribe alert label. (LP: #962860)
 -- Rodney Dawes <email address hidden> Mon, 21 May 2012 16:30:28 -0400

Changed in libubuntuone (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.