[Maverick] 32bit Ubuntu installer not calculating swap correctly for PAE systems

Bug #604765 reported by Jerone Young on 2010-07-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
partman-auto (Ubuntu)
High
Colin Watson
Maverick
High
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

When calculating the amount of swap needed on a system, 32bit Ubuntu does not use the correct calculation.

It needs to use the same logic that it uses to calculate memory size, as it does when determining if the PAE kernel needs to be installed.

What happens now is that during install only see up to 3Gig memory can be seen by kernel. But once properly determined that machine has more then this, the PAE kernel is installed. Though the amount of swap does not match up with the amount of memory exposed when booted with the PAE kernel.

This causes hibernation to fail on these systems.

Jerone Young (jerone) on 2010-07-12
Changed in oem-priority:
importance: Undecided → High
summary: - 32bit Ubuntu not calculating swap correctly for PAE systems
+ [Maverick] 32bit Ubuntu not calculating swap correctly for PAE systems
Changed in oem-priority:
status: New → Confirmed
Jerone Young (jerone) on 2010-07-13
summary: - [Maverick] 32bit Ubuntu not calculating swap correctly for PAE systems
+ [Maverick] 32bit Ubuntu installer not calculating swap correctly for PAE
+ systems
Jerone Young (jerone) on 2010-07-13
visibility: private → public
Brent Fox (brent-s-fox) wrote :

Let me make sure I understand the problem. Let's say a machine has 8GB of RAM. At install time, the boot kernel only sees 3GB of RAM, so it creates a 3GB swap partition. Then later, the installer detects that the PAE kernel is needed, so it installs it.

After reboot, the user is able to address all 8GB of RAM, but now they have a swap partition that is not big enough to hold the contents of memory, therefore hibernate (suspending to disk) is likely to fail.

Do I have that right?

Jerone Young (jerone) wrote :

@Brent
             Correct. That is what we observed.

Evan (ev) on 2010-07-14
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
Colin Watson (cjwatson) wrote :

This is probably fairly straightforward to glue into partman-auto; it can use /usr/lib/base-installer/dmi-available-memory if it's available (though if and when we get round to merging this upstream, that's not really a great place for it).

After this, no change to ubiquity beyond a routine update to the new partman-auto should be needed.

affects: base-installer (Ubuntu Maverick) → partman-auto (Ubuntu Maverick)
Changed in ubiquity (Ubuntu Maverick):
assignee: Evan Dandrea (ev) → nobody
Changed in partman-auto (Ubuntu Maverick):
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu Maverick):
status: New → Invalid
importance: High → Undecided
Changed in partman-auto (Ubuntu Maverick):
status: New → In Progress
Colin Watson (cjwatson) wrote :

(Excuse me for stealing this bug, Evan. I realised the fix was straightforward and decided I might as well round out the week with it.)

Colin Watson (cjwatson) wrote :

OK. I'm not actually able to test this directly myself in any very reliable way. However, I've gone ahead and uploaded a change to partman-auto which should cover this. This will be included in ubiquity 2.3.8 when it's uploaded, which should be early next week, and at that point I'd greatly appreciate confirmation that I got this right.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 91ubuntu4

---------------
partman-auto (91ubuntu4) maverick; urgency=low

  * Use /usr/lib/base-installer/dmi-available-memory if available to
    determine memory size for RAM-dependent recipe elements (LP: #604765).
 -- Colin Watson <email address hidden> Sat, 21 Aug 2010 00:09:22 +0100

Changed in partman-auto (Ubuntu Maverick):
status: In Progress → Fix Released
Jerone Young (jerone) wrote :

@Colin
      I'll test it over the weekend and let you know.

Jerone Young (jerone) wrote :

@Colin
           Willl wait till the Ubiquity update .

Jerone Young (jerone) wrote :

Testing on a machine with 4G ram and 250Gig HDD. The installer gave the machine 12G swap...so hibernate can't fail due to lack swap space with this

Changed in oem-priority:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers