Move to pulse audio is not resetting volume levels at ALSA level

Bug #418620 reported by Jerone Young on 2009-08-25
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Canonical Ubuntu QA Team
alsa-utils (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

If volume levels are changed at the ALSA level they are not being reset on reboot or any other time. The issue here is if a program changes the ALSA levels or a user uses "alsamixer" the user has no idea why their sound does not work as they are only exposed to the pulse audio layer.

Volume levels should possible by reset on reboot or dynamically during runtime to ensure users allways have sound and recording available.

The same goes for ALSA switches and recording settings.

Changed in oem-priority:
assignee: nobody → Canonical Ubuntu QA Team (canonical-qa)
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

Is there a specific reason why this bug report is private?

Jerone Young (jerone) on 2009-08-31
visibility: private → public
Changed in pulseaudio (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
David Henningsson (diwic) wrote :

I would say more users use alsamixer to fix their sound, rather than screwing it up.

So it seems to me like the suggested solution will make things worse (and we will probably be overwhelmed with regression bug reports). I would say it would be better to expose users to the alsamixer layer, at least if we're talking Karmic time frame.

An use case could be that one user likes to have his sound card's "3D effect" on, while another wants it to be off. This is not exposed through pulseaudio atm. How will both users be able to configure their systems right, without one of them having to use alsamixer every time he logs in?

Martin Pitt (pitti) wrote :

We have had /etc/init.d/alsa-utils storing hw settings on shutdown/restoring on boot pretty much since day one in Ubuntu, for the reasons pointed out by David; note that this has a "reset" command, to.

To be honest I don't quite follow the reasoning here: if a user uses a program like alsamixer to change e. g. mixer levels or 3D sound settings, it is not unreasonable to assume that he can use the very same program to change it back? Or did you find a program which noninteractively mucks around with the alsa settings and breaks them?

Jerone Young (jerone) wrote :

@Martin
        Now alsamixer is completely hidden away (not even installed anymore by default). The cases both of you describe are advanced users. But your new, average, & novice users may not have a clue that their is a alsamixer .

        The problem is the settings are not being restored currently. Try turning down the PCM alsamixer .. reboot .. and you still have no sound. Programs such as skype directly control the alsa mixer .. even if a user is unaware. This is the problem.

        This is a support issue. Since pulseaudio is trying to cover up everything you must have a way for someone to easily get them out of a bad situation. The alsa settings are now not being exposed in 9.10 unlike 9.04 and below.

Err, alsa-utils is still seeded by default for desktop, no?

The volume not being restored correctly is a race that I'm investigating,
but I'm traveling for work until Saturday...

On Sep 23, 2009 9:10 AM, "Jerone Young" <email address hidden> wrote:

@Martin
       Now alsamixer is completely hidden away (not even installed anymore
by default). The cases both of you describe are advanced users. But your
new, average, & novice users may not have a clue that their is a alsamixer .

       The problem is the settings are not being restored currently. Try
turning down the PCM alsamixer .. reboot .. and you still have no sound.
Programs such as skype directly control the alsa mixer .. even if a user is
unaware. This is the problem.

       This is a support issue. Since pulseaudio is trying to cover up
everything you must have a way for someone to easily get them out of a bad
situation. The alsa settings are now not being exposed in 9.10 unlike 9.04
and below.

-- Move to pulse audio is not resetting volume levels at ALSA level
https://bugs.launchpad.net/bug...

> But your new, average, & novice users may not have a clue that their
> is a alsamixer.

Right, I wouldn't expect them to. I just said that the same program
that was used to change the setting could be used to change it back.

> The problem is the settings are not being restored currently. Try
> turning down the PCM alsamixer .. reboot .. and you still have no
> sound.

So you mean they _are_ being restored currently, but you want every
boot to start with the "factory defaults" again?

> Programs such as skype directly control the alsa mixer .. even if a
> user is unaware.

And this isn't reflected in the pulse audio levels? That works for me,
when I use alsamixer to change the levels, I instantly see the change
in the mixer applet. That doesn't work for you?

I agree that this would be a bug.

Thanks!

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
bwallum (rbw2) wrote :

I'm not too sure if I understand the real issue here. I have experienced a 'learning curve' with pulse audio but have got it to work. It is dynamic and you need to have an application running and using audio in order to see the application (and controls) listed in the Applications tab in the Sound Preferences window, or the Applications tab in the Volume Control window.

There are other issues around pulseaudio but I am finding it pretty good once I found my way around it. One glaring problem is that only output is initiated by default and the user has to set the Profile to duplex to get a microphone to work. Not a good first impression.

Changed in pulseaudio (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Tony Espy (awe) wrote :

Based on Daniel's comment, this really sounds like an alsa-utils bug, not a pulseaudio bug.

Jerone Young (jerone) wrote :

The issue here is that what your average user is exposed to is what is in the gnome-volume-control.

If for some reason (what ever that reason is) someone or something changes the alsamixers. Users will be changing the controls in the gnome-volume-mixer and nothing will be happening to resolve their issue.

A simple way to resolve this is to reset the alsa levels on reboot. So if a person does fall into this situation they can get out by simply rebooting.

On Thu, Oct 1, 2009 at 7:50 PM, Jerone Young <email address hidden> wrote:
> A simple way to resolve this is to reset the alsa levels on reboot. So
> if a person does fall into this situation they can get out by simply
> rebooting.

That's actually exactly where the culprit lies. There's a race in when
alsactl store is being called. I'm debugging this now.

gheevaari (msdosdos) wrote :

This may not be the place sorry am very new to ubuntu pulseaudio ? problem pulse sound is good but i still need trebel & Bass
and Everytime i play song in totem or rhythmbox or any other my headphone sound becomes one speaker .Ok Go In terminal write alsamixer and then set headphone 1 volume up then set headphone LFE 1 to off and center 1 to off .solves the problem but wait as soon as next song plays i have to do same headphone lfe1 to off ,headphone center to off .Now Isnt there something to set this headphone lfe 1 to off and center to off .Please Help alsactl store does not work in this situation and am new to ubuntu been searching for months for some kind of solution am now very tired .soundcard is creative soundblaster 5.1 with Live Drive with front headphone, aux2 in optical in /out midi in/out 2 microphone and spdif in/out .Can You Help Please

lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 RAID bus controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 13)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 8400 GS] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
03:06.1 Input device controller: Creative Labs SB Live! Game Port (rev 08)
in ubuntu 9.10

Cyril Jaquier (cyril-jaquier) wrote :

I expect to have the same audio settings before and after boot. So resetting to some default values is not a good idea at all I think.

I have a desktop with audio inputs/outputs in front and behind the case. The front levels are separated from the other levels and I can only change those levels using alsamixer. In karmic, the front levels are always set to 0 which is definitely not a good idea as I need to use alsamixer to change the levels. The pulseaudio sound preferences dialog does not allow me to change this setting.

Jerone Young (jerone) wrote :

Marking oem-priority as fixed as pulse audio will now reset to some default level if the alsamixer is tweaked.

@Cyril this would be a pulseaudio issue and probably an alsa one. You probably want to try and install package
"linux-backport-modules-alsa-karmic-generic".

Changed in oem-priority:
status: New → Fix Released
Daniel T Chen (crimsun) wrote :

No alsactl component involved here.

Changed in alsa-utils (Ubuntu):
status: New → Invalid
Daniel T Chen (crimsun) wrote :

Fixed in lucid

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers