[SRU][live-build] can not customize the mkisoimage option

Bug #1864426 reported by Leon Liao on 2020-02-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
hugh chao
Focal
High
hugh chao
live-build (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]

Although live build has been used in both oem and foundation team, but the main different is that:

--Foundation--
Only for squashfs, cd-image will be used after that, the iso image created by live build will not be used directly.

--OEM--
Oem team uses live build in whole process which includes several binary hooks, and the final image created by live build will be used directly.

So the problem is that currently the iso image which created by live build doesn't support uefi boot,
so when we build a support uefi bootable image, the mkisoimage needs extra options.

[Test Case]
With below options in any live build config (oem team put it in <config>/common), an uefi bootable image can be built.

ISOHYBRID_OPTIONS="--uefi"
GENISOIMAGE_OPTIONS_EXTRA="-eltorito-alt-boot -efi-boot boot/grub/efi.img -no-emul-boot -joliet-long"

[Regression Potential]
Low, oem team has been using this patch for years (from 2012),
we haven't found any potential regression.

Related branches

Leon Liao (lihow731) on 2020-02-24
tags: added: oem-priority somerville
hugh chao (hugh712) on 2020-05-08
Changed in oem-priority:
assignee: Leon Liao (lihow731) → hugh chao (hugh712)
tags: added: stella sutton
hugh chao (hugh712) on 2020-05-12
description: updated
Changed in oem-priority:
status: New → Confirmed
information type: Proprietary → Public
hugh chao (hugh712) on 2020-05-18
summary: - [live-build] can not customize the mkisoimage option
+ [SRU][live-build] can not customize the mkisoimage option
hugh chao (hugh712) wrote :

upload debdiff for focal

Changed in oem-priority:
status: Confirmed → In Progress
hugh chao (hugh712) on 2020-05-18
description: updated
description: updated
tags: added: verification-needed-focal

The attachment "3.0~a57-1ubuntu39.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
hugh chao (hugh712) on 2020-05-19
description: updated
description: updated
Łukasz Zemczak (sil2100) wrote :

I have sponsored this patch for both groovy and focal just now. Note to the SRU team: I know this basically is a new feature instead of a bugfix, but I think it should be thought more like a HWE change. It is very important that the OEM team, working on OEM images, uses the same tooling as we use via the archive. Removing the delta here should be important even here. So I think this should be considered for accepting as an SRU for focal (for the upcoming point-releases).

Changed in live-build (Ubuntu):
status: New → Fix Committed
hugh chao (hugh712) wrote :

@Łukasz

Thanks, let's wait for next point-releases.

Changed in oem-priority:
status: In Progress → Fix Committed

Hello Leon, or anyone else affected,

Accepted live-build into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/live-build/3.0~a57-1ubuntu38.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in live-build (Ubuntu):
status: Fix Committed → Fix Released
Changed in live-build (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed
hugh chao (hugh712) wrote :

tried to build the oem image with this version and below config

ISOHYBRID_OPTIONS="--uefi"
GENISOIMAGE_OPTIONS_EXTRA="-eltorito-alt-boot -efi-boot boot/grub/efi.img -no-emul-boot -joliet-long"

there are two partitions in the images and can boot from the usb sticker correctly.

tags: added: verification-done-focal
removed: verification-needed-focal
Łukasz Zemczak (sil2100) wrote :

Thanks for the swift verification!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers