[SRU] Need backport-iwlwifi-dkms in Bionic

Bug #1856024 reported by You-Sheng Yang on 2019-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
backport-iwlwifi-dkms (Ubuntu)
Undecided
You-Sheng Yang
Bionic
Undecided
Unassigned

Bug Description

backport-iwlwifi-dkms is already in Eoan/Focal. We are requested to enable this wifi in 18.04 so we need this package in Bionic as well.

No possible regression as this is a new and independent package in Bionic.

Proposed PPA in https://launchpad.net/~vicamo/+archive/ubuntu/ppa-1856024.

You-Sheng Yang (vicamo) on 2019-12-11
description: updated
Changed in backport-iwlwifi-dkms (Ubuntu):
status: New → In Progress
You-Sheng Yang (vicamo) wrote :

Need sponsor for uploading fix in the PPA.

Timo Aaltonen (tjaalton) on 2019-12-20
Changed in backport-iwlwifi-dkms (Ubuntu):
status: In Progress → Fix Released
Alex Tu (alextu) on 2020-01-03
Changed in oem-priority:
importance: Undecided → Critical

Hello You-Sheng, or anyone else affected,

Accepted backport-iwlwifi-dkms into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/backport-iwlwifi-dkms/7906-0ubuntu3~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in backport-iwlwifi-dkms (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
You-Sheng Yang (vicamo) wrote :

Verified against following kernels:

  * 4.15.0-73-generic
  * 4.15.0-1066-oem
  * 5.0.0-37-generic
  * 5.0.0-1033-oem-osp1
  * 5.3.0-26-generic (to add OBSOLETE_BY=5.0.0)

You-Sheng Yang (vicamo) wrote :

Since 5.3 hwe kernel has been landed to Bionic, and this (7906) would fail 11n AP association on 5.3 kernels, I'm marking this as verification-failed-bionic and will upload another revision to disable compiling this dkms against kernel 5.0 or above.

tags: added: verification-failed-bionic
removed: verification-needed verification-needed-bionic
You-Sheng Yang (vicamo) wrote :

Depending on changes in bug 1859389.

Anthony Wong (anthonywong) wrote :

5.3 HWE kernel is still in -proposed, so 7906-0ubuntu3~18.04.1 doesn't have immediate impact. More importantly 7906-0ubuntu3~18.04.1 is needed to fix bug 1859472 so we should get it out of the door as soon as possible and then fix bug 1859389 in next SRU.

You-Sheng Yang (vicamo) on 2020-01-14
tags: added: verification-done-bionic
removed: verification-failed-bionic

The verification of the Stable Release Update for backport-iwlwifi-dkms has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Timo Aaltonen (tjaalton) wrote :

the package never left the new queue, so the archive version wasn't tested

tags: added: verification-needed-bionic
removed: verification-done-bionic
Timo Aaltonen (tjaalton) wrote :

apparently it was downloaded directly from lp

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backport-iwlwifi-dkms - 7906-0ubuntu3~18.04.1

---------------
backport-iwlwifi-dkms (7906-0ubuntu3~18.04.1) bionic; urgency=critical

  * Initial release (LP: #1856024).
    - Sync from Eoan 7906-0ubuntu3.

 -- You-Sheng Yang <email address hidden> Wed, 11 Dec 2019 16:20:39 +0800

Changed in backport-iwlwifi-dkms (Ubuntu Bionic):
status: Fix Committed → Fix Released
Elvis Stansvik (elvstone) wrote :

Hi folks. I'm on bionic and got a desktop notification about "closed drivers may be necessary..." when this SRU landed in bionic-updates.

Just to check: I only really need this package if I'm suffering from https://bugs.launchpad.net/ubuntu/+source/backport-iwlwifi-dkms/+bug/1859472 ? If I don't really have any issues with wifi, I can ignore the `backport-iwlwifi-dkms` package and use the `iwlwifi` driver that I already have from `linux-modules-extra-5.0.0-37-generic`?

Or is it recommended for everyone to install this package?

Elvis Stansvik (elvstone) wrote :

(Forgot to say in my previous post, I'm using the HWE kernel, so 5.0.0-37 currently)

Yes, please ignore that message as we're to land another commit to disable
the build against kernel 5.0 or above.

Elvis Stansvik <email address hidden> 於 2020年1月15日 週三 17:20 寫道:

> (Forgot to say in my previous post, I'm using the HWE kernel, so
> 5.0.0-37 currently)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1856024
>
> Title:
> [SRU] Need backport-iwlwifi-dkms in Bionic
>
> Status in OEM Priority Project:
> New
> Status in backport-iwlwifi-dkms package in Ubuntu:
> Fix Released
> Status in backport-iwlwifi-dkms source package in Bionic:
> Fix Released
>
> Bug description:
> backport-iwlwifi-dkms is already in Eoan/Focal. We are requested to
> enable this wifi in 18.04 so we need this package in Bionic as well.
>
> No possible regression as this is a new and independent package in
> Bionic.
>
> Proposed PPA in
> https://launchpad.net/~vicamo/+archive/ubuntu/ppa-1856024.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oem-priority/+bug/1856024/+subscriptions
>

Elvis Stansvik (elvstone) wrote :

Alright, thanks Yang, makes sense.

Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers