Shell dialog messages are truncated and ellipsized...

Bug #1809788 reported by Yuan-Chen Cheng on 2018-12-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
OEM Priority Project
High
Marco Trevisan (Treviño)
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
High
Marco Trevisan (Treviño)
Disco
High
Marco Trevisan (Treviño)
yaru-theme (Ubuntu)
High
Carlo Lobrano

Bug Description

[ Impact ]

When plugging in a Thunderbolt device, under certain conditions, there could be a pop-up window asking for authentication from the user.

In the dialog box, the prompt text is truncated. Please refer to attached screen shot for more details.

The issue can be found in the gnome-control-center package for bionic:
1:3.28.2-0ubuntu0.18.04.2
1:3.28.1-0ubuntu1

However, the issue is confirmed to be gone in latest such package for Cosmic:
1:3.30.2-1ubuntu0.18.10.1

[ Test case ]

In a terminal run:
 $ boltctl enroll foo

Text in the auth message should not be cut, using both Ubuntu theme, Yaru or default gnome-shell

[ Regression Potential ]

The dialogs text is wrapped when not needed, or dialog text isn't ellipsized when requested.

Related branches

Yuan-Chen Cheng (ycheng-twn) wrote :
Changed in oem-priority:
importance: Undecided → High
status: New → Confirmed
Yuan-Chen Cheng (ycheng-twn) wrote :

can't be reproduced in 18.10.

summary: - TBT authentication message will be cut from the dialog box
+ bionic - TBT authentication message will be cut from the dialog box
tags: added: bionic
Chih-Hsyuan Ho (chih) on 2019-01-17
description: updated

that looks similar to bug #1721908 , unsure what commit fixed it if it's resolved in 18.10 though

information type: Proprietary → Public
tags: added: desktop-trello-import
tags: removed: desktop-trello-import

Testing on current 3.30 version in disco it doesn't seems to be fixed to me, can you make a screenshot showing how it's like for your on 18.10?

Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Can anyone please point out the command to simulate the same issue to happen?

Sebastien Bacher (seb128) wrote :

@Marco, Laney pointed out the other day than using 'boltctl enroll foo' was enough without needing the hw

Yeah, disco isn't fixed either here.

Changed in gnome-shell (Ubuntu):
status: New → Triaged
Changed in gnome-shell (Ubuntu Bionic):
status: New → Triaged

Ok, this is somewhat theme related.
See: https://imgur.com/a/SSsYBfO

So adding yaru.

no longer affects: yaru-theme (Ubuntu Bionic)
Changed in yaru-theme (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Carlo Lobrano (c-lobrano)
Daniel van Vugt (vanvugt) wrote :
summary: - bionic - TBT authentication message will be cut from the dialog box
+ Shell dialog messages are truncated and ellipsized...
Daniel van Vugt (vanvugt) wrote :

I can't see any history of a fix. But it's only reported in 3.28 here and 3.30 upstream...?

Daniel van Vugt (vanvugt) wrote :

I would say remove Yaru here. The theme can't directly control whether the dialog is too small and needs wrapping. Although it can control the dialog size indirectly with some tweaks, but doing that would be a hack.

I think this is a pure Gnome Shell bug.

Changed in gnome-shell:
status: Unknown → New
Changed in yaru-theme (Ubuntu):
status: Triaged → Invalid
Changed in gnome-shell (Ubuntu):
status: Triaged → In Progress
Changed in gnome-shell (Ubuntu Bionic):
status: Triaged → In Progress
status: In Progress → Triaged
description: updated
Changed in gnome-shell (Ubuntu Disco):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
no longer affects: yaru-theme (Ubuntu Disco)
Changed in gnome-shell (Ubuntu Bionic):
status: Triaged → In Progress
Changed in oem-priority:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Changed in gnome-shell:
status: New → Fix Released
Iain Lane (laney) wrote :

I'm going to upload this to bionic before it's fixed in disco/eoan. There we're giving upstream a couple of days to release 3.32.2 which will contain this. SRU person, If you happen to review this before then, hope that's OK. :-)

Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package gnome-shell - 3.32.2-1ubuntu1

---------------
gnome-shell (3.32.2-1ubuntu1) eoan; urgency=medium

  * Merge with Debian. Remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      - Show monitor scaled cursor when magnifier is enabled

gnome-shell (3.32.2-1) experimental; urgency=medium

  * New upstream release
    - Fix ellipsization in dialog subtitles/bodies (LP: #1809788)
    - Don't ...

Read more...

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released

Hello Yuan-Chen, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.4-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

 apt-cache policy gnome-shell
gnome-shell:
  Installato: 3.28.4-0ubuntu18.04.1
  Candidato: 3.28.4-0ubuntu18.04.1
  Tabella versione:
 *** 3.28.4-0ubuntu18.04.1 100

Message is fully visible here

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.4-0ubuntu18.04.1

---------------
gnome-shell (3.28.4-0ubuntu18.04.1) bionic; urgency=medium

  * New upstream stable release
    - Fix ellipsization in dialog subtitles/bodies (LP: #1809788)
    - dnd: Only handle touch events in wayland (LP: #1817020)
    - windowManager: listen actively to windows being destroyed during WS switch
      (LP: #1812527)
    - Fix unresponsive-app dialog blocking input in other windows (LP: #1740869)
    - Fix regression on missing spread animation (LP: #1827284)
  * d/p/js-fix-invalid-access-errors.patch,
    d/p/js-ui-Choose-some-actors-to-cache-on-the-GPU.patch:
    - Refreshed
  * d/p/switchMonitor-switch-to-next-config-upon-initial-keypress.patch
    - Ensure switch display mode is cyclic (LP: #1772811)
  * debian/control:
    - Depends on mutter 3.28.4-0ubuntu18.04.1
  * d/p/st-widget-Add-missing-g_return_val_if_fail.patch:
    - st-widget: Protect from NULL obj in get_theme_node (LP: #1796606)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 10 May 2019 11:43:10 +0100

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Yuan-Chen, or anyone else affected,

Accepted gnome-shell into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.32.2-2ubuntu1~ubuntu19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
removed: verification-done
tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Gold Star (goldstar611) wrote :

I don't think "the bug" is fixed (It looks that way because the dialog shows only a single line)

bolt ctl doesn't provide a long enough dialog, try my bug at https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1721908

Gold Star (goldstar611) wrote :

I booted the wrong iso. 19.10 daily is indeed fixed. Sorry for the confusion.

Gold Star,

Are you using gnome-shell 3.32.2-2ubuntu1~ubuntu19.04.1 ?

Check with
  $ apt-cache policy gnome-shell

Gold Star (goldstar611) wrote :

Hi Marco,

Both 19.04 and 19.10 have the same Disco Dingo background so I used the wrong VM without noticing.

Non fixed gnome-shell (19.04) has package version 3.32.0+git20190410-1ubuntu1
Fixed gnome-shell (19.10 daily build) has package version gnome-shell 3.32.2-2ubuntu1

Launchpad Janitor (janitor) wrote :
Download full text (6.9 KiB)

This bug was fixed in the package gnome-shell - 3.32.2-2ubuntu1~ubuntu19.04.1

---------------
gnome-shell (3.32.2-2ubuntu1~ubuntu19.04.1) disco; urgency=medium

  * No-change SRU backport from eoan to disco. (LP: #1834517)

gnome-shell (3.32.2-2ubuntu1) eoan; urgency=medium

  * Merge with Debian. Remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      - Show monitor scaled cursor when magnifier is enabled

gnome-shell ...

Read more...

Changed in gnome-shell (Ubuntu Disco):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.