need backport the new scancode of dell-wmi for Microphone mute hotkey to xenial

Bug #1738153 reported by Alex Tu on 2017-12-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Status tracked in Xenial
Xenial
Critical
Alex Tu
systemd (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Dimitri John Ledkov
Artful
Undecided
Dimitri John Ledkov

Bug Description

[Impact]
dell-wmi expend the scan code of Microphone mute hotkey from 0x150 to 0x100150, so need to add a new mapping for it.

related commit:
https://github.com/systemd/systemd/pull/5012

[Test Case]
1. install the udev package which applied patch.
2. check if Microphone mute hotkey works.
3. if it not works, please provide the log of evtest.

[Regression Potential]
low regression potential, because it just add one more mapping.

also affect:
LP: #1736352
LP: #1740080
LP: #1734609

Alex Tu (alextu) on 2017-12-14
Changed in udev (Ubuntu):
assignee: nobody → Alex Tu (alextu)
description: updated
Alex Tu (alextu) on 2017-12-18
Changed in udev (Ubuntu):
status: New → Confirmed
Alex Tu (alextu) wrote :
Alex Tu (alextu) wrote :

and the deb packages could be get from ppa:alextu/test , systemd - 229-4ubuntu21oem1

Alex Tu (alextu) on 2017-12-19
Changed in udev (Ubuntu):
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

How critical is the fix? I'm asking because systemd is a big component triggering lots of autopkgtests, requiring a lot of shepherding for it to get to the archive (many tests fail and need to be retried etc.). Usually we bundle up a few fixes at once so that the time spent is worth the effort. For important fixes however we can consider getting this in as is.

What's the severity of the bug? How many users are affected and how does it impact them?

Alex Tu (alextu) wrote :

This issue happens to all xenial, zesty dell platform users who updated kernel to the one after 4.8.0. Because the root cause is the change of dell-wmi kernel module [1]

And this is a cert blocking issue for OEM projects.
How long will this kind SRU be in your experience ?

[1] https://github.com/torvalds/linux/commit/e075b3c898e4055ec62a1f0ed7f3b8e62814bfb6

Alex Tu (alextu) on 2017-12-20
Changed in udev (Ubuntu):
status: In Progress → Confirmed
Leon Liao (lihow731) on 2017-12-26
description: updated
description: updated
Changed in udev (Ubuntu):
importance: Undecided → High
Simon Quigley (tsimonq2) wrote :

I'm resubscribing Łukasz Zemczak and unsubscribing ~ubuntu-sponsors for now because he's the last person to evaluate this as an SRU and there's nothing to sponsor quite yet.

Thanks!

Alex Tu (alextu) wrote :

looks this patch is missed in recently update[1],
as I said in #4, this issue will impact *all* user who updated their kernel.
The Microphone mute hotkey will be failed then.

[1] https://paste.ubuntu.com/p/NQMXTMzVbN/

Alex Tu (alextu) wrote :

btw,
it's already in bionic by this commit : https://github.com/systemd/systemd/pull/5012/commits/5d14ba02c4c2e09a9b158412a0912d0493e3b90f
And also checked systemd 237-3ubuntu4 in bionic included that patch.

the target of this launchpad ticket is to backport it to xenial.

Changed in udev (Ubuntu):
assignee: Alex Tu (alextu) → nobody
Łukasz Zemczak (sil2100) wrote :

Let me reach out to xnox to see if he's planning another systemd SRU after the current one migrates into -updates. If yes, maybe we can have him bundle up this change. If not, we can just release this one fix then.

Dimitri John Ledkov (xnox) wrote :

Please do not assign bugs to udev source package, it has been long time merged into systemd source package.

Yeah, I can cherry-pick this for SRUs.

no longer affects: udev (Ubuntu)
no longer affects: udev (Ubuntu Xenial)
Changed in systemd (Ubuntu):
status: New → Fix Released
Changed in systemd (Ubuntu Xenial):
status: New → Confirmed
Changed in systemd (Ubuntu Artful):
status: New → Confirmed
Changed in systemd (Ubuntu Xenial):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in systemd (Ubuntu Artful):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in systemd (Ubuntu Artful):
status: Confirmed → Won't Fix
Changed in systemd (Ubuntu Xenial):
status: Confirmed → In Progress
Robie Basak (racb) wrote :

> low regression potential, because it just add one more mapping.

The patch uploaded also removes the old mapping. Is there any possibility that this will regress some users? How would one test for this?

Hello Alex, or anyone else affected,

Accepted systemd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/229-4ubuntu21.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in systemd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
cktenn (cktenn) wrote :

Verified fixed on DP/N BRM5-DVT1-C2H with xenial-proposed
Image: dell-bto-xenial-breckenridge-mlk-cfl-X46-20180705-128.iso

There's also one thing to mention; it has to reboot twice before the fix to take effect.

tags: added: verification-done-xenial
removed: verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers