switching to activated guest session causes screen blank

Bug #1405349 reported by TienFu Chen on 2014-12-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
Trusty
Undecided
Unassigned
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Committed
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Medium
Marco Trevisan (Treviño)

Bug Description

Hi,
I switch to activated guest session, but the screen remains blank. I have to wake it up with keyboard/mouse action.

How to reproduce:
1. login with your account normally.
2. switch to guest session from the panel menu "Switch Account... -> Guest Session", now it's under guest session and the display is normal.
3. switch back to your user account, then switch to guest session again.
4. The screen remains blank.

Another method:
1. sudo true && gdbus call --session --dest org.gnome.ScreenSaver \
     --object-path /com/canonical/Unity/Session --method \
     com.canonical.Unity.Session.ActivateScreenSaver && \
     sleep 1 && sudo chvt 1 && sleep 1 && sudo chvt 7

I can't reproduce this issue under Precise.
Vivid snapshot 22-Mar-2015 can also reproduce this issue.

[Test Case]
1. Run:
sudo true && gdbus call --session --dest org.gnome.ScreenSaver \
     --object-path /com/canonical/Unity/Session --method \
     com.canonical.Unity.Session.ActivateScreenSaver && \
     sleep 1 && sudo chvt 1 && sleep 1 && sudo chvt 7
2. Wait few seconds
3. Make sure the screen is black
4. When restored on tty7, the screen should be not blank anymore

[Regression Potential]
None

Package:
lightdm 1.10.3-0ubuntu2
unity-settings-daemon-14.04.0+14.10.20140606~0ubuntu1
---
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-stella-datong140729-kylin-trusty-amd64-20150205-2DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2015-02-09 (1 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20150205-07:08
LightdmConfig:
 [SeatDefaults]
 autologin-guest=false
 autologin-user-timeout=0
 autologin-session=lightdm-autologin
Package: lightdm 1.10.3-0ubuntu2
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.13.0-38.65stella1-generic 3.13.11.8
Tags: trusty third-party-packages
Uname: Linux 3.13.0-38-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Related branches

TienFu Chen (ctf) on 2014-12-24
summary: - switch to activated guest session cause screen blank
+ switching to activated guest session causes screen blank
TienFu Chen (ctf) on 2014-12-24
description: updated
Ara Pulido (ara) wrote :

TienFu, can you run "apport-collect 1405349"?

Changed in oem-priority:
status: New → Incomplete

apport information

description: updated
tags: added: apport-collected third-party-packages trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

Changed in oem-priority:
status: Incomplete → Confirmed
Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in lightdm:
status: New → Confirmed
TienFu Chen (ctf) wrote :

Tested with latest Vivid 22-Mar-2015 image, this issue be reproduced too.

description: updated
description: updated
Robert Ancell (robert-ancell) wrote :

The appropriate part from lightdm.log seems to be:
[+148.35s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: Interrupted system call

i.e. We requested the VT switch but perhaps it didn't occur?

Robert Ancell (robert-ancell) wrote :

I'm not able to reproduce this locally, could you try the following branch and see if it fixes it (for trusty)?
$ sudo apt-get build-dep lightdm
$ bzr branch lp:~robert-ancell/lightdm/lp1405349
$ cd lp1405349
$ bzr-buildpackage
And install the appropriate .deb files from ../build-area

TienFu Chen (ctf) wrote :

@Robert:
I have built the package and tested on a system, but problem remains.
The /var/log/lightdm directory is attached for your reference.

I think it's not a machine-specified issue. I can duplicate it on many machines on my site.

TienFu Chen (ctf) wrote :

Continue #12,
the packages I installed from the build are:
liblightdm-gobject-1-0_1.10.5-0ubuntu1_amd64.deb
lightdm_1.10.5-0ubuntu1_amd64.deb

Robert Ancell (robert-ancell) wrote :

The logs indicate that the VT switch is probably still not occurring. Can you check if when you end up on a blank screen you can get back to your session by doing the VT switch with the alt+ctrl+F keys?

Also, do you go to a greeter and enter your password before returning to the user session?

Exactly what hardware are you reproducing the problem on? What video cards / drivers? I'm at a sprint and trying with the laptops here and no-one seems to be able to reproduce. We are finding that switching is running slower than we'd expect but we always get back to the guest session.

Robert Ancell (robert-ancell) wrote :

Oh, I misread the initial report. I can confirm the guest session isn't active until you move the mouse.

Robert Ancell (robert-ancell) wrote :

This is not actually caused by LightDM - when you make the guest session active (via logind) it doesn't appear to detect this and turn the screen on.

To reproduce:
1. Login with your account normally.
2. Switch to guest session from the panel menu "Switch Account... -> Guest Session"
3. Switch back to your user account.
4. Find the guest session ID by running loginctl, i.e.
$ loginctl
   SESSION UID USER SEAT
        c4 1000 bob seat0
        c1 135 guest-4aZrXA seat0
5. Switch to the guest session, i.e.
$ loginctl activate c1

Observed result:
The screen is black until the mouse moves

Expected result:
The desktop is shown immediately

Robert Ancell (robert-ancell) wrote :

I'm thinking something like unity-settings-daemon should be picking up that the session has become active and enable the screen.

Robert Ancell (robert-ancell) wrote :

More investigation shows that this is actually a Unity bug. The black screen you are seeing is the lock screen but Unity doesn't have a lock screen when in guest mode. The lock screen is triggered when you switch users via the indicator.

You can also trigger this by typing alt+ctrl+L inside the guest session. It will show a black screen that disappears when you move the mouse.

The solution should be that Unity does nothing when the lock screen is requested to be activated.

no longer affects: lightdm
affects: lightdm (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity (Ubuntu Trusty):
status: New → In Progress
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Trusty):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
status: New → In Progress
milestone: none → 7.3.3
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150627.1-0ubuntu1

---------------
unity (7.3.2+15.10.20150627.1-0ubuntu1) wily; urgency=medium

  [ Andrea Azzarone <email address hidden> ]
  * Fix a regression with urgent icons not showing up if launcher is
    hidden. (LP: #1450991)
  * Make sure new icons are added to the model before calling
    SortAndUpdate. (LP: #1458950)
  * This likely could fix
    https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1451613. At
    least the backtraces posted there suggest this. But I think that
    those backtraces are just leftovers of old crashes-on-unloading.

  [ CI Train Bot ]
  * New rebuild forced.

  [ Chris Townsend ]
  * Allow mouse clicks that are not in the visible area of the Quicklist
    to pass through down to the Launcher icon. Fixes a failing AP test.
    (LP: #1456245)

  [ Luke Yelavich ]
  * Implement filter results controls accessibility (LP: #1457071)

  [ Marco Trevisan (Treviño) ]
  * ApplicationManager: add missing features, keep a copy of views
    around
  * DecorationsForceQuitDialog: remove deprecated override style
    functions, use CSS
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT
    changes (LP: #1405349)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires
    a redraw (LP: #1461618)
  * PanelMenuView: connect to target window / application title changes
    (LP: #1418449)

 -- CI Train Bot <email address hidden> Sat, 27 Jun 2015 04:44:56 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
tags: added: rls-w-incoming
Sebastien Bacher (seb128) wrote :

one part of the issue got fixed, the screen is still blanked if you switch users using the indicator though...

Andrea Azzarone (azzar1) on 2015-10-23
description: updated
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello TienFu, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

Installed and tested all 3 patched 𝐔𝐧𝐢𝐭𝐲 𝟕 version 7.2.6+14.04.20151021-0ubuntu1 packages on 𝐔𝐛𝐮𝐧𝐭𝐮 𝟏𝟒.𝟎𝟒𝐋𝐓𝐒 "Trusty". I did 3 Test Cases:

[𝐓𝐞𝐬𝐭 𝐂𝐚𝐬𝐞 𝟏]
Ran
sudo true && gdbus call --session --dest org.gnome.ScreenSaver \
     --object-path /com/canonical/Unity/Session --method \
     com.canonical.Unity.Session.ActivateScreenSaver && \
     sleep 1 && sudo chvt 1 && sleep 1 && sudo chvt 7

Result: 𝐒𝐮𝐜𝐜𝐞𝐬𝐬. Doesn't show blank screen forever, shows LockScreen on waiting a few seconds.

[𝐓𝐞𝐬𝐭 𝐂𝐚𝐬𝐞 𝟐]
1. login with your account normally.
2. switch to guest session from the panel menu "Switch Account... -> Guest Session", now it's under guest session and the display is normal.
3. switch back to your user account, then switch to guest session again.

Result: 𝐒𝐮𝐜𝐜𝐞𝐬𝐬. Shows Guest Session without needing to wake up the screen. Shows Login Screen when switching back to main user.

[𝐓𝐞𝐬𝐭 𝐂𝐚𝐬𝐞 𝟑]
Method proposed by @robert-ancell . Triggered LockScreen on Guest Session by typing Super+L inside the guest session.

Result: 𝐒𝐮𝐜𝐜𝐞𝐬𝐬. Well, it's not a blank screen (sleeping screen) anymore but a black screen with mouse pointer visible.

With the new Unity passing all test cases, I think I verified it for inclusion in SRU.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Since the fixed Unity 7.2.6 package is now released to trusty-updates, I'm marking this bug as "Fix Released" for Unity .2

Ara Pulido (ara) on 2016-05-30
Changed in oem-priority:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers