Active/Active specs are not passing the specs tox test

Bug #1620914 reported by Michael Johnson on 2016-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
octavia
Fix Released
High
Stephen Balukoff

Bug Description

The active/active specs for version0.9 are failing the specs tests in tox. tox -e specs produces:

======================================================================
FAIL: test_template (specs-tests.test_titles.TestTitles)
specs-tests.test_titles.TestTitles.test_template
----------------------------------------------------------------------
_StringException: Traceback (most recent call last):
  File "specs-tests/test_titles.py", line 108, in test_template
    self._check_titles(titles)
  File "specs-tests/test_titles.py", line 57, in _check_titles
    self.assertEqual(7, len(titles))
  File "/home/michjohn/projects/fixspec/octavia/.tox/specs/local/lib/python2.7/site-packages/testtools/testcase.py", line 411, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/home/michjohn/projects/fixspec/octavia/.tox/specs/local/lib/python2.7/site-packages/testtools/testcase.py", line 498, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: 7 != 1

There are extra sections that are causing the tests to fail.

Fix proposed to branch: master
Review: https://review.openstack.org/367611

Changed in octavia:
status: New → In Progress

Reviewed: https://review.openstack.org/367611
Committed: https://git.openstack.org/cgit/openstack/octavia/commit/?id=dad4504f9c08d81abf6cee58979e9cd84a9d373f
Submitter: Jenkins
Branch: master

commit dad4504f9c08d81abf6cee58979e9cd84a9d373f
Author: Stephen Balukoff <email address hidden>
Date: Thu Sep 8 13:15:08 2016 -0700

    Fix active-active specs tox test

    The recently-merged active-active specifications did not pass the
    specs tox test. This commit makes minor adjustments to the formatting
    and sectioning of these documents so that they now pass the tox test.

    Change-Id: Ic8319c6940cb7ffcb185e7c35c4ec536ad19107f
    Closes-Bug: #1620914

Changed in octavia:
status: In Progress → Fix Released

This issue was fixed in the openstack/octavia 0.9.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers