OCS Inventory NG Agent for Windows

Installer creates incomplete ocsinventory.ini

Reported by Holger Schletz on 2011-07-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OCS Inventory: Windows Agent
Medium
Didier Liroulet

Bug Description

The 2.0.0.22 installer creates an ocsinventory.ini like this:

[OCS Inventory Agent]
ComProvider=ComHTTP.dll
Debug=0
Local=
HKCU=0
NoTAG=1
IpDisc=
[OCS Inventory Service]
TTO_WAIT=0

All important information like SERVER is missing. As a consequence, the agent has no information about the server to contact once the installer has finished, effectively cutting it off with no means to fix it remotely.

2.0.0.20 with the same options behaves correctly.

This is the command line I used:

OCS-NG-Windows-Agent-Setup.exe /S /SERVER=myserver.example.com/ocsinventory /NOSPLASH /notag /NO_SYSTRAY

The Problem also occurs with interactive setup.

description: updated
Gerold Gruber (gruber-citkomm) wrote :

same problem with 2.0.0.22 installer here

Gerold Gruber (gruber-citkomm) wrote :

my cmdline:
OCS-NG-Windows-Agent-Setup /S /NOSPLASH /NO_SYSTRAY /SSL=0 /SERVER=http://myserver.example.org/ocsinventory /NOTAG /TAG=clients.internal.domain

Didier Liroulet (dliroulet) wrote :

Hy Gerold.

I've found the problem.

It appears when you install a new agent specifying TAG in the command, but without using /NOW parameter.

In the case, all config is written except TAG value, because agent end before executing the code :(

Version 2.0.0.24 fix this.

https://bugs.launchpad.net/ocsinventory-windows-agent/+bug/754410/+attachment/2206211/+files/OCSNG-Windows-Agent-2.0.0.24.zip

Could you please chek if the problem is solved for you ?

Cheers

Changed in ocsinventory-windows-agent:
assignee: nobody → Didier Liroulet (dliroulet)
importance: Undecided → Low
importance: Low → Medium
status: New → Confirmed
status: Confirmed → Fix Committed
Didier Liroulet (dliroulet) wrote :

Sorry Gerold, answered here to bug Bug #802625 .

But, agent 2.0.0.24 also fixes your problem ;-)

It comes from a changes into ComHTTP.dll export function declaration to fix agent crash in some cases.

Could you check agent 2.0.0.24 works for you ?

Cheers

Gerold Gruber (gruber-citkomm) wrote :

looks good so far, but we tested only win7_64 and XP so far without proxy.

We will have to check with proxy configuration on Monday.

Gerold Gruber (gruber-citkomm) wrote :

tests with proxy also ok

Didier Liroulet (dliroulet) wrote :

Thanks a lot Gerold

Changed in ocsinventory-windows-agent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers