OBLogout - Advanced Openbox Logout Script

doesn't always exit before suspend

Reported by wmdiem on 2009-01-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OBLogout
Medium
Andrew Williams

Bug Description

I've noticed that sometimes (no particular pattern) when coming back from a suspend I come back to the Logout menu and have to hit cancel to get to the desktop (also in these cases the screen lock isn't up). I assume this is because the "self.dbus_powermanagement.Suspend(0)" gets issued before the "self.quit()", and sometimes it takes effect before the program has a chance to exit (or before gnome-screen-saver comes up. I wonder whether this could be avoided by forking a background process that just pauses long enough for the parent to quit before issuing the suspend.

Related branches

Andrew Williams (nikdoof) wrote :

This seems to be a issue with the dbus call timing out due to the suspend and erroring the function, and not running the self.quit() function. This can be avoided by using a try/except on the dbus call to catch any timeout errors which should normally occur (as the program will usually not receive the response before the system suspends).

Changed in oblogout:
importance: Undecided → Medium
milestone: none → 0.2.0
status: New → Confirmed
assignee: nobody → nikdoof
Andrew Williams (nikdoof) wrote :

Fixed in the latest 0.2 revision.

Changed in oblogout:
status: Confirmed → Fix Committed
Changed in oblogout:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers