Warning: `font-lock-beginning-of-syntax-function' is an obsolete variable (as of Emacs 23.3)

Bug #659158 reported by nurikabe on 2010-10-12
64
This bug affects 14 people
Affects Status Importance Assigned to Milestone
nXhtml
Medium
Unassigned

Bug Description

Warning popping up. Seeing this in the October 11 build of 24.0.50.1

Warning: `font-lock-beginning-of-syntax-function' is an obsolete variable (as of Emacs 23.3); use `syntax-begin-function' instead.
Warning: `font-lock-syntactic-keywords' is an obsolete variable (as of Emacs 24.1); use `syntax-propertize-function' instead.

lborgman (lennart-borgman) wrote :

Thanks nurikabe, I have noticed this, but I am not sure how to fix it. It looks rather simple but I want to ensure backward compatibility in this case.

Changed in nxhtml:
importance: Undecided → Medium
status: New → In Progress
Changed in nxhtml:
status: In Progress → Fix Committed
Changed in nxhtml:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Reuben Thomas (rrt) wrote :

I am still getting this bug and I've updated with vcs-web-nxhtml. What am I missing?

Mathias Nohr (fitschn) on 2012-01-25
Changed in nxhtml:
status: Fix Committed → Fix Released
Marc Bowes (marcbowes) wrote :

This bug still affects me. I'm using the tip of emacsmirror/nxhtml from github [1] and my emacs version is GNU Emacs 24.2.1. This is extremely annoying since it opens a warning buffer for every new buffer I open.

[1] https://github.com/emacsmirror/nxhtml/commit/bcfc026d5136763efc3eeeb66e89c00de31f9814

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers