"nw_fermi" driver not working in Ubuntu version 12.04

Bug #977255 reported by Jolani Pexa on 2012-04-09
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nwfermi
Undecided
djp

Bug Description

Hi,

I've been successfully running the "nw_fermi" driver to operate the touch screen of my HP Touchsmart computer.

Yesterday I upgraded to the Ubuntu version 12.04 and it's no longer working.

Any idea?

Regards,

Jolani

On 04/09/2012 07:32 AM, Jolani Pexa wrote:
> Public bug reported:
>
> Hi,
>
> I've been successfully running the "nw_fermi" driver to operate the
> touch screen of my HP Touchsmart computer.
>
> Yesterday I upgraded to the Ubuntu version 12.04 and it's no longer
> working.
>
> Any idea?
The driver and daemon seems working even though I built driver by myself.
The X driver doesn't get built. I probably will try to fix it next week.

>
> Regards,
>
> Jolani
>
> ** Affects: nwfermi
> Importance: Undecided
> Status: New
>

BaneTBI (dalton-justin) wrote :

Any update on this, I'm trying to get ubuntu to work on my HP TouchSmart and I can't seem to get it to work.

Mario Hoffmann (mssn-hoffmann) wrote :

It's the same Problem like last Dist Upgrade

[ 59.696] (EE) module ABI major version (12) doesn't match the server's version (16)
[ 59.696] (II) UnloadModule: "nextwindow"
[ 59.696] (II) Unloading nextwindow
[ 59.696] (EE) Failed to load module "nextwindow" (module requirement mismatch, 0)
[ 59.696] (EE) No input driver matching `nextwindow'

regards Mario

jcgeny (grml4d) wrote :

i have the same problem with ubuntu 12.04 and a hp touchsmart , it seems that xf86-input-nextwindow has not been updated .
as far as i found it is here : http://ppa.launchpad.net/djpnewton/xf86-input-nextwindow/ubuntu/dists/
i ll check here when solution is found

djp (djpnewton) on 2012-05-09
Changed in nwfermi:
assignee: nobody → djp (djpnewton)
status: New → Confirmed
Mario Hoffmann (mssn-hoffmann) wrote :

djp made an rebuild / update for the 32bit precise System. Thanks for that.

But i work with an 64bit System.

djp (djpnewton) wrote :

The 64 bit build is now complete, the build server was just taking its sweet time

Changed in nwfermi:
status: Confirmed → Fix Released
Jiandong Zheng (ezjd) wrote :

X input drive has problem which prevents X from starting in armhf build using same source for Precise.

Here is the Xorg.0.log, and stopped at ""Adding extended input device "Nextwindow Fermi Touchscreen"
[ 28.675] (II) config/udev: Adding input device Nextwindow Fermi Touchscreen (/dev/input/event2)
[ 28.675] (**) Nextwindow Fermi Touchscreen: Applying InputClass "evdev pointer catchall"
[ 28.676] (**) Nextwindow Fermi Touchscreen: Applying InputClass "nw fermi"
[ 28.676] (II) LoadModule: "nextwindow"
[ 28.676] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 28.895] (II) Module nextwindow: vendor="X.Org Foundation"
[ 29.352] compiled for 1.11.3, module version = 0.3.2
[ 29.352] Module class: X.Org XInput Driver
[ 29.352] ABI class: X.Org XInput driver, version 16.0
[ 29.352] (II) Using input driver 'nextwindow' for 'Nextwindow Fermi Touchscreen'
[ 29.352] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 29.353] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 29.353] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 29.353] (**) Option "Device" "/dev/input/event2"
[ 29.353] (II) Nextwindow Fermi Touchscreen: Using device /dev/input/event2.
[ 29.353] (**) Option "UseTouchHelp" "1"
[ 29.353] (II) Nextwindow Fermi Touchscreen: Using touch help.
[ 29.353] (**) Option "DragThreshold" "10"
[ 29.353] (**) Option "RightClickTimeout" "1200"
[ 29.353] (**) Option "DoubleClickTimeout" "500"
[ 29.398] (**) Option "config_info" "udev:/sys/devices/virtual/input/input2/event2"
[ 29.398] (II) XINPUT: Adding extended input device "Nextwindow Fermi Touchscreen" (type: UNKNOWN, id 9)

Thomas Wink (poedts) wrote :

For me the same problem. After installing the driver the computer becomes unresponsive .

I installed xf86-input-nextwindow 0.3.3 precise via ppa, no problems there. But after installing nwfermi-0.6.5.0_amd64.deb and rebooting my system got stuck. I had to go to recovery mode, go to root shell and uninstall nwfermi with apt-get. After that I continued with normal boot and the touchscreen was working, allthough the screen resolution was low and I was no able to login. After rebooting the system works as normal, but without touchscreen functionality.

Below my Xorg.0.log.
[ 99.807] (II) config/udev: Adding input device Nextwindow Fermi Touchscreen (/dev/input/event8)
[ 99.807] (**) Nextwindow Fermi Touchscreen: Applying InputClass "evdev pointer catchall"
[ 99.807] (**) Nextwindow Fermi Touchscreen: Applying InputClass "nw fermi"
[ 99.807] (II) LoadModule: "nextwindow"
[ 99.807] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 99.807] (II) Module nextwindow: vendor="X.Org Foundation"
[ 99.807] compiled for 1.11.3, module version = 0.3.2
[ 99.807] Module class: X.Org XInput Driver
[ 99.807] ABI class: X.Org XInput driver, version 16.0
[ 99.807] (II) Using input driver 'nextwindow' for 'Nextwindow Fermi Touchscreen'
[ 99.807] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 99.807] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 99.807] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 99.807] (**) Option "Device" "/dev/input/event8"
[ 99.807] (II) Nextwindow Fermi Touchscreen: Using device /dev/input/event8.
[ 99.807] (**) Option "UseTouchHelp" "1"
[ 99.808] (II) Nextwindow Fermi Touchscreen: Using touch help.
[ 99.808] (**) Option "DragThreshold" "10"
[ 99.808] (**) Option "RightClickTimeout" "1200"
[ 99.808] (**) Option "DoubleClickTimeout" "500"
[ 99.808] (**) Option "config_info" "udev:/sys/devices/virtual/input/input8/event8"
[ 99.808] (II) XINPUT: Adding extended input device "Nextwindow Fermi Touchscreen" (type: UNKNOWN, id 16)

Download full text (4.1 KiB)

Hi,

I have a ubuntu 12.04, and samsung syncmaster ld220z touchscreen monitor.

When I attach the usb cable from monitor to my pc, I get a black screen: my system still works (I can access to ssh service), but X seems stops to work.. no way to come back from this black screen, I have to deatach the usb cable and reboot my pc .

this is my screen id:
Bus 001 Device 005: ID 1926:0288 NextWindow

these are my packages:
Package: xf86-input-nextwindow
Priority: extra
Section: libs
Installed-Size: 77
Maintainer: daniel newton <email address hidden>
Architecture: i386
Version: 0.3.3~precise1
Depends: libc6 (>= 2.1.3), xserver-xorg-core
Filename: pool/main/x/xf86-input-nextwindow/xf86-input-nextwindow_0.3.3~precise1_i386.deb
Size: 8852
MD5sum: 1f3b1fc4687a300d95992689ea56174c
SHA1: 50acc1fd20a70eaf243f07cd18fe9b87f38a0d4a
Description: Nextwindow Xorg input driver for nwfermi

Package: nwfermi
Status: install ok installed
Priority: optional
Section: restricted/misc
Installed-Size: 200
Maintainer: Daniel Newton <email address hidden>
Architecture: i386
Version: 0.6.5.0
Provides: nwfermi
Depends: make, sed (>> 3.0), dkms, linux-libc-dev, libc6-dev, linux-headers-generic | linux-headers, patch, xf86-input-nextwindow
Description: The driver for the NextWindow 1950/3000 Touch Screens

these are the last lines of Xorg.0.log:
[ 1219.633] (II) config/udev: Adding input device Nextwindow Fermi Touchscreen (/dev/input/mouse2)
[ 1219.634] (II) No input driver specified, ignoring this device.
[ 1219.634] (II) This device may have been added with another device file.
[ 1219.634] (II) config/udev: Adding input device Nextwindow Fermi Touchscreen (/dev/input/event11)
[ 1219.634] (**) Nextwindow Fermi Touchscreen: Applying InputClass "evdev pointer catchall"
[ 1219.634] (**) Nextwindow Fermi Touchscreen: Applying InputClass "nw fermi"
[ 1219.634] (II) LoadModule: "nextwindow"
[ 1219.634] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 1219.634] (II) Module nextwindow: vendor="X.Org Foundation"
[ 1219.634] compiled for 1.11.3, module version = 0.3.2
[ 1219.634] Module class: X.Org XInput Driver
[ 1219.634] ABI class: X.Org XInput driver, version 16.0
[ 1219.634] (II) Using input driver 'nextwindow' for 'Nextwindow Fermi Touchscreen'
[ 1219.634] (II) Loading /usr/lib/xorg/modules/input/nextwindow_drv.so
[ 1219.634] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 1219.634] (**) Nextwindow Fermi Touchscreen: always reports core events
[ 1219.634] (**) Option "Device" "/dev/input/event11"
[ 1219.634] (II) Nextwindow Fermi Touchscreen: Using device /dev/input/event11.
[ 1219.634] (**) Option "UseTouchHelp" "0"
[ 1219.634] (**) Option "DragThreshold" "10"
[ 1219.634] (**) Option "RightClickTimeout" "1000000000"
[ 1219.634] (**) Option "DoubleClickTimeout" "1000000000"
[ 1219.664] (**) Option "config_info" "udev:/sys/devices/virtual/input/input11/event11"
[ 1219.664] (II) XINPUT: Adding extended input device "Nextwindow Fermi Touchscreen" (type: UNKNOWN, id 12)

these lines are from dmesg:
[ 1218.071819] input: Nextwindow Fermi Touchscreen as /devices/virtual/input/input11
[ 1218.073006] nwfermi 3-1.3:1.0: NextWindow...

Read more...

On 05/10/2012 12:06 AM, Thomas Wink wrote:
> For me the same problem. After installing the driver the computer
> becomes unresponsive .
>
> I installed xf86-input-nextwindow 0.3.3 precise via ppa, no problems
> there. But after installing nwfermi-0.6.5.0_amd64.deb and rebooting my
> system got stuck. I had to go to recovery mode, go to root shell and
> uninstall nwfermi with apt-get. After that I continued with normal boot
> and the touchscreen was working, allthough the screen resolution was low
> and I was no able to login. After rebooting the system works as normal,
> but without touchscreen functionality.
>
My problem is only with X input driver, which causes X fails to start,
probably because the dkms driver was rebuilt.

jcgeny (grml4d) wrote :

same as Jiandong Zheng , pc stops at ubuntu screen
starting from new install of os , i added xorg-input-evographix [i use evo in synaptic to find it , its last in the list , so name may be wrong] , then utouch , then update the os and reboot.
i install xf86-input-nextwindow_0.3.3~precise1_amd64.deb and after nwfermi-0.6.5.0_amd64.deb

i saw that nwfermi downloads 76 Mo [ i read that it needs ia32-libs] but what files do your files download ?

i see some opening windows but i can not read them as they close too fast .

ciriffo (piccoccio) wrote :

same as Thomas Vink, non problem in installing xf86-input-nextwindow 0.3.3 precise via ppa; after installing nwfermi-0.6.5.0_amd64.deb the touch started working for a while, but very soon stopped working. after rebooting the screen was black.
ubuntu 12.04 on hp touchsmart 520-1020it; the touch worked fine on the same pc using Ubuntu 11.10.

aleshribar (ales-hribar) wrote :

Comment next line in /etc/udev/rules.d/40-nw-fermi.rules to get touchscreen working:

#ACTION=="add|change", SUBSYSTEM=="input", ATTRS{name}=="Nextwindow Fermi Touchscreen", ENV{NAME}="nextwindow", ENV{ID_INPUT.tags}

Secondary mouse button emulation not working though.

jcgeny (grml4d) wrote :

aleshribar (ales-hribar) had found the bug ;']
p.s. : my comment above has an error , name is : xserver-xorg-input-elographics

Mario Hoffmann (mssn-hoffmann) wrote :

After i Comment the ACTION Line. See Comment #13 from ales-hribar, the X starts.

But the Screen is not useable. It seens the remove the mouse Icon.

djp (djpnewton) wrote :

there is now a new build of xf86-input-nextwindow for 12.04 https://launchpad.net/~djpnewton/+archive/xf86-input-nextwindow/+packages

Jiandong Zheng (ezjd) wrote :

This works OK. Thanks!

ciriffo (piccoccio) wrote :

it works ok for me too. thanks!

Rodolfo Saccani (rsaccani) wrote :

I use encfs (which is based on fuse). After installing xf86-input-nextwindow and nwfermi-0.6.5.0_amd64.deb encfs stopped working complaining that there was no fuse support in the kernel.
After removing xf86-input-nextwindow and nwfermi, encfs started working again.

Thomas Wink (poedts) wrote :

As of today the touchscreen is working. System AMD64, Ubuntu 12.04 precise with nextwindow 0.3.4 and latest nwfermi driver.

Thomas Wink (poedts) wrote :

spoke too soon. after suspend touchscreen stops working. have to reboot to make it work.

Oh well, thanks a lot any way

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments