NVIDIA 173 driver Unable to load X Server Display Configuration page in settings

Bug #882134 reported by blitzd on 2011-10-26
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned

Bug Description

The default NVIDIA driver that Ubuntu 11.10 uses does not appear to allow any configuration of the X server display settings, and has the following error on the nvidia-settings page where you would configure display options:

Unable to load X Server Display Configuration page:

Failed to query NoScanout for screen 0.

This error has occured on my laptop as well as my desktop.

Switching to 'current' appears to resolve the issue, however that driver has other issues of it's own. The 173 driver previously functioned properly on 10.10 and 11.04 on both my laptop and my desktop.

blitzd (blitzd) wrote :

re-filed to the proper project

affects: unity → nvidia-drivers-ubuntu
MauRice (dalmagro) wrote :

Same problem here with 11.10, 32bits and 64bits.

Have a Geforge 7300GS,
With the 173 driver Unity3D works but can not configure the xorg.conf file -> Failed to query NoScanout for screen 0

With the current (280) driver Unity3D do't work. I have a Desktop, but nothing in it works. Within Unity2D I can configure the xorg.conf file working with the 280 driver.

With other distro's on the same DekstopPC I have no problems using the current (280) nVidia driver.

Bhavesh Nande (bhaveshnande) wrote :

Same here with Ubuntu 11.10 Oneiric Ocleot 64-bit. A fix was released for Lucid https://bugs.launchpad.net/ubuntu/lucid/+source/nvidia-settings/+bug/539196 but not for Oneiric.

wribeiro (wribeiro) wrote :

In Ubuntu 11.10 no way to change screen resolution, no way to apply a second monitor.
NVidia X Server Settings gives the message "Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0." when the item "X Server Display Configuration" is selected.
Driver 'current' doesn't work, causes a blank screen all the time.

HP Pavilion NVidia Graphics
Ubuntu 11.10 i386

I have installed 11.10 today in my desktop, replacing 11.04 by this new release of Ubuntu. However, I have some issues with my screen resolution. As posted above, when I open Nvidia X Server Settings, I go to X Server Display Configuration in order to change the screen resolution , but I get the following message:

Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0.

This did't happen with Natty, so I'm very surprised.

My system properties are:

Ubuntu 11.10 (amd 64)
Graphics: Nvidia GeForce 6200/AGP/SSE2
Nvidia Graphics Controller: GeForce 6200/AGP/SSE2 (version 173).

I hope you can help us to solve this trouble.

Regards.
Roberto.

Hi. I have installed the 'current version (recommended)' of the driver, and everything is ok now. However, I expect to be able to install the latest version of the driver without having problems.

Hope this can help for now.

Regards.

bewresu (bewresu) wrote :

This seems to be the same as bug 834529.

I am affected by this problem as well.

NVIDIA FX 5500
Nvidia Version 173.14.30
Ubuntu 11.10

Hope this helps.

Butterfly (kelebek333) wrote :

I solve this problem with install nvidia-settings 270.29 from archive.ubuntu.com

for 32 bit

wget archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_270.29-0ubuntu1_i386.deb
sudo dpkg -i nvidia-settings*

for 64 bit

wget archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_270.29-0ubuntu1_amd64.deb
sudo dpkg -i nvidia-settings*

vince (vince06fr) wrote :

same issue for me
thanks kelebek333 for yhe trick

Sud B (basaks) wrote :

{code}
wget archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_270.29-0ubuntu1_amd64.deb
sudo dpkg -i nvidia-settings*
{code}

This is the only thing that worked for me.

Cerin (chrisspen) wrote :

Just upgraded a Macbook Pro from Ubuntu 10.04 to 11.10.

Everything was working under 10.04, but now most video driver related features are gone. The entire UI is slow, I'm unable to dim the screen or use multiple monitors.

Trying to run the Nvidia Settings tool gives me the error:

Unable to load X Server Display Configuration page:

Failed to query NoScanout for screen 0.

Cerin (chrisspen) wrote :

Using the "Additional Drivers" dialog to activate the "current-updates" Nvidia driver seems to have resolved all major problems for me.

Thomas Bonte (toemaz) wrote :

Thx kelebek333, worked flawless on my Dell Latitude D620

piotr zimoch (ebytyes) on 2013-05-15
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Tonal (tonal-promsoft) wrote :

NVIDIA NV34 GeForce FX 5200
nvidia-173 - version 173.14.39
Ubuntu 14.04

thanks kelebek333 for the trick, worked on ubuntu 11.10 nvidia driver 173

Buford T. Justice (btjustice) wrote :

Using kelebek333's fix, I had to do this on a computer running Ubuntu MATE 14.04.2 LTS with a NVIDIA FX 5200...

For 64-bit:

wget http://archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_295.33-0ubuntu1_amd64.deb
sudo dpkg -i nvidia-settings*

For 32-bit:

wget http://archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_295.33-0ubuntu1_i386.deb
sudo dpkg -i nvidia-settings*

Buford T. Justice (btjustice) wrote :

EDIT...

Wrong version in my post above. Use this one instead...

For 64-bit:

wget http://archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_195.36.08-0ubuntu2_amd64.deb
sudo dpkg -i nvidia-settings*
sudo nvidia-settings

For 32-bit:

wget http://archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/nvidia-settings_195.36.08-0ubuntu2_i386.deb
sudo dpkg -i nvidia-settings*
sudo nvidia-settings

Check here for different versions...

http://archive.ubuntu.com/ubuntu/pool/main/n/nvidia-settings/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers