Unable to resolve function glX...

Reported by Graham Inggs on 2010-06-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.04 amd64 / nvidia graphics driver 195.36.15

DesignModeler in ANSYS Workbench 12.1 starts with an empty Model View window.
The following error messages appear in the terminal:
Unable to resolve function glXQueryExtension
Unable to resolve function glXMakeCurrent
Unable to resolve function glXUseXFont

The Model View window works correctly after downloading and installing version 195.36.15 of the driver from Nvidia here:
http://www.nvidia.com/object/linux_display_amd64_195.36.15.html

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: nvidia-current 195.36.15-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.35-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Jun 3 16:14:17 2010
DkmsStatus:
 nvidia-current, 195.36.15, 2.6.32-21-generic, x86_64: installed
 nvidia-current, 195.36.15, 2.6.32-22-generic, x86_64: installed
 vboxnetflt, 3.2.0, 2.6.32-22-generic, x86_64: installed
 vboxdrv, 3.2.0, 2.6.32-22-generic, x86_64: installed
 vboxnetadp, 3.2.0, 2.6.32-22-generic, x86_64: installed
MachineType: System manufacturer System Product Name
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=44c73484-34ae-4bc9-a23a-f885b8672f14 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_ZA.utf8
 SHELL=/bin/bash
SourcePackage: nvidia-graphics-drivers
dmi.bios.date: 12/30/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4N72-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd12/30/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4N72-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-22-generic

Graham Inggs (ginggs) wrote :
description: updated
Graham Inggs (ginggs) wrote :

I've discovered that ANSYS DesignModeller expects to find libGL.so.1 in /usr/lib/.
The following solved my problem:

 sudo ln -s /usr/lib/nvidia-current/libGL.so.1 /usr/lib/libGL.so.1

I agree with Graham.
Conceptually you have to find where is your libGL.so.1 and then create a dynamic link in /usr/lib/.
In my case i have Ansys WB 12.1 on a Sony-Vaio laptop with ATI Radeon Video card and O.S. Ubuntu 10.04 Desktop for X86-64 and i solved the problem this way:

sudo ln -s /usr/lib/fglrx/libGL.so.1 /usr/lib/libGL.so.1

Andy Barr (ajbarr) wrote :

his bug also affects Altair's HyperView software. The above work around fix the the problem. I would be interested to know why the libGL.so.1 was moved when compared to Ubuntu 9.10.

Stefano Rivera (stefanor) wrote :

libGL.so is provided by multiple packages: mesa, nvidia, ati. In the past, it used to use the alternatives system to select the GL library. The current approach since (and including) lucid is to install a configuration file in /etc/ld.so.conf.d that instructs the linker to look in /usr/lib/$PROVIDER. It sounds like these packages have a fixed library search path.

I don't know if there's an easy workaround besides the provided one.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Won't Fix
Chris Halse Rogers (raof) wrote :

Right. The current alternatives system via ld.so.conf.d is easier to maintain and a bit less fragile than our previous system.

It does have the problem that software with a fixed search path, or that doesn't use the linker, will not work. For those, I suggest the symlink workaround. We can't easily or reliably provide this workaround in the packages, but it's safe for systems where you know the hardware.

I'm marking this as Wont Fix for this reason.

afrodoc (arsenovic) wrote :

have a similar program with the mesa drivers, using different program: Ansolft HFSS.
i tried to use the sym link work-around without success

the error from hfss on the command line is

Unable to resolve function glXQueryExtension

my links are

> ls -al /usr/lib/libGL*
lrwxrwxrwx 1 root root 22 2010-08-12 14:40 /usr/lib/libGL.so -> /usr/lib/mesa/libGL.so
lrwxrwxrwx 1 root root 24 2010-08-12 14:41 /usr/lib/libGL.so.1 -> /usr/lib/mesa/libGL.so.1
lrwxrwxrwx 1 root root 26 2010-08-12 14:41 /usr/lib/libGL.so.1.2 -> /usr/lib/mesa/libGL.so.1.2
lrwxrwxrwx 1 root root 20 2010-06-22 08:56 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.070701
-rw-r--r-- 1 root root 461488 2010-04-29 01:54 /usr/lib/libGLU.so.1.3.070701

this problem arose when i upgrade from 9.10 to 10.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers