Nux

compiz crashed with SIGSEGV in nux::WindowCompositor::DndEventCycle()

Bug #1363959 reported by David on 2014-09-01
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Marco Trevisan (Treviño)
Trusty
Fix Committed
High
Marco Trevisan (Treviño)
nux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

An occasional unpredictable crash in the Unity shell occurs during a drag-and-drop operation.

[Test Case]

Unfortunately it is not possible to reproduce this bug at will. Apparently is is caused by an uninitialized pointer dereference that only occurs in a timing-dependent manner.

Running a full autopilot test suite against the Unity desktop shell reveals no new regressions.

[Regression Potential]

The code change effectively adds a test for a null pointer. It is possible that this might introduce a regression in drag-and-drop functionality that previously relied on undefined behaviour to work when it didn't crash.

[Other Info]

Fix was released with Ubuntu 14.10 and no new regressions have been reported.

Related branches

David (davidluksenburg) wrote :

StacktraceTop:
 nux::WindowCompositor::DndEventCycle (this=0x85131b0, event=...) at ./WindowCompositor.cpp:287
 nux::WindowCompositor::ProcessEvent (this=0x85131b0, event=...) at ./WindowCompositor.cpp:1164
 nux::WindowThread::DoProcessEvent (this=0x84b6b40, event=...) at ./WindowThread.cpp:730
 nux::WindowThread::ProcessEvent (this=0x84b6b40, event=...) at ./WindowThread.cpp:665
 nux::nux_event_dispatch (user_data=0x84b6b40) at ./MainLoopGLib.cpp:133

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in nux:
status: New → Confirmed
no longer affects: compiz (Ubuntu)
Changed in nux:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
milestone: none → 4.0.7
status: Confirmed → In Progress
information type: Private → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.7+14.10.20141007-0ubuntu1

---------------
nux (4.0.7+14.10.20141007-0ubuntu1) utopic; urgency=low

  [ Marco Trevisan (Treviño) ]
  * WindowCompositor: don't try to use an null dnd_area pointer (LP:
    #1363959)
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 14:14:14 +0000

Changed in nux (Ubuntu):
status: New → Fix Released
Changed in nux:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-11-10
Changed in nux (Ubuntu Trusty):
status: New → In Progress
Stephen M. Webb (bregma) on 2014-11-18
description: updated
Stephen M. Webb (bregma) wrote :

debdiff between the version in trusty-updates and the proposed SRU containing the fix

Hello David, or anyone else affected,

Accepted nux into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nux/4.0.6+14.04.20141107-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nux (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: removed: ubuntu
tags: added: verification-done
removed: verification-needed

This crash has no real reproduction case, so marked this verification-done since:

1. It's been in Utopic for a couple of months now (and Vivid too) with no new crashes reported or regressions.
2. I've been running this package since it's been in the ci-train PPA (and -proposed after that) with no new regressions seen.

The verification of the Stable Release Update for nux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.6+14.04.20141107-0ubuntu1

---------------
nux (4.0.6+14.04.20141107-0ubuntu1) trusty; urgency=low

  [ Marco Trevisan (Treviño) ]
  * WindowCompositor: don't try to use an null dnd_area pointer (LP:
    #1363959)
 -- Ubuntu daily release <email address hidden> Fri, 07 Nov 2014 15:52:02 +0000

Changed in nux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-08-12
Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.