Nux

unable to type Greek characters to the dash

Bug #1205713 reported by Filippos Kolyvas on 2013-07-27
180
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Brandon Schaefer
2.0
Triaged
High
Brandon Schaefer
Unity
Invalid
High
Brandon Schaefer
nux (Ubuntu)
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

On Ubuntu 13.10 Saucy, when i switch to the Greek layout, i cannot type any greek character to the Dash's search field.
The pointer does not move at all, which means that it is not just an appearance problem, but there is no input at all of the character.
The same applies when i try to use the "Execute command" field that appears when pressing the Alt+F2 keyboard shortcut.
This has only to do wiith greek characters, as other characters that are not related to the keyboard layout (such as numerical characters, dots, comas, hyphens etc) can be typed normally regardless of the keyboard layout setting.

** Workaround **
In the terminal:
  im-config -n xim

Then reboot!

ProblemType: BugDistroRelease: Ubuntu 13.10
Package: unity 7.0.2+13.10.20130723.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-5.15-generic 3.10.2
Uname: Linux 3.10.0-5-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Jul 27 23:02:46 2013
InstallationDate: Installed on 2013-07-12 (15 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130711)
MarkForUpload: TrueSourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Filippos Kolyvas (fkol-k4) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
Simos Xenitellis  (simosx) wrote :

I am also affected by this; using Ubuntu 13.10 with en_US.UTF-8 locale, and unable to type Greek.

Can you see at all the Greek localisation of Unity in 13.10; A Russian translator mentioned that the Russian translation is not visible either. A quick explanation would be if Unity runs under the C locale, which is not a Unicode locale.
If the only characters that can be typed are from ASCII (http://www.asciitable.com/ - NOT extended), then most probably it is a locale issue not supporting the UTF-8 encoding.

Filippos Kolyvas (fkol-k4) wrote :

Ok, i checked some more things:
My locale settings is el_GR.UTF-8. I dont have a problem with the translation visibility, Unity and the Dash are translated in Greek and everything appears as it should, in Greek.
I tried to use the OnBoard screen keyboard to input some greek characters, but summoning the Dash seems to close the OnBoard application (is that a feature or a bug?), so i could not test this.
I also tried to type some ASCII-extended characters (eg the "ϕ" character) using the keyboard, but that was also not possible.
On the other side, copying some text containing greek characters & pasteing it to the Dash search field works. Characters appear as they normally should, and search also works (eg. if i copy a filename with greek characters and paste it to the Dash, the Dash finds it).
Should i add those additional information to the original description?

N1ck 7h0m4d4k15 (nicktux) wrote :

Also as another user in Ubuntu-gr forums indicated, it is strange but when you type a Greek letter with accent then Dash accept this letter.
Only letters with accent can be accepted. e.g. ί ά ό έ

Igor Zubarev (igor.zubarev) wrote :

Confirm the bug for Russian. Affects Russian too.

Stephen M. Webb (bregma) wrote :

I select the Greek keyboard globally and bring up the dash to enter text and the keyboard is forced back to en_US.

Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 7.1.1
Stephen M. Webb (bregma) wrote :

Note that I can cut and paste Greek (or other non-US-ASCII characters) into the dash search box and they work correctly. The problem appears to be in the keyboard handling.

Michael G. Vlachos (mgvlachos) wrote :

affected also.

Stephen M. Webb (bregma) on 2013-07-29
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress

For anyone who wants a quick work around:

im-config -n xim

The overall problem being is the default IM in unity/nux is set to ibus. Nux talks with ibus a bit differently, so if ibus is the active IM then we don't set up xim handling, which means theres no valid x input context. If theres no valid x input context then we can't use XmbLookupString, which handles unicode.

So overall if doing this:
"echo $XMODIFIERS"

prints out:
"@im=ibus"

Then nux things you are running IBus (even if you aren't) and greek will not work!

"imconfig -n xim" will change @im=ibus to @im=xim, then nux will create the correct x input context and greek/unicode stuff will work :).

Sorry about this!

O also, after doing:

im-config -n xim

You'll have to restart X, or reboot :)

description: updated

Also not this is fixed with the new ibus 1.5. So current saucy. What you'll need to do, is ibus-setup then go to Input Methods, and go to greek.

Now to activate/switch between greek and english press Ctrl+Space

Filippos Kolyvas (fkol-k4) wrote :

@ Brandon
Sorry for the late responce, i have a serious case of lack of time lately.

I tried the im-config -n xim workaround, but that didn' t work. The echo $XMODIFIERS command returned nothing when i checked.
Then i tried the ibus-setup fix. That worked like a charm, thank you!
The only thing i have noticed, is that when using the Ctrl+Space shortcut for the ibus, then the copy (ctrl+c), cut (ctrl+x) and paste (ctrl+v) shortcuts work only on English keyboard layout and not in Greek.
Assigning the ibus on the Super+space shortcut, fixed that too.
That of course causes the Launcher to show up for a second when switching layouts, but that's just a minor annoyance.

Can we revert the ibus change so that we can check for the final fix?
Alternatively, is there a way to assign a custom shortcut to the ibus? I usually assign the Caps Lock key for layout switching, is there a way to do that through the ibus too?

Thanks again!

N1ck 7h0m4d4k15 (nicktux) wrote :

I confirm that this problem may be resolved (somehow).
After the recent updates (these included ibus-1.5.3) the only thing I had to do it was to set the Input Method to iBus, then logout and login. → http://i.imgur.com/w1ipLM4.jpg
After this, search in Dash works with Greek letters and with accent also → http://i.imgur.com/4oAr583.jpg

George Macris (georgemakris) wrote :

also affected

Péter Márton (peteremmm) wrote :

I'm hungarian, the only letters I can't use are Ő and Ű. The otheres - Á, É, Í, Ó, Ö, Ü work fine.

This bug is no resolve with the new ibus 1.5.3 which is default in unity 13.10. If you set your keyboard layout to greek it also get selected in ibus, which works with the dash/hud.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Filippos Kolyvas (fkol-k4) wrote :

I'm sorry, i cannot understand what the phrase 'this bug is no resolve' means, does it mean that the bug *will not be resolved*, that *will not be resolved yet* or that *it cannot be resolved*?

The situation now is that we no longer can change the keyboard layout with just one shortcut, but we have to use two.
Also, we cannot set the shortcut just like eny other distribution to Alt+Shift or Caps Lock (that i use), but we have to use the Super key+ simething, so that every time we change the keyboard layout, the Launcher appears.
One other thing, is that the keyboard indication is set to *En* and it does not change even if the keyboard layout changes to *Gr*.

Ok, i'm truly sorry if that sounds (or reads) somewhat saucy (pun fully intended), but this really is not 'fix commited', this is hiding a problem while creating another, possibly bigger one.
I would surely rather not having the option to type in Greek to the Dash, than adding two keys in my keyboard layout shortcut and not beeing able to see what my current layout is.
Any info on what the plans for the matter are, would be appreciated.

George Christofis (geochr) wrote :

What is the progress ?
With the latest daily iso and the Xmir enabled, we still cannot type Greek letters to the Dash or the HUD except of accented letters (έ. ύ, ϋ, ΰ, ί, ϊ, ΐ, ό, ά, ώ) !

Also when the keyboard is set to Greek layout the shortcuts of the ctrl+<any_key> format don't work!
Is it possible to not that we won't be able to use shortcuts for copy, cut, paste etc when typing Greek?

With a such a big malfunction when will we be able to test if all works properly? Is the current bug not enough for the above issues or should we file another one? Would that be an ibus bug?
The next milestone of Unity 7.1.1 was due to 2013-08-15 but has not been released yet. Is any of these matters addressed in it?

@ Brandon Schaefer (brandontschaefer) or anyone else of the developer team, please explain us what exactly the comment #17 means and what we must be prepared for!

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1205713/comments/17

bug is now resolved*

Sorry, missed a w.

So in 13.10, ibus 1.5 is installed by default, which is now always on. This means if you change your keyboard layout to greek, then ibus changes its active keyboard layout as well to greek. Allowing for greek characters in the dash.

All you have to do is change the keyboard layout to greek in current 13.10 from the system settings. If it does not please let me know!

(also make sure you're all updated, "ibus version" should be 1.5.3)

Mikhail Paulyshka (pavlyshko) wrote :

Still can not type cyrillic(russian language) characters in the dash.

After testing it again, it seems ibus is not enabled by default which I thought it was.

Though strangely, if using only XIM it should work anyway...soo there is a problem somewhere I need to look into.

Sorry again everyone!

Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Fix Committed → In Progress

This is broken in xim as well.. very strangely we were getting size 0 when type greek characters? Either way, there is a branch with a fix for nux, and if you use ibus it'll work. Just need to test a few more things before a branch is pushed.

Changed in nux:
status: New → In Progress
Changed in nux (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in nux:
importance: Undecided → High
Changed in nux (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
status: In Progress → Invalid
Changed in unity:
status: In Progress → Invalid
George Christofis (geochr) wrote :

@Brandon Schaefer (brandontschaefer)
Correct, ibus is not enable by default.
The branch in which you are report, is available for testing or we must be waiting ?
Is there something that we can help you ?

@ George

Unless you want to compile nux/unity otherwise it'll be out in the next release (hopefully!) which im not sure when.

I can also look into putting together a ppa so users can use blocked languages now.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:nux at revision None, scheduled for release in nux, milestone 4.0.3

Changed in nux:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.2+13.10.20130829.1-0ubuntu1

---------------
nux (4.0.2+13.10.20130829.1-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Use a temp buf to poke for the size of string vs passing nullptr.
    For some reason this was working for most cases, but not greek.
    Using a temp buf allows us to poke the greeks chars and others that
    werent working. (LP: #1205713)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 812
 -- Ubuntu daily release <email address hidden> Thu, 29 Aug 2013 06:42:50 +0000

Changed in nux (Ubuntu):
status: In Progress → Fix Released
N1ck 7h0m4d4k15 (nicktux) wrote :

Yes, I confirm that this bug has been resolved.
I made the today updates and nux version now is
4.0.2+13.10.20130829.1-0ubuntu1

You have to change the keyboard input to default though,
http://i.imgur.com/Tmt9YHC.jpg

Restart LightDM and should be fine.

Regards
 NikTh

Simos Xenitellis  (simosx) wrote :

@BrandonSchaefer: Could you please have a look at
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1228422

I think we got major regressions from this change.
In a nutshell, IBus does not support features that we have been used to, when we were using the GTK+ IM. For example, accelerators and menu shortcuts do not work anymore.

Is it possible to get IBus enabled only when the app that has the focus is Unity?

Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: 7.1.1 → none
Stephen M. Webb (bregma) on 2013-10-11
Changed in nux:
status: Fix Committed → Fix Released
Nick Kalivas (noe1313) wrote :

Also i cannot type any greek character on Ubuntu 13:10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers