still some accent issues with unity/nux

Reported by Didier Roche on 2012-03-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
High
Marco Trevisan (Treviño)
Unity
High
Marco Trevisan (Treviño)
Unity Distro Priority
High
Unassigned
nux (Ubuntu)
High
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Even with the recent fix, we still get some issues with combined characters:
- open the dash
- press ^
- press ^ again
-> ^ shows as expected
-> press ^ again
-> "^^" is displayed where other toolkits show only one "^" (and then, if you press o, it will shows: "^ô")

worse:
- close now the dash (escape)
- open it again
- press ^
-> ^ will show (still on the hold mode, you need to press "space" or another character so that you can finally enters an "ô"). Even deleting with backspace won't let you exiting this mode.

This is the same with " and other dead keys

Didier Roche (didrocks) on 2012-03-09
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Sebastien Bacher (seb128) wrote :

Confirmed here with today ppa updates

Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2012-03-09
description: updated
Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2012-03-09
Changed in unity-distro-priority:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Fix Committed
Jay Taoko (jaytaoko) wrote :

I haven't been able to reproduce this but on my system. I am using a US keyboard with English as the default language. I may need a French keyboard and a system set with French by default in order to verify.

greg (grigorig) wrote :

I can reproduce this problem with a German deadkey keyboard layout.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in nux:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 6.0
status: Confirmed → In Progress
Changed in nux:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in nux (Ubuntu):
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nux (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux:
milestone: none → 3.2
Changed in unity:
milestone: 6.0 → 6.2
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 3.2.0-0ubuntu1

---------------
nux (3.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - still some accent issues with unity/nux (LP: #950740)
    - nux source bundles tinyxml (LP: #789303)
    - Support for automation (LP: #685199)
    - add alpha function on a NuxBaseWindow (LP: #718827)
    - Timestamp field on the event structure is always 0 (LP: #735645)

  [ Adam Conrad ]
  * Removed debian/patches/02_libgeis_rename.patch

  [ Didier Roche ]
  * debian/control:
    - build-dep on a recent geis
 -- Lukasz 'sil2100' Zemczak <email address hidden> Fri, 10 Aug 2012 11:47:53 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-12-11
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers