compiz crashed with SIGSEGV in g_datalist_id_set_data_full() from ... from unity::PanelTray::~PanelTray() from ... from unity::panel::Controller::Impl::OnScreenChanged

Reported by Craig Magina on 2012-01-25
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Nux
Undecided
Unassigned
Unity
Critical
Marco Trevisan (Treviño)
nux (Ubuntu)
Critical
Marco Trevisan (Treviño)

Bug Description

The crash occured when I disconnected my external vga display.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Tue Jan 24 19:27:25 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x7f6bcccf0b55 <g_datalist_id_set_data_full+341>: mov 0x0(%r13),%esi
 PC (0x7f6bcccf0b55) ok
 source "0x0(%r13)" (0xaaaaaaaaaaaaaaa8) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 g_datalist_id_set_data_full () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 unity::PanelTray::~PanelTray() () from /usr/lib/compiz/libunityshell.so
 unity::PanelTray::~PanelTray() () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in g_datalist_id_set_data_full()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Craig Magina (craig.magina) wrote :
visibility: private → public

StacktraceTop:
 g_data_set_internal (dataset=0x0, new_destroy_func=0, new_data=0x0, key_id=53, datalist=0x90e910) at /build/buildd/glib2.0-2.31.12/./glib/gdataset.c:373
 g_datalist_id_set_data_full (datalist=0x90e910, key_id=53, data=0x0, destroy_func=0) at /build/buildd/glib2.0-2.31.12/./glib/gdataset.c:680
 g_object_real_dispose (object=0x90e900) at /build/buildd/glib2.0-2.31.12/./gobject/gobject.c:1001
 g_object_unref (_object=0x90e900) at /build/buildd/glib2.0-2.31.12/./gobject/gobject.c:2971
 slot_rep (dup__=0x7f6bbcba4b70 <sigc::internal::typed_slot_rep<sigc::bound_mem_functor6<void, unity::PanelMenuView, int, int, int, int, unsigned long, unsigned long> >::dup(void*)>, this=0x17c7420, destroy__=0x7f6bbcba4080 <sigc::internal::typed_slot_rep<sigc::bound_mem_functor6<void, unity::PanelMenuView, int, int, int, int, unsigned long, unsigned long> >::destroy(void*)>, call__=0x17c7420) at /usr/include/sigc++-2.0/sigc++/functors/slot_base.h:84

Changed in nux (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in g_datalist_id_set_data_full()
+ compiz crashed with SIGSEGV in g_data_set_internal()
tags: removed: need-amd64-retrace
Tim Penhey (thumper) on 2012-01-25
Changed in unity:
status: New → Triaged
importance: Undecided → Critical

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-01-27
Changed in nux (Ubuntu):
status: Confirmed → Triaged
importance: Medium → Critical
Didier Roche (didrocks) on 2012-02-01
Changed in nux:
status: New → Triaged
Tim Penhey (thumper) on 2012-02-17
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → backlog
Changed in nux (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in nux:
status: Triaged → Invalid
Changed in nux (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Tim Penhey (thumper) on 2012-03-15
Changed in unity:
milestone: backlog → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
summary: - compiz crashed with SIGSEGV in g_data_set_internal()
+ compiz crashed with SIGSEGV in g_datalist_id_set_data_full() from ...
+ from unity::PanelTray::~PanelTray() from ... from
+ unity::panel::Controller::Impl::OnScreenChanged
Omer Akram (om26er) on 2012-04-02
no longer affects: nux
Changed in unity:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in nux:
status: New → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.10.0-0ubuntu1

---------------
nux (2.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_datalist_id_set_data_full() from ...
      from unity::PanelTray::~PanelTray() from ... from
      unity::panel::Controller::Impl::OnScreenChanged (LP: #921316)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - [dash] Dash does not render "panel line" (LP: #926344)
    - [multi-monitor] DND doesn't work for the launchers in other monitors
      (LP: #965025)
    - Unity dash can't select items using keyboard when ibus is active
      (LP: #973344)
  * debian/rules:
    - remove disable-tests are now tests are only build if the right build-dep
      are here.
  * debian/control:
    - add libxtst-dev as nux Makefile rules are broken and still try to include
      the .h files even if the pc file check failed.
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 15:14:45 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers