Nux

mouse_leave signal is not emitted when a view loses mouse after a button release

Bug #1496140 reported by Marco Trevisan (Treviño) on 2015-09-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Committed
Medium
Marco Trevisan (Treviño)
nux (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

When releasing the mouse over a view that has just taken the mouse control, nux doesn't inform the old mouse owner view about this update.

Related branches

Changed in nux (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.8+15.10.20150921.1-0ubuntu1

---------------
nux (4.0.8+15.10.20150921.1-0ubuntu1) wily; urgency=medium

  [ Stephen M. Webb ]
  * new upstream release 4.0.8
  * debian/control (Standards-Version): bump to 3.9.6 (no changes)

  [ Marco Trevisan (Treviño) ]
  * debian/control:
    - add xserver-xorg-video-dummy as build dependency
    - set libnux-4.0-common arch to all
    - depend on source:Version of libnux-4.0-common

  [ Andrea Azzarone <email address hidden> ]
  * Remove alternative select mainloop. (LP: #1111216)

  [ Marco Trevisan (Treviño) ]
  * WindowCompositor: emit mouse_leave signal when releasing mouse over
    a new area (LP: #1496140)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 21 Sep 2015 17:41:54 +0000

Changed in nux (Ubuntu):
status: In Progress → Fix Released
Changed in nux:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers