Nux

Dash content flickers when the touchpad is used to scroll it.

Bug #1228093 reported by Andrea Azzarone on 2013-09-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Marco Trevisan (Treviño)
Trusty
Fix Committed
Medium
Marco Trevisan (Treviño)
nux (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Nominated for Trusty by Stephen M. Webb
Trusty
Undecided
Unassigned

Bug Description

[Impact]
Dash content flickers when two-finger scrolling on the touchpad

[Test case]
1. Enable two fingers scroll from Unity Control Center -> Mouse and Touchpad
2. Open the unity dash, expand the search results and start scrolling vertically
3. Content should not flicker and should ignore horizontal scroll events

[Regression potential]
Scrolling on dash content does not work properly

Related branches

Andrea Azzarone (azzar1) on 2013-09-20
Changed in nux:
status: New → In Progress
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 4.0.3
Changed in nux (Ubuntu):
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Stephen M. Webb (bregma) on 2013-10-04
Changed in nux:
milestone: 4.0.3 → 4.0.4
Stephen M. Webb (bregma) on 2014-03-15
Changed in nux:
milestone: 4.0.6 → 4.0.7
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.7+14.10.20140731-0ubuntu1

---------------
nux (4.0.7+14.10.20140731-0ubuntu1) utopic; urgency=medium

  [ Stephen M. Webb ]
  * bumped to package version 4.0.7

  [ Christopher Townsend ]
  * Need to add version 1.11 of lcov to the supported versions so the
    Debian package build can succeed. (LP: #1342896)

  [ Brandon Schaefer ]
  * Fixes FTBFS. Remove unused functions. This seems to be brought up
    only in gcc/g++ 4.9. (LP: #1350101)

  [ Marco Trevisan (Treviño) ]
  * ScrollView: correctly handle vertical and horizontal scrolling (LP:
    #1228093)
 -- Ubuntu daily release <email address hidden> Thu, 31 Jul 2014 14:58:52 +0000

Changed in nux (Ubuntu):
status: In Progress → Fix Released
Changed in nux (Ubuntu):
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
Changed in nux:
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
status: In Progress → Fix Committed
description: updated

Hello Andrea, or anyone else affected,

Accepted nux into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nux/4.0.6+14.04.20140930-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nux (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Christopher Townsend (townsend) wrote :

Verified that the Dash is no longer jerky when using two finger scrolling. Horizontal scrolling is ignored.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for nux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.6+14.04.20140930-0ubuntu1

---------------
nux (4.0.6+14.04.20140930-0ubuntu1) trusty; urgency=low

  [ Erkin Bahceci ]
  * Area: always make sure we remove and object from layout queue. (LP:
    #1337244)

  [ Marco Trevisan (Treviño) ]
  * ScrollView: correctly handle vertical and horizontal scrolling. (LP:
    #1228093)
 -- Ubuntu daily release <email address hidden> Tue, 30 Sep 2014 16:05:28 +0000

Changed in nux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-08-12
Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers