Nux

segmentation fault when running nux tests

Bug #1097281 reported by Eleni Maria Stea on 2013-01-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Low
Sam Spilsbury
nux (Ubuntu)
Undecided
Unassigned

Bug Description

I run:
make check
and when the tests start I get the following errors in .xtest-text-entry:
./xtest-text-entry
nux::logging::Writer::Writer()
Nux: Gpu Vendor: Intel Open Source Technology Center
Nux: Gpu Renderer: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
Nux: Gpu OpenGL Version: 3.0 Mesa 9.0
Nux: Gpu OpenGL Major Version: 3
Nux: Gpu OpenGL Minor Version: 0
Nux: The GraphicsEngine is using the GLSL shader code path.
Nux: [IBusIMEContext::IBusIMEContext] Can not connect to ibus
Nux: TextEntry created: Ok
Nux: Typed "Nux": Ok
make[2]: *** [test-apps] Segmentation fault (core dumped)
make[2]: Leaving directory `/shared/common/staging/source/nux/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/shared/common/staging/source/nux/tests'
make: *** [check-recursive] Error 1

Further information:

The test segfaults in the signal handler for SetKeyFocusArea after calling nux::GetWindowThread. This is because the tests unsafely call directly into the program thread from the test thread, so when the signal fires, it attempts to access thread local storage that doesn't exist.

Fixing this requires some framework in nux to communicate with window threads outside of the event system.

Related branches

Changed in nux:
assignee: nobody → Eleni Maria Stea (hikiko)
Changed in nux:
assignee: Eleni Maria Stea (hikiko) → nobody
Changed in nux:
assignee: nobody → Eleni Maria Stea (hikiko)
Changed in nux:
importance: Undecided → Low
Changed in nux:
assignee: Eleni Maria Stea (hikiko) → Sam Spilsbury (smspillaz)
status: New → Confirmed
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:nux at revision None, scheduled for release in nux, milestone 4.0

Changed in nux:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.0daily13.02.26-0ubuntu1

---------------
nux (4.0.0daily13.02.26-0ubuntu1) raring; urgency=low

  [ Sam Spilsbury ]
  * segmentation fault when running nux tests (LP: #1097281)
  * xtest-text-entry-deadkeys SIGABRTs with BadValue XError (LP:
    #1112321)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 762
 -- Automatic PS uploader <email address hidden> Tue, 26 Feb 2013 04:01:53 +0000

Changed in nux (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2013-05-10
Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers