Scrobbling to last.fm

Reported by Andrey Zaytsev on 2011-08-28
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Nuvola Player
Wishlist
Unassigned

Bug Description

Will you add last.fm support?

Changed in google-music-frame:
status: New → Confirmed
importance: Undecided → Wishlist
Jiří Janoušek (fenryxo) wrote :

Next release will support user scripts (now available in daily builds). I have found one providing last.fm support:
http://userscripts.org/scripts/show/108979

Save the script as ~/.local/share/google-music-frame/userscripts/lastfm.js and append the line "user_scripts = lastfm" to ~/.config/google-music-frame/main.conf

The script loads successfully, but I don't have last.fm account to test whole functionality. Can you confirm it works?

Andrey Zaytsev (a-einsam) wrote :

Unfortunately, it isn't work(Maybe only for me?). The script loads, but when I tried to authorize application freezes.

Can you please run "google-music-frame --debug" in terminal and attach
the output when app freezes?

On Mon, Aug 29, 2011 at 01:18, Andrey Zaicev <email address hidden> wrote:
> Unfortunately, it isn't work(Maybe only for me?). The script loads, but
> when I tried to authorize application freezes.
>
> --
> You received this bug notification because you are subscribed to Google
> Music Frame.
> https://bugs.launchpad.net/bugs/836111
>
> Title:
>  Scrobbling to last.fm
>
> Status in Google Music Frame:
>  Confirmed
>
> Bug description:
>  Will you add last.fm support?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/google-music-frame/+bug/836111/+subscriptions
>

Changed in google-music-frame:
status: Confirmed → Incomplete
Andrey Zaytsev (a-einsam) wrote :
Jiří Janoušek (fenryxo) wrote :

It looks like last.fm doesn't support secure connection. To disable secure connection open the configuration file ~/.config/google-music-frame/main.conf and append the line "secure_connection = off" (without quotes).

Andrey Zaytsev (a-einsam) wrote :

Now it works. Thanks.

Jiří Janoušek (fenryxo) wrote :

Good. But after upgrade to the latest build (currently in queue) enable the secure connection again. It's applied only to Google Music domain since revision 27.

Changed in google-music-frame:
milestone: none → 0.2
status: Incomplete → Fix Committed
Jiří Janoušek (fenryxo) wrote :

Released in GMF 0.2

Changed in google-music-frame:
milestone: 0.2 → none
status: Fix Committed → Fix Released
Josh Holland (jshholland) wrote :

I have tried the above with GMF 0.2, but the script does not appear to load. I tried with secure_connection = off, but that didn't make any difference. --debug log attached, as is the user script I am using. I can't see any reference to test/test2 in the script, so I assume this is something inside GMF.

Jiří Janoušek (fenryxo) wrote :

I'm sorry I can't reproduce the issue. Please check whether you lastfm.js is exactly same as attached lastfm2.js

Jiří Janoušek (fenryxo) wrote :

Support of userscripts may be dropped in the future. Last.fm scrobbling has to be implemented as a core feature.

Changed in nuvola-player:
status: Fix Released → Confirmed
dz0ny (janez-troha) wrote :

Here is sample for twitter http://live.gnome.org/Vala/LibSoupSample, I can work on feature if you wish?

Jiří Janoušek (fenryxo) wrote :

Great. You can use GMF.Player.song_changed signal to get the current song and Application.config to store configuration.

Changed in nuvola-player:
assignee: nobody → dz0ny (janez-troha)

Yep, allready found nice lib
http://gitorious.org/glastfm/mainline/blobs/master/glastfm.vala which
should also support gnu-fm variants.

2011/11/20 Launchpad Bug Tracker <email address hidden>:
> Jiří Janoušek (janousek.jiri) has assigned this bug to you for Google Music Frame (Nuvola Player):
>
> Will you add last.fm support?
>
> ** Affects: nuvola-player
>     Importance: Wishlist
>     Assignee: dz0ny (janez-troha)
>         Status: Confirmed
>
> --
> Scrobbling to last.fm
> https://bugs.launchpad.net/bugs/836111
> You received this bug notification because you are a bug assignee.
>

Changed in nuvola-player:
status: Confirmed → In Progress
Jiří Janoušek (fenryxo) wrote :

Will you use this library as a shared library or built-in library?

dz0ny (janez-troha) wrote :

This should be built-in library with:

1. One way authentication(mobile mode)
2. Support for other services, but initially only for last-fm
3. Dependable only on SOUP, JSON libs.
4. Configurable from Options tab

Jiří Janoušek (fenryxo) wrote :

Great :-)

Changed in nuvola-player:
milestone: none → 0.4
Changed in nuvola-player:
milestone: 0.4 → 1.0
Jiří Janoušek (fenryxo) wrote :

What's the progress?

Changed in nuvola-player:
milestone: 1.0 → 1.1
Changed in nuvola-player:
assignee: dz0ny (janez-troha) → nobody
status: In Progress → Confirmed
Changed in nuvola-player:
assignee: nobody → Jiří Janoušek (fenryxo)
Changed in nuvola-player:
status: Confirmed → In Progress
Jiří Janoušek (fenryxo) wrote :

Fixed in trunk, revno 258.

Changed in nuvola-player:
status: In Progress → Fix Committed
assignee: Jiří Janoušek (fenryxo) → nobody
Jiří Janoušek (fenryxo) wrote :

Fix released in Nuvola Player 1.1.0 and 2.0.0.

Changed in nuvola-player:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints