Couldn't play song skipped ahead

Reported by lockheed on 2012-11-14
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nuvola Player
Undecided
Unassigned

Bug Description

Since couple of weeks, Nuvola won't play music any more.

It will attempt to play a song, then output in an orange box near the top of the screen, "COULDN'T PLAY SONG. SKIPPED AHEAD." After skipping a few times, a popup will appear, stating: "Google Play is having trouble reaching the server to play your music. Please try again later."

The music plays just fine if I access the Google Play with some browser like Chrome or Opera.

$ nuvolaplayer --version
Nuvola Player 2.0.1
Revision: 583, <email address hidden>
$ uname -m -p
x86_64 unknown (it's Arch)

$ nuvolaplayer -D -v
    Nuvola Info main.vala:118: Welcome to Nuvola Player, version: 2.0.1
    Nuvola Info main.vala:122: Revision: 583, <email address hidden>
    Nuvola Info main.vala:123: Report any issues/bugs you might find to http://nuvolaplayer.fenryxo.cz/support/bug_reporting.html
    Nuvola Debug main.vala:124: command: /usr/lib/nuvolaplayer/nuvolaplayer -D -v
    Nuvola Debug main.vala:126: Enabled features: Dynamic Proxy Resolver, Disk cache for remote data, Dock Manager support, MPRIS support, console client, support for media keys, optimization of SVG images, Last.fm scrobbling, Notifications, Lyrics fetching
    Nuvola Debug main.vala:127: Disabled features: Unity Quicklist, experimental features, debug symbols
       Gtk Debug Connecting to session manager
    Nuvola Debug main.vala:189: Application activated
   Diorite Debug Max data cache size: 100
   libsoup Warning No feature manager for feature of type 'SoupProxyURIResolver'
   Diorite Debug No proxy settings applied.
   Diorite Debug Action activated: ui-both
    Nuvola Debug servicesmanager.vala:91: Found service Google Play Music at /usr/share/nuvolaplayer/services/googleplay, version 3.2
    Nuvola Debug servicesmanager.vala:91: Found service Google Play Music at /usr/share/nuvolaplayer/services/googleplay, version 3.2
    Nuvola Debug servicesmanager.vala:91: Found service Google Play Music at /usr/share/nuvolaplayer/services/googleplay, version 3.2
    Nuvola Info servicesmanager.vala:104: Using service Google Play Music from /usr/share/nuvolaplayer/services/googleplay, version 3.2
    Nuvola Debug main.vala:456: Starting web interface for googleplay: https://play.google.com/music/listen#Vienna%2520PO%2520(Muti)%20-%20Mozart%2520-%2520Le%2520Nozze%2520di%2520Figaro%2520(Disc%25201)_al
    Nuvola Debug jsapi.vala:438: Reset main object
   Diorite Debug XFCE session vanished: org.xfce.SessionManager
   Diorite Debug GNOME session vanished: org.gnome.SessionManager
    Nuvola Debug jsapi.vala:495: Window object cleared
    Nuvola Debug jsapi.vala:567: JSAPI injected successfully
    Nuvola Debug main.vala:815: Autoplay: false
    Nuvola Debug player.vala:139: Playback state changed: none → paused
    Nuvola Debug player.vala:139: Playback state changed: paused → playing
    Nuvola Debug player.vala:172: Album art changed: null → https://ssl.gstatic.com/music/fe/b0fb0e97ff4bb1ebce74eee156f6201c/default_album_med.png
    Nuvola Debug player.vala:212: Artist changed: null → Vienna PO (Muti)
    Nuvola Debug player.vala:219: Song changed: null → Sinfonia
    Nuvola Debug player.vala:219: Song changed: Sinfonia → Act 1 No.1 Duettino - Cinque...dieci...venti...
    Nuvola Debug mainwindow.vala:165: ~~ Delete event
    Nuvola Debug mainwindow.vala:167: ~~ Queue wanna_quit_cb
    Nuvola Debug mainwindow.vala:173: ~~ wanna_quit_cb
    Nuvola Debug main.vala:676: On close: quit
    Nuvola Debug main.vala:614: Early shutdown
    Nuvola Debug main.vala:637: Late shutdown
    Nuvola Debug main.vala:642: User interface state saved.
    Nuvola Debug main.vala:649: Unparent main_view
    Nuvola Debug main.vala:654: Destroy main_view
    Nuvola Debug main.vala:656: Destroy main_window
    Nuvola Debug main.vala:658: User interface destroyed.
   Diorite Debug Cache.dump()
   Diorite Debug Cache.dump() done

Thanks for taking the time to report this bug. However, I need more
information to investigate it further. Do you have installed a MP3
decoder as described in FAQ #2011?

https://answers.launchpad.net/nuvola-player/+faq/2011

Note to self: probably a duplicate of bug #1029254

  status incomplete

Changed in nuvola-player:
status: New → Incomplete
lockheed (qwrules) wrote :

Yes, I have this MP3 decoder installed (gstreamer0.10-fluendo and gstreamer0.10-fluendo-mp3 package).

Jiří Janoušek (fenryxo) wrote :

> Since couple of weeks, Nuvola won't play music any more.

Did you use the same version of Nuvola Player before the breakage?

What version of libgtk3, libwebkitgtk and libsoup do you use?

Is the issue reproducible in an attached webkitgtk test browser?

lockheed (qwrules) wrote :

I do not recall if it's the same version.

libsoup 2.40.2-1

The other packaged do not exist in Arch.

lockheed (qwrules) wrote :

But whatever I have installed, it is the newest version. After all, this is Arch.

> I do not recall if it's the same version.

Nuvola Player 2.0.1 was released in October 12th. Could you remember
whether the issue did appear after or before this date?

> libsoup 2.40.2-1

Thanks.

> The other packaged do not exist in Arch.

Look for similarly named packages then. I'm sure they exist, but I
don't use Arch, so I don't know exact names.

lockheed (qwrules) wrote :

Well, I haven't used it regularly, but I would say it started sometime around mid-late October.

I cannot find a way to check other library versions, but I tried running google music in Jumanji, which is a webkit browser, and everything works fine in it.

lockheed (qwrules) wrote :

I can tell you my gtk3 is 3.6.2-1 and webkitgtk3-1.10.1-2 so I suppose lib versions are the same.

lockheed (qwrules) wrote :

And webkitgtk2-1.10.1-2

Jiří Janoušek (fenryxo) wrote :

> Well, I haven't used it regularly, but I would say it started sometime
> around mid-late October.

OK.

> I cannot find a way to check other library versions,

You already provided all versions: libsoup 2.40.2-1; gtk3 3.6.2-1;
webkitgtk3 1.10.1-2. Nuvola Player was tested with libsoup 2.40.0;
gtk3 3.6.0; webkitgtk3 1.10.0, so there might be a regression in one
of the libraries NP depends on.

> but I tried running
> google music in Jumanji, which is a webkit browser, and everything works
> fine in it.

OK, but I really need to know, whether the issue is reproducible in
the attached webkitgtk test browser. You probably already have
installed all required build dependencies, so just use the script
build.sh.

https://bugs.launchpad.net/nuvola-player/+bug/1078705/+attachment/3433178/+files/webkitgtkbrowsernoplugins.tar.gz

lockheed (qwrules) wrote :

After running this browser, I get the same issue like in Nuvola.

Not sure it it's relevant, but Nuvola stopped working around the time when I cleaned my system from unused packages (some of which were later re-instelled). Here's the list:
http://pastebin.com/4j3ecaHE

lockheed (qwrules) wrote :

Hi. I wondered if you got some update on that error.

Jiří Janoušek (fenryxo) wrote :

> After running this browser, I get the same issue like in Nuvola.

Webkitgtk seems not to be able to play MP3 audio on your system, so
this is not a bug in Nuvola Player. The issues might be caused by a
bug in

a) upstream libsoup 2.40.2/gtk3 3.6.2/webkitgtk3 1.10.1
b) Arch Linux's libsoup 2.40.2-1/gtk3 3.6.2-1/webkitgtk3 1.10.1-2
c) your configuration

> Not sure it it's relevant, but Nuvola stopped working around the time when I cleaned my system from unused packages (some of which were later re-instelled). Here's the list:
> http://pastebin.com/4j3ecaHE

I don't recognize any library that seems to be necessary for audio playback.

> Hi. I wondered if you got some update on that error.

I'm planning to install a development version of Ubuntu with
webkitgtk3 1.10.1 next week to check option a).

  status new

Changed in nuvola-player:
status: Incomplete → New
Jiří Janoušek (fenryxo) wrote :

The webkitgtk3 1.10.1 seems to use the latest Gstreamer API (1.0
instead of 0.10), so it is necessary to install a MP3 decoder
compatible with Gstreamer 1.0. Could you try to install following
packages (at least one of them should exist)?

gstreamer1.0-fluendo-mp3
gstreamer1-fluendo-mp3
gstreamer1.0-plugins-ugly
gstreamer1-plugins-ugly

  status incomplete

Changed in nuvola-player:
status: New → Incomplete
Andrew Azores (andrew-azores) wrote :

I'm having the same bug, also on x86_64 Arch, also Nuvola 2.0.1 rev 583. I have the same exact problem with Play Music working fine in Chrome. I tried Jumanji as I read on here and it has the same behaviour as in Nuvola. Midori also seems to behave the same as Jumanji and Nuvola. I have installed the following two packages:

gstreamer0.10-fluendo-mp3
gstreamer0.10-ugly-plugins

Which are the closest I can seem to find to the previously listed packages. I don't see Gstreamer 1.0 versions in the Arch official repos nor the User repos (AUR). For Gstreamer itself I seem to have both 0.10 and 1.0.3 installed on my machine.

Jiří Janoušek (fenryxo) wrote :

Thanks for feedback.

> I'm having the same bug, also on x86_64 Arch, also Nuvola 2.0.1 rev 583.
> I have the same exact problem with Play Music working fine in Chrome.

Chrome doesn't have much in common with Nuvola Player, because it uses
different WebKit port and different sound framework, so any testing in
Chrome is not very relevant.

> I
> tried Jumanji as I read on here and it has the same behaviour as in
> Nuvola. Midori also seems to behave the same as Jumanji and Nuvola. I
> have installed the following two packages:

All three programs use WebKitGtk. Since webkitgtk-3.0 1.10.2 in Arch
Linux repository[1][2] was built with gstreamer-1.0, it is necessary
to install codecs for gstreamer-1.0.

[1] https://www.archlinux.org/packages/extra/x86_64/webkitgtk3/
[2] https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/webkitgtk

> I don't see Gstreamer 1.0 versions in the Arch official repos
> nor the User repos (AUR).

It seems Arch Linux developers decided to confuse users and rename the
packages. Could you try to install a package gst-plugins-ugly[3]?

[3] https://www.archlinux.org/packages/extra/x86_64/gst-plugins-ugly/

Andrew Azores (andrew-azores) wrote :

I have installed that package now but it has not resolved the problem.

Jiří Janoušek (fenryxo) wrote :

> I have installed that package now but it has not resolved the problem.

Could you run following commands in terminal and attach output? You
will need a MP3 file for the last two commands. You can download a
song from www.jamendo.com, if you don't have any MP3 file.

gst-inspect-0.10 | grep mp3

gst-inspect-1.0 | grep mp3

GST_DEBUG="*:2,GST_ELEMENT_FACTORY:3,GST_PLUGIN_LOADING:3"
gst-launch-0.10 playbin2 uri=file:///path/to/file.mp3

GST_DEBUG="*:3,GST_ELEMENT_FACTORY:4,GST_PLUGIN_LOADING:4"
gst-launch-1.0 playbin uri=file:///path/to/file.mp3

Andrew Azores (andrew-azores) wrote :

gst-inspect-0.10 | grep mp3
flump3dec: flump3dec: Fluendo MP3 Decoder (C build)
lame: lamemp3enc: L.A.M.E. mp3 encoder
lame: lame: L.A.M.E. mp3 encoder
mad: mad: mad mp3 decoder
mpegaudioparse: mp3parse: MPEG1 Audio Parser
typefindfunctions: application/x-id3v2: mp3, mp2, mp1, mpga, ogg, flac, tta
typefindfunctions: application/x-id3v1: mp3, mp2, mp1, mpga, ogg, flac, tta
typefindfunctions: application/x-apetag: mp3, ape, mpc, wv
typefindfunctions: audio/mpeg: mp3, mp2, mp1, mpga

gst-inspect-1.0 | grep mp3
lame: lamemp3enc: L.A.M.E. mp3 encoder
mad: mad: mad mp3 decoder
typefindfunctions: audio/mpeg: mp3, mp2, mp1, mpga
typefindfunctions: application/x-apetag: mp3, ape, mpc, wv
typefindfunctions: application/x-id3v1: mp3, mp2, mp1, mpga, ogg, flac, tta
typefindfunctions: application/x-id3v2: mp3, mp2, mp1, mpga, ogg, flac, tta

GST_DEBUG="*:2,GST_ELEMENT_FACTORY:3,GST_PLUGIN_LOADING:3"
gst-launch-0.10 playbin2 uri=file:///run/media/(removed rest of file path)
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Missing element: ID3 tag demuxer
WARNING: from element /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder available for type 'application/x-id3'.
Additional debug info:
gsturidecodebin.c(874): unknown_type_cb (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
ERROR: from element /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20: Your GStreamer installation is missing a plug-in.
Additional debug info:
gstdecodebin2.c(3576): gst_decode_bin_expose (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
no suitable plugins found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

GST_DEBUG="*:3,GST_ELEMENT_FACTORY:4,GST_PLUGIN_LOADING:4"
gst-launch-1.0 playbin uri=file:///run/media/(removed rest of file path)
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Missing element: ID3 tag demuxer
WARNING: from element /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0: No decoder available for type 'application/x-id3'.
Additional debug info:
gsturidecodebin.c(880): unknown_type_cb (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0
ERROR: from element /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0: Your GStreamer installation is missing a plug-in.
Additional debug info:
gstdecodebin2.c(3703): gst_decode_bin_expose (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0:
no suitable plugins found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

Jiří Janoušek (fenryxo) wrote :

> gst-inspect-1.0 | grep mp3
> lame: lamemp3enc: L.A.M.E. mp3 encoder
> mad: mad: mad mp3 decoder

MP3 decoder is indeed installed, ...

> GST_DEBUG="*:3,GST_ELEMENT_FACTORY:4,GST_PLUGIN_LOADING:4"
> gst-launch-1.0 playbin uri=file:///run/media/(removed rest of file path)
> Setting pipeline to PAUSED ...
> Pipeline is PREROLLING ...
> Missing element: ID3 tag demuxer
> WARNING: from element /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0: No decoder available for type 'application/x-id3'.
> Additional debug info:
> gsturidecodebin.c(880): unknown_type_cb (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0
> ERROR: from element /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0: Your GStreamer installation is missing a plug-in.
> Additional debug info:
> gstdecodebin2.c(3703): gst_decode_bin_expose (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0:
> no suitable plugins found

... but Gstreamer is still missing something. I suggest you to contact
preferred support channel of your distribution to get help with
Gstreamer 1.0 installation and configuration on your system. You can
use previous commands as a test case.

I'm closing this bug as invalid, because the issue is not caused by
Nuvola Player itself, but by a non-functional external library.

  status invalid

Changed in nuvola-player:
status: Incomplete → Invalid
Vaarnan Drolia (varnan) wrote :

I had the same problem but installing "gst-plugins-good" and "gst-plugins-ugly" resolved it.

-V

lockheed (qwrules) wrote :

I just tried your method, but it didn't help.

Andrew Azores (andrew-azores) wrote :

Working for me now!

lockheed (qwrules) wrote :

Andrew, what have you done to make it work?

Andrew Azores (andrew-azores) wrote :

I had uninstalled Nuvola some time ago. I reinstalled it along with *both* "gst-plugins-ugly" and "gst-plugins-good" packages. The -good package also pulled in several other dependencies:

aalib-1.4rc5-9
libavc1394-0.5.4-1
libcaca-0.99.beta18-
libdv-1.0.0-4
libiec61883-1.2.0-3
libraw1394-2.1.0-
wavpack-4.60.1-2
gst-plugins-good-1.0.6-1

I have tested it and both -good and -ugly are required. With neither or only either one installed the same "Could not play song. Skipped ahead" message always appears.

Jiří Janoušek (fenryxo) wrote :

I've updated FAQ #2011 to mention gst-plugins-good. Thanks for feedback.

https://answers.launchpad.net/nuvola-player/+faq/2011

Jiří Janoušek (fenryxo) wrote :

Josh Cole sent to our mailing list a story about his issues with
Gstreamer 1.0 and Nuvola Player[1]. The cause of his problems was
missing Gstreamer PulseAudio plugin. If there is anyone still affected
by this issue, could you check whether you have installed the
Gstreamer PulseAudio plugin (gstreamer1.0-pulseaudio, gst-pulseaudio
or similarly named)?

[1] https://lists.launchpad.net/nuvola-player-devel/msg00078.html

  status incomplete

Changed in nuvola-player:
status: Invalid → Incomplete
lockheed (qwrules) wrote :

I have that issue and I am using ALSA, not Pulse Audio, so I don't think PA plugin would help in any way.

Jiří Janoušek (fenryxo) wrote :

> I have that issue and I am using ALSA, not Pulse Audio, so I don't think
> PA plugin would help in any way.

Do you have installed the library /usr/lib/gstreamer-1.0/libgstalsa.so then?

lockheed (qwrules) wrote :

Yes.

Jiří Janoušek (fenryxo) wrote :

This bug report expired in Nuvola Player, because it is marked incomplete and no response was made in last 31 days. However, you can still provide missing information and set status back to "New" to reopen this bug report.

--
Sent by Primus the Bot on behalf of Jiří Janoušek

Changed in nuvola-player:
status: Incomplete → Expired
Changed in nuvola-player:
status: Expired → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers