NUnit 2.6 GUI does not generate TestResult.xml

Bug #942164 reported by Jim Arasim
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NUnit V2
Fix Released
Medium
Charlie Poole

Bug Description

I just installed NUnit 2.6, but after running one or more tests, the
GUI does not generate TestResult.xml by default anymore. I have to
select Tools -> Save Results As XML ...

Related branches

Revision history for this message
Charlie Poole (charlie.poole) wrote :

I'm not able to reproduce this error. The TestResul.xml file is saved as expected, in the same directory as the project file or test assembly.

Can you provide a specific example, including paths, where this problem arises?

Changed in nunitv2:
status: New → Incomplete
Revision history for this message
Charlie Poole (charlie.poole) wrote :

I stumbled across what may be the cause of this report. TestResult.xml was getting created in the wrong place in some cases. I have modified the code to locate it relative to the application base. In the absence of a specific example from the originator of this bug, I'm making the assumption that it's the same issue.

Changed in nunitv2:
status: Incomplete → Triaged
status: Triaged → Fix Committed
Changed in nunitv2:
importance: Undecided → Medium
assignee: nobody → Charlie Poole (charlie.poole)
milestone: none → 2.6.1rc2
Changed in nunitv2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers