Add Platform detection for .NET 4.0

Bug #422411 reported by Charlie Poole on 2009-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NUnit V2
Status tracked in Trunk
Trunk
Fix Released
Medium
Jv

Bug Description

Fix PlatformAttribute processing so that "NET-4.0" is recognized and processed correctly for inclusion and exclusion of the test.

Changed in nunitv2:
assignee: nobody → Jv (jv-ravichandran)
importance: Undecided → Medium
milestone: none → 2.5.3
status: New → Confirmed

Thanks, Charlie. I am subscribed to the bugs by email also.

I am currently generating the ssh key for launchpad using windows putty. Is
this right and required? Currently downloading the puttygen.

Please guide me on getting the latest branch of 3.0.

Jv

On 9/1/09, Charlie Poole <email address hidden> wrote:
>
> Public bug reported:
>
> Fix PlatformAttribute processing so that "NET-4.0" is recognized and
> processed correctly for inclusion and exclusion of the test.
>
> ** Affects: nunitv2
> Importance: Medium
> Assignee: Jv (jv-ravichandran)
> Status: Confirmed
>
> ** Changed in: nunitv2
> Importance: Undecided => Medium
>
> ** Changed in: nunitv2
> Status: New => Confirmed
>
> ** Changed in: nunitv2
> Milestone: None => 2.5.3
>
> ** Changed in: nunitv2
> Assignee: (unassigned) => Jv (jv-ravichandran)
>
> --
> Add Platform detection for .NET 4.0
> https://bugs.launchpad.net/bugs/422411
> You received this bug notification because you are a bug assignee.
>
> Status in NUnit V2 Test Framework: Confirmed
>
> Bug description:
> Fix PlatformAttribute processing so that "NET-4.0" is recognized and
> processed correctly for inclusion and exclusion of the test.
>

Charlie Poole (charlie.poole) wrote :

Let's not discuss help issues on the bug itself.

> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On
> Behalf Of Jv
> Sent: Monday, August 31, 2009 11:56 PM
> To: <email address hidden>
> Subject: Re: [Bug 422411] [NEW] Add Platform detection for .NET 4.0
>
> Thanks, Charlie. I am subscribed to the bugs by email also.
>
> I am currently generating the ssh key for launchpad using
> windows putty. Is this right and required? Currently
> downloading the puttygen.
>
> Please guide me on getting the latest branch of 3.0.
>
> Jv
>
>
> On 9/1/09, Charlie Poole <email address hidden> wrote:
> >
> > Public bug reported:
> >
> > Fix PlatformAttribute processing so that "NET-4.0" is
> recognized and
> > processed correctly for inclusion and exclusion of the test.
> >
> > ** Affects: nunitv2
> > Importance: Medium
> > Assignee: Jv (jv-ravichandran)
> > Status: Confirmed
> >
> > ** Changed in: nunitv2
> > Importance: Undecided => Medium
> >
> > ** Changed in: nunitv2
> > Status: New => Confirmed
> >
> > ** Changed in: nunitv2
> > Milestone: None => 2.5.3
> >
> > ** Changed in: nunitv2
> > Assignee: (unassigned) => Jv (jv-ravichandran)
> >
> > --
> > Add Platform detection for .NET 4.0
> > https://bugs.launchpad.net/bugs/422411
> > You received this bug notification because you are a bug assignee.
> >
> > Status in NUnit V2 Test Framework: Confirmed
> >
> > Bug description:
> > Fix PlatformAttribute processing so that "NET-4.0" is
> recognized and
> > processed correctly for inclusion and exclusion of the test.
> >
>
> --
> Add Platform detection for .NET 4.0
> https://bugs.launchpad.net/bugs/422411
> You received this bug notification because you are a direct
> subscriber of the bug.
>

Changed in nunitv2:
status: Confirmed → In Progress
Jv (jv-ravichandran) wrote :

Fixed. A test assembly compiled with VS.Net 2010 using .Net 4.0 can be recognized and processed by NUnit with this fix..

Charlie Poole (charlie.poole) wrote :

I think you meant your comment to be for bug 421252.

Yes, Charlie. The comment is for bug 421252.

Jv

On Thu, Sep 24, 2009 at 12:14 PM, Charlie Poole <email address hidden> wrote:

> I think you meant your comment to be for bug 421252.
>
> --
> Add Platform detection for .NET 4.0
> https://bugs.launchpad.net/bugs/422411
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in NUnit V2 Test Framework: In Progress
>
> Bug description:
> Fix PlatformAttribute processing so that "NET-4.0" is recognized and
> processed correctly for inclusion and exclusion of the test.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers