NUnit Test Adapter for VS 2012 cannot find tests when run

Bug #1203587 reported by Shawn Debnath on 2013-07-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NUnit Test Adapter
Undecided
Unassigned

Bug Description

The Test Explorer window discovers and lists the tests just fine, however, I get errors when I try to run the tets:

In the case of clicking the Run All button in Test Explorer, the error message in Output/Tests window:

------ Run test started ------
No test is available in {PATH OMITTED}.dll {PATH OMITTED}.dll. Make sure that installed test discoverers & executors, platform & framework version settings are appropriate and try again.
========== Run test finished: 0 run (0:00:00.1009842) ==========

In the case of right clicking on an individual test and clicking Run Selected Tests menu item in Test Explorer, the error message in Output/Tests window:

------ Run test started ------
Could not find test executor with URI 'executor://nunittestexecutor/'. Make sure that the test executor is installed and supports .net runtime version 4.0.30319.18051.
========== Run test finished: 0 run (0:00:00.1100552) ==========

When we use ReSharper or the console version of NUnit to run the same tests, they work fine so leads me to believe there is something wrong with the latest update of NUnit Test Adapater for Visual Studio

Info:
NUnitTestAdapter (Beta 6) Version: 0.96.0.4
NUnit Version: 2.6.2
ReSharper 8

Is there any log file or other details I can share to help with the investigation?

Thanks,
Shawn

Jim (jimf-wa) wrote :

I had the same issue as ShawnD. I have a work-around, but not cannot provide any additional insight as to why it is happening.

I started to see "Could not find test executor with URI 'executor://nunittestexecutor/'" message after I installed ReSharper8 into Vs2012 Ultimate earlier this afternoon. There isn't any other messaging in the VS2012 interface and it took me about 5 minutes to remember about the Output window | Tests to check there. When I did check, that is when I saw the test about the text executor.

At first I thought that it was because I had used ReSharper8's test manager. So I closed and reopened VS2012, cleaned and rebuilt the solution and tried to run the tests but I got the same message.

I turned off ReSharper8 (VS2012 Tools | Options | ReSharper | Suspend), which does not require restarting VS2012. Without closing VS2012, I cleaned and rebuilt the solution and tried to run the tests but I got the same message.

Next, I closed and restarted VS2012. This time, the tests ran fine.

If you need additional log files or other items for assistance in debugging, please ask.

Thanks,

Thanks for the info.

Shawn, what happens if you try this?

BTW, the URI built into the NUnit test adapter is
executor://NUnitTestExecutor - note the caps. I don't know if this is
significant, but someone might want to bring this to the attention of the
Resharper folks.

Charlie

On Sat, Jul 27, 2013 at 4:40 PM, Jim <email address hidden> wrote:

> I had the same issue as ShawnD. I have a work-around, but not cannot
> provide any additional insight as to why it is happening.
>
> I started to see "Could not find test executor with URI
> 'executor://nunittestexecutor/'" message after I installed ReSharper8
> into Vs2012 Ultimate earlier this afternoon. There isn't any other
> messaging in the VS2012 interface and it took me about 5 minutes to
> remember about the Output window | Tests to check there. When I did
> check, that is when I saw the test about the text executor.
>
> At first I thought that it was because I had used ReSharper8's test
> manager. So I closed and reopened VS2012, cleaned and rebuilt the
> solution and tried to run the tests but I got the same message.
>
> I turned off ReSharper8 (VS2012 Tools | Options | ReSharper | Suspend),
> which does not require restarting VS2012. Without closing VS2012, I
> cleaned and rebuilt the solution and tried to run the tests but I got
> the same message.
>
> Next, I closed and restarted VS2012. This time, the tests ran fine.
>
> If you need additional log files or other items for assistance in
> debugging, please ask.
>
> Thanks,
>
> --
> You received this bug notification because you are subscribed to NUnit
> Extended Testing Platform.
> https://bugs.launchpad.net/bugs/1203587
>
> Title:
> NUnit Test Adapter for VS 2012 cannot find tests when run
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nunit-vs-adapter/+bug/1203587/+subscriptions
>

Shawn Debnath (sdebnath) wrote :

Yeah, the workaround does the trick, though, of course this is not the ideal situation. Charlie, since I am not at all familiar with Visual Studio, are we sure this is a ReSharper issue because the error is reported when trying to run the tests via test explorer? If ReSharper sets the URI, could the test explorer reset it on activation? Any logs we can have to see the details of the failure to understand the issue better? Ideally we wouldn't have to disable ReSharper since its crucial for development as well. Any information would be appreciated. Thanks!

Charlie Poole (charlie.poole) wrote :

Hi Shawn,

The NUnit executor URI is in the NUnit code, so there's nothing to
reset. One hypothesis is that resharper is taking over handling the
context menu and is incorrectly invoking NUnit. However, this is just
a guess.

In any case, reporting the problem to JetBrains might get them to
fix it or, alternatively, to indicate what we need to change to be
compatible with them.

Charlie

On Sat, Jul 27, 2013 at 5:42 PM, Shawn D <email address hidden> wrote:

> Yeah, the workaround does the trick, though, of course this is not the
> ideal situation. Charlie, since I am not at all familiar with Visual
> Studio, are we sure this is a ReSharper issue because the error is
> reported when trying to run the tests via test explorer? If ReSharper
> sets the URI, could the test explorer reset it on activation? Any logs
> we can have to see the details of the failure to understand the issue
> better? Ideally we wouldn't have to disable ReSharper since its crucial
> for development as well. Any information would be appreciated. Thanks!
>
> --
> You received this bug notification because you are subscribed to NUnit
> Extended Testing Platform.
> https://bugs.launchpad.net/bugs/1203587
>
> Title:
> NUnit Test Adapter for VS 2012 cannot find tests when run
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nunit-vs-adapter/+bug/1203587/+subscriptions
>

Shawn Debnath (sdebnath) wrote :

Posted a support request with JetBrains: http://resharper-support.jetbrains.com/requests/1321. Not sure if others can see it but I will post the results back here once resolved.

Shawn Debnath (sdebnath) wrote :

Victor from ReSharper support created a YouTrack page for this issue, which you can use it to track the issue, add comments or even better, vote for it:

http://youtrack.jetbrains.com/issue/RSRP-380922

Thanks.

Charlie Poole (charlie.poole) wrote :

Thanks for the info. I'm marking this bug as needing more info for now.

On Mon, Jul 29, 2013 at 9:00 AM, Shawn <email address hidden> wrote:

> Victor from ReSharper support created a YouTrack page for this issue,
> which you can use it to track the issue, add comments or even better,
> vote for it:
>
> http://youtrack.jetbrains.com/issue/RSRP-380922
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to NUnit
> Extended Testing Platform.
> https://bugs.launchpad.net/bugs/1203587
>
> Title:
> NUnit Test Adapter for VS 2012 cannot find tests when run
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nunit-vs-adapter/+bug/1203587/+subscriptions
>

Changed in nunit-vs-adapter:
status: New → Incomplete
Charlie Poole (charlie.poole) wrote :

Turns out to be a resharper bug, which they are fixing. Too bad we have no way to track resharper bugs here on Launchpad.

Changed in nunit-vs-adapter:
status: Incomplete → Triaged
status: Triaged → Invalid
Terje Sandstrom (b-tfrje-j) wrote :

Just to follow this up:

This bugs was fixed in the 8.0.1 version.

JetBrains ReSharper 8.0.1 Full Edition
Build 8.0.1000.2286 on 2013-09-05T07:18:00

Liviu Mandras (liviu-mandras) wrote :

I am having the same issue , with

JetBrains ReSharper 8.0.2 C# Edition
Build 8.0.2000.2660 on 2013-09-27T07:18:12

And version 1.0.0.0 of the Nunit Test adapter. I I disable resharper it works ok can you please sync with jetbranins to make it work?

That bug is really not a problem of the NUnit test adapter. It also occurs on other test adapters. Only Jetbrains can fix this.

Charlie Poole (charlie.poole) wrote :

I previously marked this bug "Invalid" since it was a Resharper issue, commenting that it's too bad we can't track Jetbrains issues here on Launchpad. Since that seems to be confusing folks and since JB fixed the bug in their 8.01 release, I'm changing it to "Fix Released"

Changed in nunit-vs-adapter:
status: Invalid → Fix Released

The bug is still reproducing with resharper 8.02

Terje Sandstrom (b-tfrje-j) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers