icon package-install missing ->workaround found!

Bug #1268871 reported by Stefan on 2014-01-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Numix Circle
Undecided
Unassigned

Bug Description

After I updated this icon theme yesterday I can't run the software-center anymore.
When I run the command in terminal I get this error:

Traceback (most recent call last):
  File "/usr/bin/software-center", line 142, in <module>
    app = SoftwareCenterAppGtk3(datadir, xapian_base_path, options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 387, in __init__
    self.datadir)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 78, in __init__
    self._get_emblems(self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 192, in _get_emblems
    pb = icons.load_icon(emblem, self.ICON_SIZE, 0)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Pictogram ‘package-install’ niet beschikbaar in dit thema

The last error is in dutch; translation: "gi._glib.GError: Icon 'package-install' is not available in this theme"

When I change my icon theme I'm able to launch the software-center again.

I can launch the Software Centre just fine with Numix-Circle. :)
Do you still suffer from the issue or we can close it?

Stefan (stefanvs) wrote :

I still suffer from this bug, and am unable to run the Software Center unless I change my icontheme to "elementary"

Stefan (stefanvs) wrote :

Apparently I have this problem with most of all of my icon themes except Elementary.
In other words Elementary is the only icon theme that has this package-install icon.
find /usr/share/icons -name package-install.*

/usr/share/icons/elementary/actions/16/package-install.svg

These are my currently installed icons:
ls /usr/share/icons -w 1 -d */

default/
default.kde4/
DMZ-Black/
DMZ-White/
elementary/
gnome/
handhelds/
hicolor/
Numix/
Numix-Circle/
oxygen/
redglass/
ubuntu-mono-dark/
ubuntu-mono-light/
/usr/share/icons
whiteglass/

Wait, you wanna tell me it doesn't run even with ubuntu-mono-dark (or light)?

This is quite concerning. It could be an ElementaryOS-specific problem, in which case you should report the bug here: https://launchpad.net/elementaryos

All applications should have their icons stored in /usr/share/app-install/icons . Check to see if the elementaryOS software center icon is there. If not, then this is likely to be an elementaryOS bug.

Most likely it is not a numix bug, because if it doesn't start with ubuntu-mono-dark / light it is bug in your distro or something siw wrong with your install.
If it does start with the ubuntu icon themes please change the status from "won't fix", but if it does, it is not a not a numix for for the Ubuntu Software Centre is Ubuntu application and must run with the ubuntu icon themes.

Changed in numix-icon-theme-circle:
status: New → Won't Fix
Tobias Niemeier (o4u9wm3n) wrote :

There is a simple workaround for this issue:
Just go to /usr/share/icons. All your icons should be listed here.
Go into the dir "Numix" for example, there should be a file named index.theme.
Open this file as Administrator with scratch, vi, or whatever texteditor you prefer.
In ther line "Inherits=..." add "elementary," before "gnome"
Usually this line should then look like this:
"Inherits=elementary,gnome,hicolor"

If I'm not mistaken, this should mean that, if an icon is missing, the icon pack "elementary" is searched for this icon.

For me, this fixed the problem with software-center.

This should be applicable for the other icon-packs as well.

Stefan (stefanvs) wrote :

Thank you Tobias! That worked like a charm!

summary: - icon package-install missing
+ icon package-install missing ->workaround found!
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers