Memory upgrade makes Ubuntu painfully slow

Bug #816035 reported by Hans Meier on 2011-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
grub2 (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
linux (Ubuntu)
Low
Andy Whitcroft
Oneiric
Low
Andy Whitcroft

Bug Description

When upgrading the system memory of an Acer Veriton 1000 from 1GB to 2GB, the Ubuntu 11.04 operating system becomes unusable slow. The problem is reproducible and only occurrs when both memory modules are inserted (operation in dual-channel mode). When booting from the live CD the problem does not occur, only when booting the operating system from hard disk after installation. When booting from the live CD, the hard drive can also be mounted and accessed with normal performance.

 The following diagnostic steps have already been performed:

- upgraded system BIOS to latest version available
- tried different memory modules (same outcome)
- run memtest86 (all memory ok)
- run ubuntu and other Linux from live CD (works ok)
- installed Windows XP on hard drive (boots and runs with normal performance)
- installed Fedora Linux 15 on hard drive (boots and runs with normal performance)

More information:
- Performance is already very slow at the Ubuntu Grub Bootloader Menu (before OS kernel is loaded): takes about 20 seconds to draw the main screen, 20 more seconds to draw the edit screen when using "e" button on a grub list element
- Besides the very poor performance no errors are shown; OS can also be booted in about 10mins (instead of 30 seconds when only one mem module is inserted)
- When OS is booted, bottleneck seems to be disk I/O, but hard disk activity is only very low; no kernel / system errors visible, system responsiveness also ok as long as no disk access happens.

I suspect Ubuntu to apply some special settings already at GRUB bootloader level when installing to a hard drive, or access memory in a special way. These "settings" seem not to be compatible with the systems dual channel memory access mode.

Please inform me when any additional information is required, I'll be glad to provide.

Kind regards,
H.

Hans Meier (freedriv3r) on 2011-07-25
affects: ubuntuone-dev-tools → ubuntu-community
Hans Meier (freedriv3r) wrote :

I could not find a project to attach this issue to, looking for someone with knowledge about Ubuntu bootloader concept / details.

affects: ubuntu-community → null
Changed in null:
status: New → Invalid

Can you provide the output of the following commands both when the system is booted with 1GB and when booted with 2GB?

dmesg
lshw -C memory

Hans Meier (freedriv3r) wrote :
Hans Meier (freedriv3r) wrote :
Hans Meier (freedriv3r) wrote :
Hans Meier (freedriv3r) wrote :
Hans Meier (freedriv3r) wrote :

Attached the output of dmesg and lshw. Thanks for looking into this!

Changed in null:
status: Invalid → New
status: New → Invalid
Hans Meier (freedriv3r) wrote :

Similar problems here (http://ubuntuforums.org/showthread.php?t=276648) and here (http://ubuntuforums.org/showthread.php?t=355730); in both cases the solution appeared to be a bios upgrade. Unfortunately this did not solve the problem for me; also won't explain why Ubuntu seems to be the only OS having problems with the current hardware configuration.

Hans Meier (freedriv3r) wrote :

Additional remark: I noticed slight differences in the kernel log regarding console mode initialization:

Console: colour dummy device 80x25 (when 1G)
vs.
Console: colour VGA+ 80x25 (when 2G).

When disabling the graphical terminal in GRUB (GRUB_TERMINAL=console), grub actually runs at normal speed again; but the subsequent OS startup process remains unchanged slow (probably because console mode is changed again). There appears to be some correlation between the presence of 2GB memory/dual channel access and the selected video mode; I however do not understand what is going at low level, possibly a bug in system BIOS. Can someone help or offer a workaround?

Andy Whitcroft (apw) wrote :

filed this against grub2/linux as it is likely those are the packages which can help diagnose this issue.

affects: ubuntu → grub2 (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 816035

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: natty
Andy Whitcroft (apw) wrote :

Marking confirmed as we have what we need at this point.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Hans Meier (freedriv3r) wrote :

As suggested by apw, I booted the system with "enable_mtrr_cleanup" and "mtrr_cleanup_debug", and the system performance was normal. Attached the dmesg.

Andy Whitcroft (apw) wrote :

I am suspicious that the following mtrrs though reasonable looking are actually the issue:

[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 000000000 mask F80000000 write-back
[ 0.000000] 1 base 07E800000 mask FFF000000 uncachable
[ 0.000000] 2 base 07F800000 mask FFF800000 uncachable
[ 0.000000] 3 base 07E700000 mask FFFF00000 uncachable

Note that 1 and 2 overlap, this is normally a situation which triggers 'undefined' behaviour including doing utterly the wrong thing. We should try booting with enable_mtrr_cleanup and see if that helps any.

Hans Meier (freedriv3r) wrote :
Andy Whitcroft (apw) wrote :

It turns out that the enable_mtrr_cleanup is effectivly always enabled in FC12 and later, hense that boots quickly.

Hans Meier (freedriv3r) wrote :

Maybe this kernel setting should be enabled by default in Ubuntu Linux as well. For GRUB the problem still exists, but can be worked around by re-installing GRUB with setting "GRUB_TERMINAL=console" (in /etc/default/grub). This puts GRUB into simple text mode which (in my case at least) does not cause any problems.

Thanks to apw for analyzing this and offering a solution!

Tim Gardner (timg-tpi) on 2011-07-26
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → In Progress
Andy Whitcroft (apw) on 2011-07-26
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-7.9

---------------
linux (3.0.0-7.9) oneiric; urgency=low

  [ Andy Whitcroft ]

  * Revert "[Upstream] add local prefix to oss local change_bits"
  * Revert "SAUCE: add tracing for user initiated readahead requests"
  * Revert "SAUCE: vfs: Add a trace point in the mark_inode_dirty function"
  * Revert "SAUCE: Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47"
  * Revert "SAUCE: fix documentation strings for struct input_keymap_entry"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range checks
    (grub)"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range
    checks"
  * Revert "SAUCE: vt -- allow grub to request automatic vt_handoff"
  * Revert "SAUCE: vt -- maintain bootloader screen mode and content until
    vt switch"
  * [Config] enable CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT=1
    - LP: #816035
  * ubuntu: Yama: if an underlying filesystem provides a permissions op use
    it
  * SAUCE: (no-up) add tracing for user initiated readahead requests
  * SAUCE: vt -- maintain bootloader screen mode and content until vt
    switch
  * SAUCE: vt -- allow grub to request automatic vt_handoff

  [ Arjan van de Ven ]

  * SAUCE: (no-up) vfs: Add a trace point in the mark_inode_dirty function

  [ Kees Cook ]

  * Revert "SAUCE: (no-up) Disable building the ACPI debugfs source"
  * [Config] enforce ACPI_CUSTOM_METHOD disabled

  [ Keng-Yu Lin ]

  * SAUCE: (no-up) Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47
    - LP: #632884, #803005

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_BLK_DEV_CMD64X=m on powerpc
    - LP: #513131
  * [Config] Enable CONFIG_RT2800PCI_RT53XX=y
    - LP: #815064

  [ Rezwanul Kabir ]

  * SAUCE: (no-up) Add support for Intellimouse Mode in ALPS touchpad on
    Dell E2 series Laptops
    - LP: #632884

  [ Upstream Kernel Changes ]

  * Revert "yama: if an underlying filesystem provides a permissions op use
    it"
  * Revert "Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops"
  * Revert "tty: include linux/slab.h for kfree"
  * Revert "gpio/ml_ioh_gpio: include linux/slab.h for kfree"
  * Revert "pch_dma: add include/slab.h for kfree"
  * mmc: Added quirks for Ricoh 1180:e823 lower base clock frequency
    - LP: #773524
  * oss: rename local change_bits to avoid powerpc bitsops.h definition
 -- Leann Ogasawara <email address hidden> Mon, 25 Jul 2011 09:08:01 -0700

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) wrote :

Discussing this in IRC we decided to enable this option for Oneiric to see if there are any regressions (upload above).

papukaija (papukaija) on 2011-09-06
tags: removed: 1000 channel dual grub io memory upgrade veriton
Benjamin Kerensa (bkerensa) wrote :

Notably this bug if flagged as Oneiric when the reporter indicates it is a 11.04 bug.

Changed in grub2 (Ubuntu):
status: New → Invalid
Changed in grub2 (Ubuntu Oneiric):
status: New → Invalid
bananenkasper (bananenkasper) wrote :

I expiriencing this issue on an up-to-date Oneiric if RAM goes behond 20gb.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers