Existing systray causes unity to crash (gnome panel conflict): Unity keeps reloading on my system and get white background...

Bug #578585 reported by Jorge on 2010-05-11
126
This bug affects 23 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
Unity
Fix Released
Medium
Didier Roche
gnome-session (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

My system is a Dell Latitude D531 running Ubuntu Lucid (10.04) 64bits; I installed Ubuntu Unity without problem but when I tried to log in using it the GUI keeps reloading and I only can get out by pressing "Ctrl + Alt + Supr" and choosing "Restart".

Curtis Hovey (sinzui) on 2010-05-11
affects: launchpad → null
Changed in null:
status: New → Invalid
Jani Uusitalo (uusijani) wrote :

This affects me too, if by the "reloading" Jorge means that the top and right panels are stuck in an endless loop of disappearing and reappearing. Doesn't respond to mouse clicks either; no other way to exit than to switch to another VT and killall gnome-session.

I created a new test user to make sure it's nothing in my settings and he's affected too.

Jani Uusitalo (uusijani) wrote :
Jani Uusitalo (uusijani) wrote :

Sorry, meant my other right, the left panel in the above, of course. :)

Didier Roche (didrocks) wrote :

Thanks for testing unity and giving some feedbacks there:

Can you try to run the GNOME session (logout and in gdm, choose the GNOME session), and then run in a terminal:
$ mutter --mutter-plugins=/usr/lib/mutter/plugins/libunity-mutter.so.0 --replace
and paste there the traces, please?

Changed in ubuntu:
status: New → Invalid
Changed in unity:
status: New → Incomplete

Dear Didier,

Please find attached the output for your command:

jsalazar@jsalazar-laptop:~$ mutter
--mutter-plugins=/usr/lib/mutter/plugins/libunity-mutter.so.0 --replace
GConf-WARNING: gconf_engine_notify_add: You can't use a GConfEngine that
has an active GConfClient wrapper object. Use GConfClient API instead.

Window manager warning: Log level 8: unity_plugin_topmost_changed:
assertion `old_window != NULL' failed
Window manager warning: Broken client! Window 0x4800030 (mutter) changed
client leader window or SM client ID
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX
1.3 is not supported! This is an application bug!
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Indicator-Sound-DEBUG: At start-up attempting to set the image to
audio-volume-muted-panel

Window manager warning: Log level 16: /build/buildd/gtk
+2.0-2.20.0/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property
named `x-ayatana-indicator-dynamic'
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
Window manager warning: Log level 128: Connected to Application
Indicator Service.
Window manager warning: Log level 128: Setup proxy signals
Window manager warning: Log level 128: Connect to them.
Window manager warning: Log level 128: Request current apps
Bug in window manager: Unexpected X error: BadWindow (invalid Window
parameter) serial 4691 error_code 3 request_code 147 minor_code 1)
Aborted
jsalazar@jsalazar-laptop:~$

BR,

PD. Please let us know your comments about it; thanks a lot in advance!

--
Jorge Salazar
ZyXEL Costa Rica

On Tue, 2010-05-11 at 09:24 +0000, Didier Roche wrote:
> Thanks for testing unity and giving some feedbacks there:
>
> Can you try to run the GNOME session (logout and in gdm, choose the GNOME session), and then run in a terminal:
> $ mutter --mutter-plugins=/usr/lib/mutter/plugins/libunity-mutter.so.0 --replace
> and paste there the traces, please?
>
> ** Changed in: ubuntu
> Status: New => Invalid
>
> ** Changed in: unity
> Status: New => Incomplete
>

Confirmed on on my Sony VAIO VGN-N150G (recently updated Ubuntu Lucid (10.04) 32bit).

Laudeci Oliveira (laudeci) wrote :

This bug is affecting me either. same problem on a Dell Vostro 1520

Curtis Hovey (sinzui) wrote :

My attached sinzui0mutter.log is a good summary of the repative errors in my .xsession-errors

I note that I can gnome-shell without error.

Neil J. Patel (njpatel) wrote :

I think this bug is because the gnome-panel is persisting in the Unity session. For a quick test, try and export UNITY_DISABLE_TRAY=1 or remove the systray from the panel and try again to run Unity. I'll try and get a fix uploaded sometime today.

Didier Roche (didrocks) wrote :

You maybe got the gnome panel because you have a saved session. Can you uncheck the option in session menu on GNOME to say "I don't want to save session" and then remove ~/.config/gnome-session/saved-session. Logout and try to log back to unity.

Nick Bishop (thndrkat) wrote :

This bug is affecting me, too. Toshiba NB305 (UNE works great, btw, thanks!)

A few points.

Please, keep in mind that I am a recent convert to ubuntu, although I am quite familiar with the Unix environment. Also, I have a co-worker who is very familiar with Linux/Ubuntu, and he was helping me considerably. Any technical questions can be answered, but they might require longer-than-normal time.

I didn't experience this problem until I tried dragging the Appearances icon (I know, I shouldn't have done this, but I realized that afterwards) to the Launcher. Unity immediately started exhibiting the problems described by the OP.

We discovered that if you start the window manager from the command-line everything works correctly. However, when you start it from gdm it returns to the bad behavior.

This is the command we used to restart:

mutter --display=:0.0 --replace&

Also, with it restarted and working, if you try to drag a new application onto the launcher it breaks again in the same fashion. Replacing the window manager again fixes it again, but the new icon is not available.

Right now, it works. Don't dare restart...I'm happy to help in any way, just please have patience!

Didier Roche (didrocks) wrote :

Thanks for testing unity and helping to make it better.

@Nick: did you try to remove the directory I've pointed into my previous comment, it seems to be related to what you describe.
If you still experience this issue (and to report other issues), fell free and welcome to open a new bugs. Thanks a lot :)

Switching it to triaged and make a better title

Didier Roche (didrocks) on 2010-05-15
summary: - Ubuntu Unity keeps reloading on my system ...
+ Ubuntu Unity keeps reloading on my system and get white background...
Changed in unity:
status: Incomplete → Triaged

@Didier:

Thanks for your prompt response! I checked that directory, but it was empty. Would you like me to open a new bug? My problem is essentially the same as the bug description explains.

Nick

Pierre (pieter-vanh) wrote :

Have the same problem when I mouse over on the right "taskbar" it reloads
Top bar and search works fine

~/.config/gnome-session/saved-session folder is also empty

Didier Roche (didrocks) wrote :

@Nick: where your issue occurs, can you please try in a terminal ps aux | grep gnome-panel to see if gnome-panel is running?

@Pierre: I guess your issue is quite different, can you please open a new bug?

Nick Bishop (thndrkat) wrote :

@Didier: okay, so I loaded Unity, started seeing the bug immediately, then ran the ps from a terminal and I do not see the gnome-panel process running.

Didier Roche (didrocks) wrote :

Ok, it seems we have two bugs there, one with gnome-panel conflicting and another one with something else.
Can you please open a new bug with ubuntu-bug and reporting every needed hw info, please? I'll edit this title to make it obvious and to track the two bugs.

summary: - Ubuntu Unity keeps reloading on my system and get white background...
+ gnome panel conflict: Unity keeps reloading on my system and get white
+ background...

@Didier: I apologize for the delay-I was on vacation last week. I've tried running the ubuntu-bug utility, but I cannot get it to work correctly. If I try to run "ubuntu-bug unity" in normal UNE, it won't find it. Alt-F2 will not open the "Run Application" window in my semi-working Unity environment. Is there an alternative method of reporting this bug?

Didier Roche (didrocks) wrote :

@Nick: You can open a terminal in the launcher (I guess I've added one item there) and by triggering Ctrl + Alt + T. Another solution will be to wait for maverick alpha 1 and report the bug from the live CD directly.

Nick Bishop (thndrkat) wrote :

@Didier: Okay, I give up. I was able to get the ubuntu-bug utility to launch, and when it sent me to the launchpad site, I get all the way through the process of submitting the bug, then I get a timeout error that prohibits me from adding the bug. I'll try it again later when I get home in case the problem is with my work's wi-fi connection.

I can confirm this behaviour on a Samsung NC10.

Deleting ~/.config/gnome-session/saved-session has an effect, the same flashing background occurs but the Ubuntu log in sound plays before entering the cycle.

Running "mutter --replace", all is well but if I then run unity, or issue "Running mutter --mutter-plugins=/usr/lib/mutter/plugins/libunity-mutter.so.0 --replace" I get:

(unity:4943): Gdk-WARNING **: /build/buildd/gtk+2.0-2.20.1/gdk/x11/gdkdrawable-x11.c:942 drawable is not a native X11 window
The program 'unity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 516 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

dart (dart-v85) wrote :

i found the solution for this....pate this line on the top of the file .profile....export CLUTTER_VBLANK=none.............n your done....enjoy the new interface

Nick Bishop (thndrkat) wrote :

I have confirmed that dartttt's solution does in fact solve the issue, but I have not tested it extensively. Does this assist the Unity team in resolving this issue? Let me know if any additional testing needs to be performed.

dart (dart-v85) wrote :

vblank feature is not present in all graphic cards...so for those graphic cards that do not support vblank...this tweak is useful....vblank prevents visual tearing

Ngassam Nkwenga (cyrildz) wrote :

here is my setting :

Laptop : Amilo Li1718
Graphic card : ATI Xpress 200M
Distribution : Maverick Daily-live current
I've nothing installed else als ubuntu-restricted-extras.

I can't try unity , from the console: unity comes and go.

from GDM, the desktop keeps on reloading, with whitebackground,I have to use Ctrl+ Alt + Screenprint +k togo back and choose gnome.

do I need something else to be installed ?

adamthecamper (adamthecamper) wrote :

Ok, export CLUTTER_VBLANK=none fixed it for me, so I guess it is graphicscard/configuration problem.

Ngassam Nkwenga (cyrildz) wrote :

I tried "export CLUTTER_VBLANK=none" but this did nothing

I have the same behaviour too when the daily build of the maverick netbook

Ngassam Nkwenga (cyrildz) wrote :

Hi, I made the update and I still have the same issues, I can't start Unity.
I tried the Ubuntu Netbook Edition alpha and still have the same issues.
I don't know what to try now to have it working.

Omer Akram (om26er) wrote :

opened an Ubuntu task.

affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: Invalid → Triaged
GuyR (guy-rouger) wrote :

Hello all,
I am affected tooon Desktop Acer Aspire T650 when trying to use the Maverick Netbook: once log in the session the screen is blinking.
NB: in the same condition it was working perfectly with Lucid Netbook
Best Regards
Guy

GuyR (guy-rouger) wrote :
Download full text (13.4 KiB)

guy@lynx-netbook:~$ mutter --mutter-plugins=/usr/lib/mutter/plugins/libunity-mutter.so.0 --replace
Window manager warning: Log level 16: invalid (NULL) pointer instance
Window manager warning: Log level 8: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Window manager warning: Log level 8: mutter_window_mapped: assertion `!priv->mapped' failed

(mutter:1562): libunity-private-WARNING **: scroller-controller.vala:350: Could not find controller for given view: A scroller child; running: yes, active: no, position: 0,000000, opacity 255,000000

(mutter:1562): libunity-private-WARNING **: scroller-controller.vala:350: Could not find controller for given view: A scroller child; running: yes, active: yes, position: 42,000000, opacity 255,000000
Window manager warning: Log level 16: Unable to find the file menu stock item
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: invalid (NULL) pointer instance
Window manager warning: Log level 8: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Window manager warning: Log level 16: invalid (NULL) pointer instance
Window manager warning: Log level 8: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
(mutter:1562): Indicator-Sound-DEBUG: At start-up attempting to set the image to audio-volume-muted-panel
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 128: Guessing max time width: 61
Window manager warning: Log level 16: invalid (NULL) pointer instance
Window manager warning: Log level 8: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Window manager warning: Log level 16: invalid (NULL) pointer instance
Window manager warning: Log level 8: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: Log level 16: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Log level 128: Switching to windows from XID 67109116
Window manager warning: Log level 16: gtk_menu_detach(): menu is not attached
Window manager warni...

Ngassam Nkwenga (cyrildz) wrote :

here is my results:

Given the desire that we have for people who are running the normal
desktop to find it easy to try out Unity, it is worth investing some
time into researching the cause of this bug. There will be a LOT of
people who have existing Gnome Panel and Gnome Session settings and try
the Unity session; we don't want them to have a crashy experience.

Mark

@Mark: I think there are two bugs there seeting the stacktrace of people. That's why I tried to create this on titling ("gnome panel conflict"). The other bug is the VBlank one and driver/graphical card not supporting it.

I think for this one, unity should kill gnome-panel at start, this will handle as well:
- people saving their session in the GNOME session and switching then to the unity session (gnome-panel is saved in the registered session)
- people starting unity in their GNOME session to have a try.

or either, unity don't crash in the old-system-tray code.

summary: - gnome panel conflict: Unity keeps reloading on my system and get white
- background...
+ Existing systray causes unity to crash (gnome panel conflict): Unity
+ keeps reloading on my system and get white background...
Ngassam Nkwenga (cyrildz) wrote :

Hi I tried again Unity and there is still the same issue. I tried to run it via gdb and Unity exited with code 0377.
I hope it will help

Ngassam Nkwenga (cyrildz) wrote :

here is the debug info I tried to obtain from gdb, since Unity stopped may be the debug infos are not relevant.

Vish (vish) wrote :

Same problem with an ATI Mobility Radeon X1400 [ http://paste.ubuntu.com/476843/ ]

glxinfo : http://paste.ubuntu.com/476865/

None of the workarounds work:
- Dint have any saved session, and removing the folder dint help.
- adding export CLUTTER_VBLANK=none to the .profile didnt help either.

Vish (vish) wrote :

Also tried removing the systray from the panel , didnt help either.

Meng Jiao (meng1usa) wrote :

issue: white screen after boot

confirm: adding export CLUTTER_VBLANK=none to the .profile solved my problem.

Didier Roche (didrocks) wrote :

We decided to kill gnome-panel for people storing their session at start.

Changed in unity:
importance: Undecided → Medium
assignee: nobody → Didier Roche (didrocks)
milestone: none → 2010-09-22
Didier Roche (didrocks) wrote :

we will fix that in gnome-session

affects: unity (Ubuntu) → gnome-session (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.31.6-0ubuntu2

---------------
gnome-session (2.31.6-0ubuntu2) maverick; urgency=low

  * debian/patches/24_filter_autosaved_application_for_une.patch:
    don't start gnome-panel, metacity/compiz from saved session in UNE.
    This is a current workaround to LP: #578585. A correct fix
    will be to integrate a migration path, excluding all
    required_components from the saved list before starting them.
    It fixes (LP: #620427, #641256) as the applets aren't loaded.
 -- Didier Roche <email address hidden> Tue, 21 Sep 2010 15:38:47 +0200

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-09-22
Changed in unity:
status: Triaged → Fix Released
stinky (stinkiestshirt) wrote :

This also effects me too on my Panasonic Toughbook CF-72 in Ubuntu 10.10.

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers